diff options
Diffstat (limited to 'recipes-bsp/cppi-lld/cppi-lld-test_git.bb')
-rwxr-xr-x | recipes-bsp/cppi-lld/cppi-lld-test_git.bb | 26 |
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-bsp/cppi-lld/cppi-lld-test_git.bb b/recipes-bsp/cppi-lld/cppi-lld-test_git.bb new file mode 100755 index 00000000..871546e3 --- /dev/null +++ b/recipes-bsp/cppi-lld/cppi-lld-test_git.bb | |||
@@ -0,0 +1,26 @@ | |||
1 | DESCRIPTION = "TI CPPI low level driver unit test and example binaries" | ||
2 | COMPATIBLE_MACHINE = "keystone" | ||
3 | DEPENDS = "common-csl-ip rm-lld cppi-lld qmss-lld" | ||
4 | |||
5 | include cppi-lld.inc | ||
6 | |||
7 | CHOICELIST = "yes no" | ||
8 | |||
9 | do_compile () { | ||
10 | # Now build the lld in the updated directory | ||
11 | for device in ${DEVICELIST} | ||
12 | do | ||
13 | make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" CPPI_SRC_DIR=${S} | ||
14 | for choice in ${CHOICELIST} | ||
15 | do | ||
16 | make -f makefile_armv7 tests examples PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" CPPI_SRC_DIR=${S} USEDYNAMIC_LIB="$choice" | ||
17 | done | ||
18 | done | ||
19 | } | ||
20 | |||
21 | do_install () { | ||
22 | for device in ${DEVICELIST} | ||
23 | do | ||
24 | make -f makefile_armv7 installbin PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" CPPI_SRC_DIR=${S} INSTALL_BIN_BASE_DIR=${D}${bindir} | ||
25 | done | ||
26 | } | ||