summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/cmem/cmem-mod_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/cmem/cmem-mod_git.bb')
-rw-r--r--recipes-bsp/cmem/cmem-mod_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-bsp/cmem/cmem-mod_git.bb b/recipes-bsp/cmem/cmem-mod_git.bb
index d36816b5..bf6a4770 100644
--- a/recipes-bsp/cmem/cmem-mod_git.bb
+++ b/recipes-bsp/cmem/cmem-mod_git.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Kernel module for contiguous memory allocation from userspace"
3include cmem.inc 3include cmem.inc
4 4
5# This package builds a kernel module, use kernel PR as base and append a local 5# This package builds a kernel module, use kernel PR as base and append a local
6MACHINE_KERNEL_PR_append = "b" 6MACHINE_KERNEL_PR_append = "c"
7PR = "${MACHINE_KERNEL_PR}" 7PR = "${MACHINE_KERNEL_PR}"
8 8
9inherit module 9inherit module
@@ -12,3 +12,7 @@ EXTRA_OEMAKE += '-f lu.mak KERNEL_INSTALL_DIR="${STAGING_KERNEL_DIR}" TOOLCHAIN_
12MAKE_TARGETS = "module" 12MAKE_TARGETS = "module"
13 13
14KERNEL_MODULE_AUTOLOAD += "cmemk" 14KERNEL_MODULE_AUTOLOAD += "cmemk"
15
16do_install_prepend() {
17 cp ${B}/src/cmem/module/Module.symvers ${B}/ || true
18}