summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/am33x-cm3/am33x-cm3_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/am33x-cm3/am33x-cm3_git.bb')
-rw-r--r--recipes-bsp/am33x-cm3/am33x-cm3_git.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/recipes-bsp/am33x-cm3/am33x-cm3_git.bb b/recipes-bsp/am33x-cm3/am33x-cm3_git.bb
new file mode 100644
index 00000000..42f20da4
--- /dev/null
+++ b/recipes-bsp/am33x-cm3/am33x-cm3_git.bb
@@ -0,0 +1,55 @@
1DESCRIPTION = "Cortex-M3 binary blob for suspend-resume"
2
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://License.txt;md5=7bdc54a749ab7a7dea999d25d99a41b8"
5
6PV = "05.00.00.03"
7PR = "r1"
8
9# Make package machine specific due to different init scripts
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11
12# SRCREV corresponds to tag v05.00.00.03
13SRCREV = "a0ddffb63147e2079a08944c0e399c75538201a9"
14BRANCH ?= "master"
15
16# This init script is only used for older kernels that do not support
17# hotplug of the firmware. Newer kernels do not require the initscript
18# package.
19INITSCRIPT_NAME = "am335x-pm-firmware-load"
20INITSCRIPT_PARAMS = "defaults 96"
21
22inherit update-rc.d
23
24UPDATERCPN = "${PN}-initscript"
25
26RDEPENDS_${PN}-initscript = "am33x-cm3"
27
28SRC_URI = "git://arago-project.org/git/projects/am33x-cm3.git;protocol=git;branch=${BRANCH} \
29 file://init-am33x-cm3 \
30 file://init-am43x-cm3 \
31 "
32
33SCRIPT_ti33x = "init-am33x-cm3"
34SCRIPT_ti43x = "init-am43x-cm3"
35
36S = "${WORKDIR}/git"
37
38do_compile() {
39 make CROSS_COMPILE="${TARGET_PREFIX}"
40}
41
42do_install() {
43 install -d ${D}${base_libdir}/firmware
44 install -m 0644 bin/am335x-pm-firmware.bin ${D}${base_libdir}/firmware/
45
46 # Install the init script to load the PM firmware at boot
47 install -d ${D}${sysconfdir}/init.d
48 install -m 0755 ${WORKDIR}/${SCRIPT} ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
49}
50
51PACKAGES =+ "${PN}-initscript"
52
53FILES_${PN} += "${base_libdir}/firmware"
54
55FILES_${PN}-initscript = "${sysconfdir}/*"