summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras/recipes-ti/uio-test-pruss/uio-test-pruss_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-extras/recipes-ti/uio-test-pruss/uio-test-pruss_git.bb')
-rw-r--r--meta-ti-extras/recipes-ti/uio-test-pruss/uio-test-pruss_git.bb38
1 files changed, 0 insertions, 38 deletions
diff --git a/meta-ti-extras/recipes-ti/uio-test-pruss/uio-test-pruss_git.bb b/meta-ti-extras/recipes-ti/uio-test-pruss/uio-test-pruss_git.bb
deleted file mode 100644
index d9a420d8..00000000
--- a/meta-ti-extras/recipes-ti/uio-test-pruss/uio-test-pruss_git.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1DESCRIPTION = "Provides test pruss firmware for uio based tests"
2LICENSE = "BSD-3-Clause"
3PV = "1.0.2.0"
4require recipes-ti/includes/ti-paths.inc
5
6S = "${WORKDIR}/git"
7
8DEPENDS = "ti-cgt-pru-native"
9
10BRANCH = "master"
11LIC_FILES_CHKSUM = "file://Makefile;startline=1;endline=31;md5=0ee4f2c42eb6b04e37859bb55a18b144"
12
13UIO_TEST_PRUSS_GIT_URI = "git://git.ti.com/git/processor-sdk/uio-test-pruss.git"
14UIO_TEST_PRUSS_GIT_PROTOCOL = "https"
15SRC_URI = "${UIO_TEST_PRUSS_GIT_URI};protocol=${UIO_TEST_PRUSS_GIT_PROTOCOL};branch=${BRANCH}"
16
17# Corresponds to version 01.00.02.00
18UIO_TEST_PRUSS_SRCREV = "e52a7b099d7203ca52519650df51419e9fef7e0c"
19
20SRCREV = "${UIO_TEST_PRUSS_SRCREV}"
21
22PR = "r0"
23
24COMPATIBLE_MACHINE = "omap-a15|ti33x|ti43x"
25
26PACKAGE_ARCH = "${MACHINE_ARCH}"
27
28DEVICE_NAME = ""
29DEVICE_NAME:append:am57xx-evm = "am57xx"
30DEVICE_NAME:append:ti33x = "am33xx"
31DEVICE_NAME:append:ti43x = "am43xx"
32
33EXTRA_OEMAKE = "CGT_PRU=${TI_CGT_PRU_INSTALL_DIR} DEVICE=${DEVICE_NAME}"
34
35do_install() {
36 install -d ${D}${bindir}/
37 cp -r *.bin ${D}${bindir}/
38}