summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras/recipes-ti/beagleboard/beaglebone-getting-started.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-extras/recipes-ti/beagleboard/beaglebone-getting-started.bb')
-rw-r--r--meta-ti-extras/recipes-ti/beagleboard/beaglebone-getting-started.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-ti/beagleboard/beaglebone-getting-started.bb b/meta-ti-extras/recipes-ti/beagleboard/beaglebone-getting-started.bb
new file mode 100644
index 00000000..25538ace
--- /dev/null
+++ b/meta-ti-extras/recipes-ti/beagleboard/beaglebone-getting-started.bb
@@ -0,0 +1,21 @@
1SUMMARY = "BeagleBone Getting Started Guide"
2
3PR = "r22"
4
5inherit allarch
6
7LICENSE = "CC-BY-SA-3.0 & GPLv3+ & MIT & PD"
8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f6f02761e31334c48f7021fb94c89aaa"
9
10SRCREV = "05bedba192646152b7bc80b0accaea75aef864e5"
11SRC_URI = "git://github.com/jadonk/beaglebone-getting-started.git;protocol=https;branch=master"
12
13S = "${WORKDIR}/git"
14
15do_install() {
16 install -d ${D}${datadir}/${PN}
17 cp -R --no-dereference --preserve=mode,links ${S}/* ${D}${datadir}/${PN}
18}
19
20FILES:${PN} += "${datadir}/${PN}"
21INSANE_SKIP:${PN} = "file-rdeps"