summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb')
-rw-r--r--meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb b/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
new file mode 100644
index 00000000..168e4be3
--- /dev/null
+++ b/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Interface for GDB to commincate witha TI C66X DSP"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING.txt;md5=75859989545e37968a99b631ef42722e"
4
5# This package builds a kernel module, use kernel PR as base and append a local
6MACHINE_KERNEL_PR:append = "b"
7PR = "${MACHINE_KERNEL_PR}"
8PV:append = "+git${SRCPV}"
9
10S = "${WORKDIR}/git/kernel_module/gdbproxy-mod"
11
12inherit module
13
14PLATFORM = ""
15PLATFORM:dra7xx = "DRA7xx_PLATFORM"
16
17EXTRA_OEMAKE = "PLATFORM=${PLATFORM} KVERSION=${KERNEL_VERSION} KERNEL_SRC=${STAGING_KERNEL_DIR}"
18
19# The following is to prevent an unused configure.ac from erroneously
20# triggering the QA check for gettext.
21EXTRA_OECONF = "--disable-nls"
22do_configure() {
23 :
24}
25
26COMPATIBLE_MACHINE = "dra7xx"
27PACKAGE_ARCH = "${MACHINE_ARCH}"
28
29include gdbc6x.inc
30
31KERNEL_MODULE_AUTOLOAD += "gdbserverproxy"