summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp')
-rw-r--r--meta-ti-bsp/conf/machine/am62axx-evm-k3r5-gp.conf19
-rw-r--r--meta-ti-bsp/conf/machine/am62axx-evm-k3r5-hs-fs.conf14
-rw-r--r--meta-ti-bsp/conf/machine/am62axx-evm-k3r5-hs-se.conf22
-rw-r--r--meta-ti-bsp/conf/machine/am62axx-evm-k3r5.conf11
-rw-r--r--meta-ti-bsp/conf/machine/am62axx-evm.conf4
-rw-r--r--meta-ti-bsp/conf/machine/include/am62axx.inc15
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb4
7 files changed, 75 insertions, 14 deletions
diff --git a/meta-ti-bsp/conf/machine/am62axx-evm-k3r5-gp.conf b/meta-ti-bsp/conf/machine/am62axx-evm-k3r5-gp.conf
new file mode 100644
index 00000000..962413c3
--- /dev/null
+++ b/meta-ti-bsp/conf/machine/am62axx-evm-k3r5-gp.conf
@@ -0,0 +1,19 @@
1#@TYPE: Machine
2#@NAME: AM62A GP EVM (R5F)
3#@DESCRIPTION: Machine configuration for the TI AM62A GP EVM (R5F core)
4
5require conf/machine/include/k3r5.inc
6
7SYSFW_SOC = "am62ax"
8SYSFW_CONFIG = "evm"
9SYSFW_SUFFIX = "gp"
10
11SYSFW_TIBOOT3_SYMLINK = ""
12SYSFW_SYMLINK = ""
13
14UBOOT_MACHINE = "am62ax_evm_r5_defconfig"
15
16SPL_BINARY = ""
17UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}"
18UBOOT_IMAGE = "u-boot-r5spl-gp-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
19UBOOT_SYMLINK = "u-boot-r5spl-gp.${UBOOT_SUFFIX}"
diff --git a/meta-ti-bsp/conf/machine/am62axx-evm-k3r5-hs-fs.conf b/meta-ti-bsp/conf/machine/am62axx-evm-k3r5-hs-fs.conf
new file mode 100644
index 00000000..256f021a
--- /dev/null
+++ b/meta-ti-bsp/conf/machine/am62axx-evm-k3r5-hs-fs.conf
@@ -0,0 +1,14 @@
1#@TYPE: Machine
2#@NAME: AM62A HS-FS EVM (R5F)
3#@DESCRIPTION: Machine configuration for the TI AM62A HS-FS EVM (R5F core)
4
5# Booting HS-FS requires different SYSFW, the rest is handled at runtime
6
7require conf/machine/include/k3r5.inc
8SOC_FAMILY:append = ":k3r5-hs-fs"
9
10SYSFW_SOC = "am62ax"
11SYSFW_CONFIG = "evm"
12SYSFW_SUFFIX = "hs-fs"
13
14UBOOT_MACHINE = "am62ax_evm_r5_defconfig"
diff --git a/meta-ti-bsp/conf/machine/am62axx-evm-k3r5-hs-se.conf b/meta-ti-bsp/conf/machine/am62axx-evm-k3r5-hs-se.conf
new file mode 100644
index 00000000..c7cb0681
--- /dev/null
+++ b/meta-ti-bsp/conf/machine/am62axx-evm-k3r5-hs-se.conf
@@ -0,0 +1,22 @@
1#@TYPE: Machine
2#@NAME: AM62A HS-SE EVM (R5F)
3#@DESCRIPTION: Machine configuration for the TI AM62A HS-SE EVM (R5F core)
4
5# Booting HS-SE requires different SYSFW, the rest is handled at runtime
6
7require conf/machine/include/k3r5.inc
8SOC_FAMILY:append = ":k3r5-hs-se"
9
10SYSFW_SOC = "am62ax"
11SYSFW_CONFIG = "evm"
12SYSFW_SUFFIX = "hs"
13
14SYSFW_TIBOOT3_SYMLINK = ""
15SYSFW_SYMLINK = ""
16
17UBOOT_MACHINE = "am62ax_evm_r5_defconfig"
18
19SPL_BINARY = ""
20UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}"
21UBOOT_IMAGE = "u-boot-r5spl-hs-se-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
22UBOOT_SYMLINK = "u-boot-r5spl-hs-se.${UBOOT_SUFFIX}"
diff --git a/meta-ti-bsp/conf/machine/am62axx-evm-k3r5.conf b/meta-ti-bsp/conf/machine/am62axx-evm-k3r5.conf
deleted file mode 100644
index ca30537f..00000000
--- a/meta-ti-bsp/conf/machine/am62axx-evm-k3r5.conf
+++ /dev/null
@@ -1,11 +0,0 @@
1#@TYPE: Machine
2#@NAME: AM62AXX EVM (R5F)
3#@DESCRIPTION: Machine configuration for the TI AM62Axx EVM (R5F core)
4
5require conf/machine/include/k3r5.inc
6
7SYSFW_SOC = "am62ax"
8SYSFW_CONFIG = "evm"
9SYSFW_SUFFIX = "gp"
10
11UBOOT_MACHINE = "am62ax_evm_r5_defconfig"
diff --git a/meta-ti-bsp/conf/machine/am62axx-evm.conf b/meta-ti-bsp/conf/machine/am62axx-evm.conf
index 4eb179f3..5e11d19b 100644
--- a/meta-ti-bsp/conf/machine/am62axx-evm.conf
+++ b/meta-ti-bsp/conf/machine/am62axx-evm.conf
@@ -9,3 +9,7 @@ KERNEL_DEVICETREE = " \
9" 9"
10 10
11UBOOT_MACHINE = "am62ax_evm_a53_defconfig" 11UBOOT_MACHINE = "am62ax_evm_a53_defconfig"
12
13SPL_BINARY = "tispl.bin_HS"
14UBOOT_BINARY = "u-boot.img_HS"
15UBOOT_SYMLINK = "u-boot.img"
diff --git a/meta-ti-bsp/conf/machine/include/am62axx.inc b/meta-ti-bsp/conf/machine/include/am62axx.inc
index cc477366..d0970948 100644
--- a/meta-ti-bsp/conf/machine/include/am62axx.inc
+++ b/meta-ti-bsp/conf/machine/include/am62axx.inc
@@ -8,8 +8,19 @@ SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
8 8
9TFA_K3_SYSTEM_SUSPEND = "1" 9TFA_K3_SYSTEM_SUSPEND = "1"
10 10
11do_image_wic[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy" 11# Default tiboot3.bin on AM62A is for HS-FS
12do_image_tar[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy" 12BBMULTICONFIG = "k3r5-hs-fs"
13do_image_wic[mcdepends] = "mc::k3r5-hs-fs:ti-sci-fw:do_deploy"
14
15# Since default tiboot3.bin on AM62A is for HS-FS, add a version for GP
16BBMULTICONFIG += "k3r5-gp"
17IMAGE_BOOT_FILES += "tiboot3-am62ax-gp-evm.bin"
18do_image_wic[mcdepends] += "mc::k3r5-gp:ti-sci-fw:do_deploy"
19
20# Since default tiboot3.bin on AM62A is for HS-FS, add a version for HS-SE
21BBMULTICONFIG += "k3r5-hs-se"
22IMAGE_BOOT_FILES += "tiboot3-am62ax-hs-evm.bin"
23do_image_wic[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy"
13 24
14TFA_BOARD = "lite" 25TFA_BOARD = "lite"
15OPTEEMACHINE = "k3-am62x" 26OPTEEMACHINE = "k3-am62x"
diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 18153d37..5fb16642 100644
--- a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -44,7 +44,9 @@ SYSFW_PREFIX:am62xx-evm-k3r5-hs-fs = "fs"
44SYSFW_PREFIX:am62xx-lp-evm-k3r5 = "fs" 44SYSFW_PREFIX:am62xx-lp-evm-k3r5 = "fs"
45SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs" 45SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs"
46SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-fs = "fs" 46SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-fs = "fs"
47SYSFW_PREFIX:am62axx-evm-k3r5 = "fs" 47SYSFW_PREFIX:am62axx-evm-k3r5-gp = "fs"
48SYSFW_PREFIX:am62axx-evm-k3r5-hs-fs = "fs"
49SYSFW_PREFIX:am62axx-evm-k3r5-hs-se = "fs"
48 50
49SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin" 51SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin"
50 52