diff options
Diffstat (limited to 'meta-ti-bsp')
-rw-r--r-- | meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc | 1 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb | 23 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc | 4 |
3 files changed, 28 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc b/meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc index 3ebdae30..47e76347 100644 --- a/meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc +++ b/meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc | |||
@@ -18,6 +18,7 @@ GOODIX_FW_VERSION = "1.0.0.0" | |||
18 | CADENCE_MHDP_FW_VERSION = "1.2.17" | 18 | CADENCE_MHDP_FW_VERSION = "1.2.17" |
19 | IMG_DEC_FW_VERSION = "1.0" | 19 | IMG_DEC_FW_VERSION = "1.0" |
20 | CNM_WAVE521_FW_VERSION = "1.0.00" | 20 | CNM_WAVE521_FW_VERSION = "1.0.00" |
21 | TIFS_LPM_STUB_FW_VERSION = "08.03.02" | ||
21 | 22 | ||
22 | TI_LINUX_FW_SRCREV ?= "917625c2721eef8677df9e47d919005b0d4f93aa" | 23 | TI_LINUX_FW_SRCREV ?= "917625c2721eef8677df9e47d919005b0d4f93aa" |
23 | SRCREV = "${TI_LINUX_FW_SRCREV}" | 24 | SRCREV = "${TI_LINUX_FW_SRCREV}" |
diff --git a/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb b/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb new file mode 100644 index 00000000..90af55f1 --- /dev/null +++ b/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | SUMMARY = "TI Foundational security Low Power Management Stub" | ||
2 | |||
3 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc | ||
4 | |||
5 | PV = "${TIFS_LPM_STUB_FW_VERSION}" | ||
6 | PR = "${INC_PR}.0" | ||
7 | |||
8 | CLEANBROKEN = "1" | ||
9 | |||
10 | COMPATIBLE_MACHINE = "am62xx-evm" | ||
11 | |||
12 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | TARGET = "ti-fs-stub-firmware-am62x-gp-signed.bin" | ||
17 | |||
18 | do_install() { | ||
19 | install -d ${D}${nonarch_base_libdir}/firmware/ti-sysfw/ | ||
20 | install -m 0644 ${S}/ti-sysfw/${TARGET} ${D}${nonarch_base_libdir}/firmware/ti-sysfw/${TARGET} | ||
21 | } | ||
22 | |||
23 | FILES:${PN} = "${nonarch_base_libdir}/firmware" | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc index 8ceae8a1..bb2c1a00 100644 --- a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc +++ b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc | |||
@@ -28,3 +28,7 @@ RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j7 = " vxd-dec-fw" | |||
28 | 28 | ||
29 | # Add run-time dependency for Chips&Media Wave521 firmware to the rootfs | 29 | # Add run-time dependency for Chips&Media Wave521 firmware to the rootfs |
30 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2-evm = " cnm-wave-fw" | 30 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2-evm = " cnm-wave-fw" |
31 | |||
32 | # Add run-time dependency for TIFS Low Power Module stub | ||
33 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am62xx-evm = " tifs-lpm-stub" | ||
34 | |||