diff options
Diffstat (limited to 'meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb')
-rw-r--r-- | meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb | 63 |
1 files changed, 63 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb b/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb new file mode 100644 index 00000000..01b857c2 --- /dev/null +++ b/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb | |||
@@ -0,0 +1,63 @@ | |||
1 | DESCRIPTION = "TI Inter Process Communication (IPC) Mechanisms (for Uni- and Multi- Processor Configurations)" | ||
2 | HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC" | ||
3 | |||
4 | require ti-ipc.inc | ||
5 | require ti-ipc-common.inc | ||
6 | |||
7 | PR = "${INC_PR}.2" | ||
8 | |||
9 | DEPENDS += "virtual/kernel" | ||
10 | |||
11 | SRC_URI += "file://tiipclad-daemon.sh \ | ||
12 | file://omap_remoteproc.conf \ | ||
13 | file://tiipclad-daemon.service \ | ||
14 | file://0001-Add-kernel-build-dir.patch \ | ||
15 | " | ||
16 | |||
17 | DAEMON = "UNKNOWN" | ||
18 | DAEMON:dra7xx = "lad_dra7xx" | ||
19 | DAEMON:omapl138 = "lad_omapl138" | ||
20 | |||
21 | inherit autotools-brokensep pkgconfig update-rc.d systemd | ||
22 | |||
23 | INITSCRIPT_NAME = "tiipclad-daemon.sh" | ||
24 | INITSCRIPT_PARAMS = "defaults 10" | ||
25 | |||
26 | SYSTEMD_SERVICE:${PN} = "tiipclad-daemon.service" | ||
27 | |||
28 | EXTRA_OECONF += "PLATFORM=${PLATFORM} KERNEL_INSTALL_DIR=${STAGING_KERNEL_DIR} KERNEL_BUILD_DIR=${STAGING_KERNEL_BUILDDIR}" | ||
29 | |||
30 | do_compile[depends] += "virtual/kernel:do_shared_workdir" | ||
31 | |||
32 | do_configure() { | ||
33 | ( cd ${S}; autoreconf -f -i -s ) | ||
34 | oe_runconf | ||
35 | } | ||
36 | |||
37 | do_install:append() { | ||
38 | install -d ${D}${sysconfdir}/init.d/ | ||
39 | |||
40 | # Modify the startup scripts to point to the right | ||
41 | # lad daemon executable. | ||
42 | sed -i -e "s/__LAD_DAEMON__/${DAEMON}/" ${WORKDIR}/tiipclad-daemon.sh | ||
43 | sed -i -e "s/__LAD_DAEMON__/${DAEMON}/" ${WORKDIR}/tiipclad-daemon.service | ||
44 | |||
45 | install -d ${D}${systemd_system_unitdir} | ||
46 | install -m 0644 ${WORKDIR}/tiipclad-daemon.service ${D}${systemd_system_unitdir} | ||
47 | install -d ${D}${sysconfdir}/init.d/ | ||
48 | install -c -m 755 ${WORKDIR}/tiipclad-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
49 | } | ||
50 | |||
51 | do_install:append:dra7xx() { | ||
52 | install -d ${D}${sysconfdir}/modprobe.d/ | ||
53 | install -c -m 644 ${WORKDIR}/omap_remoteproc.conf ${D}${sysconfdir}/modprobe.d/ | ||
54 | } | ||
55 | |||
56 | PACKAGES =+ "${PN}-test" | ||
57 | RDEPENDS:${PN}-test += "${PN}" | ||
58 | |||
59 | FILES:${PN}-test = " \ | ||
60 | ${bindir}/NameServerApp \ | ||
61 | ${bindir}/MessageQApp \ | ||
62 | ${bindir}/MessageQMulti \ | ||
63 | ${bindir}/ping_rpmsg" | ||