summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp/recipes-ti/ipc/ti-ipc-examples-linux_git.bb')
-rw-r--r--meta-ti-bsp/recipes-ti/ipc/ti-ipc-examples-linux_git.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-ti/ipc/ti-ipc-examples-linux_git.bb b/meta-ti-bsp/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
new file mode 100644
index 00000000..81706592
--- /dev/null
+++ b/meta-ti-bsp/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running bios"
2require ti-ipc-examples.inc
3
4SRC_URI += "file://0001-examples-ClusterMgr-sys_errlist-has-been-deprecated-.patch;patchdir=../git/ipc-examples"
5
6DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native"
7
8do_compile:append() {
9
10 if [ "${PLATFORM}" != "UNKNOWN" ]; then
11 oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
12
13 if [ ! -z ${ALT_PLATFORM} ]; then
14 oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="linux" \
15 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
16 fi
17 oe_runmake -C examples all HOSTOS="linux" \
18 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
19 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
20
21 if [ ! -z ${ALT_PLATFORM} ]; then
22 oe_runmake -C examples all HOSTOS="linux" \
23 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
24 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
25 PLATFORM="${ALT_PLATFORM}"
26 fi
27 fi
28}
29
30do_install:append() {
31 cd ${S_ipc-examples}/src
32
33 if [ "${PLATFORM}" != "UNKNOWN" ]; then
34 # Install directory for linux examples
35 install -d ${D}${bindir}/ipc/examples
36 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
37 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
38 HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples"
39
40 if [ ! -z ${ALT_PLATFORM} ]; then
41 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
42 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
43 HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples" \
44 PLATFORM="${ALT_PLATFORM}"
45 fi
46 fi
47}
48
49FILES:${PN} += "${bindir}/*"