summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-security
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp/recipes-security')
-rw-r--r--meta-ti-bsp/recipes-security/optee/optee-os_3.16%.bbappend10
1 files changed, 3 insertions, 7 deletions
diff --git a/meta-ti-bsp/recipes-security/optee/optee-os_3.16%.bbappend b/meta-ti-bsp/recipes-security/optee/optee-os_3.16%.bbappend
index 2aa34530..7772c58e 100644
--- a/meta-ti-bsp/recipes-security/optee/optee-os_3.16%.bbappend
+++ b/meta-ti-bsp/recipes-security/optee/optee-os_3.16%.bbappend
@@ -9,13 +9,6 @@ EXTRA_OEMAKE:append:k3 = "${@ ' CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') i
9EXTRA_OEMAKE:append:am62xx = " CFG_TEE_CORE_LOG_LEVEL=1" 9EXTRA_OEMAKE:append:am62xx = " CFG_TEE_CORE_LOG_LEVEL=1"
10EXTRA_OEMAKE:append:am62axx = " CFG_TEE_CORE_LOG_LEVEL=1" 10EXTRA_OEMAKE:append:am62axx = " CFG_TEE_CORE_LOG_LEVEL=1"
11 11
12do_compile:append:k3() {
13 ( cd ${B}/core/; \
14 cp tee-pager_v2.bin ${B}/bl32.bin; \
15 cp tee.elf ${B}/bl32.elf; \
16 )
17}
18
19# Signing procedure for legacy HS devices 12# Signing procedure for legacy HS devices
20optee_sign_legacyhs() { 13optee_sign_legacyhs() {
21 ( cd ${B}/core/; \ 14 ( cd ${B}/core/; \
@@ -46,12 +39,14 @@ do_compile:append:dra7xx() {
46# Signing procedure for K3 devices 39# Signing procedure for K3 devices
47do_compile:append:k3() { 40do_compile:append:k3() {
48 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ${B}/core/tee-pager_v2.bin ${B}/bl32.bin 41 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ${B}/core/tee-pager_v2.bin ${B}/bl32.bin
42 cp ${B}/core/tee-pager_v2.bin ${B}/bl32.bin.unsigned
49 cp ${B}/core/tee.elf ${B}/bl32.elf 43 cp ${B}/core/tee.elf ${B}/bl32.elf
50} 44}
51 45
52do_install:append:ti-soc() { 46do_install:append:ti-soc() {
53 install -m 644 ${B}/*.optee ${D}${nonarch_base_libdir}/firmware/ || true 47 install -m 644 ${B}/*.optee ${D}${nonarch_base_libdir}/firmware/ || true
54 install -m 644 ${B}/bl32.bin ${D}${nonarch_base_libdir}/firmware/ || true 48 install -m 644 ${B}/bl32.bin ${D}${nonarch_base_libdir}/firmware/ || true
49 install -m 644 ${B}/bl32.bin.unsigned ${D}${nonarch_base_libdir}/firmware/ || true
55 install -m 644 ${B}/bl32.elf ${D}${nonarch_base_libdir}/firmware/ || true 50 install -m 644 ${B}/bl32.elf ${D}${nonarch_base_libdir}/firmware/ || true
56} 51}
57 52
@@ -72,6 +67,7 @@ do_deploy:append:dra7xx() {
72 67
73do_deploy:append:k3() { 68do_deploy:append:k3() {
74 ln -sf optee/bl32.bin ${DEPLOYDIR}/ 69 ln -sf optee/bl32.bin ${DEPLOYDIR}/
70 ln -sf optee/bl32.bin.unsigned ${DEPLOYDIR}/
75 ln -sf optee/bl32.elf ${DEPLOYDIR}/ 71 ln -sf optee/bl32.elf ${DEPLOYDIR}/
76} 72}
77 73