summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp/recipes-kernel')
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb7
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/ti-extras.inc14
2 files changed, 18 insertions, 3 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
index 0b36575b..688b8690 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
@@ -9,6 +9,7 @@ require recipes-kernel/linux/setup-defconfig.inc
9require recipes-kernel/linux/kernel-rdepends.inc 9require recipes-kernel/linux/kernel-rdepends.inc
10require recipes-kernel/linux/ti-kernel.inc 10require recipes-kernel/linux/ti-kernel.inc
11include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''} 11include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''}
12include ${@ 'recipes-kernel/linux/ti-extras.inc' if d.getVar('TI_EXTRAS') else ''}
12 13
13DEPENDS += "gmp-native libmpc-native" 14DEPENDS += "gmp-native libmpc-native"
14 15
@@ -20,16 +21,16 @@ KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT} \
20 21
21S = "${WORKDIR}/git" 22S = "${WORKDIR}/git"
22 23
23BRANCH = "ti-linux-6.1.y" 24BRANCH ?= "ti-linux-6.1.y"
24 25
25SRCREV = "7124dee9779a40c52c52331c3ba6ccc84f357380" 26SRCREV ?= "7124dee9779a40c52c52331c3ba6ccc84f357380"
26PV = "6.1.26+git${SRCPV}" 27PV = "6.1.26+git${SRCPV}"
27 28
28# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild 29# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
29MACHINE_KERNEL_PR:append = "b" 30MACHINE_KERNEL_PR:append = "b"
30PR = "${MACHINE_KERNEL_PR}" 31PR = "${MACHINE_KERNEL_PR}"
31 32
32KERNEL_GIT_URI = "git://git.ti.com/git/ti-linux-kernel/ti-linux-kernel.git" 33KERNEL_GIT_URI ?= "git://git.ti.com/git/ti-linux-kernel/ti-linux-kernel.git"
33KERNEL_GIT_PROTOCOL = "https" 34KERNEL_GIT_PROTOCOL = "https"
34SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \ 35SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \
35 file://defconfig" 36 file://defconfig"
diff --git a/meta-ti-bsp/recipes-kernel/linux/ti-extras.inc b/meta-ti-bsp/recipes-kernel/linux/ti-extras.inc
new file mode 100644
index 00000000..2bb88b13
--- /dev/null
+++ b/meta-ti-bsp/recipes-kernel/linux/ti-extras.inc
@@ -0,0 +1,14 @@
1
2# Use different commit, repo and branch for TI extras build
3# This will have priority over generic rt path
4
5COMPATIBLE_MACHINE = "am62xx"
6
7BRANCH = "ti-linux-6.1.y"
8BRANCH:tie-jailhouse = "ti-linux-6.1.y-jailhouse"
9
10SRCREV = "30bcc25e7cb1b25667db88d61828728f0f0b5f4b"
11SRCREV:tie-jailhouse = "0ed0dec2462b805b0188fe080895adc437871549"
12
13KERNEL_GIT_URI = "git://git.ti.com/git/processor-sdk/linux.git"
14