summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb')
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
new file mode 100644
index 00000000..1a0ec5df
--- /dev/null
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
@@ -0,0 +1,51 @@
1SECTION = "kernel"
2SUMMARY = "Linux kernel for TI devices"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
5
6inherit kernel
7
8DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh"
9require recipes-kernel/linux/setup-defconfig.inc
10require recipes-kernel/linux/cmem.inc
11require recipes-kernel/linux/ti-uio.inc
12require recipes-kernel/linux/bundle-devicetree.inc
13require recipes-kernel/linux/kernel-rdepends.inc
14require recipes-kernel/linux/ti-kernel.inc
15
16# Look in the generic major.minor directory for files
17FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-5.10:"
18
19KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT} \
20 ${EXTRA_DTC_ARGS}"
21
22S = "${WORKDIR}/git"
23
24BRANCH = "ti-linux-5.10.y"
25
26SRCREV = "dcc6bedb2c2bdb509709e4ae08303206e95ce6c2"
27PV = "5.10.65+git${SRCPV}"
28
29# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
30MACHINE_KERNEL_PR:append = "b"
31PR = "${MACHINE_KERNEL_PR}"
32
33KERNEL_GIT_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git"
34KERNEL_GIT_PROTOCOL = "git"
35SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \
36 file://defconfig"
37
38FILES:${KERNEL_PACKAGE_NAME}-devicetree += "/${KERNEL_IMAGEDEST}/*.itb"
39
40# Special configuration for remoteproc/rpmsg IPC modules
41module_conf_rpmsg_client_sample = "blacklist rpmsg_client_sample"
42module_conf_ti_k3_r5_remoteproc = "softdep ti_k3_r5_remoteproc pre: virtio_rpmsg_bus"
43module_conf_ti_k3_dsp_remoteproc = "softdep ti_k3_dsp_remoteproc pre: virtio_rpmsg_bus"
44KERNEL_MODULE_PROBECONF += "rpmsg_client_sample ti_k3_r5_remoteproc ti_k3_dsp_remoteproc"
45KERNEL_MODULE_AUTOLOAD:append:j7 = " rpmsg_kdrv_switch"
46
47# Disable SA2UL for AM64x HS and J7200 HS
48module_conf_sa2ul:am64xx-hs-evm = "blacklist sa2ul"
49KERNEL_MODULE_PROBECONF:append:am64xx-hs-evm = " sa2ul"
50module_conf_sa2ul:j7200-hs-evm = "blacklist sa2ul"
51KERNEL_MODULE_PROBECONF:append:j7200-hs-evm = " sa2ul"