diff options
Diffstat (limited to 'meta-ti-bsp/recipes-devtools')
8 files changed, 252 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-devtools/gdbc6x/gdbc6x.inc b/meta-ti-bsp/recipes-devtools/gdbc6x/gdbc6x.inc new file mode 100644 index 00000000..eeb18fb1 --- /dev/null +++ b/meta-ti-bsp/recipes-devtools/gdbc6x/gdbc6x.inc | |||
@@ -0,0 +1,9 @@ | |||
1 | # This corresponds to version 1.1.0 | ||
2 | SRCREV = "dd0c82fb5763a6b32dc6d68e561efb66ab8283d7" | ||
3 | |||
4 | PV = "1.1.0" | ||
5 | INC_PR = "r7" | ||
6 | |||
7 | SRC_URI = "git://git.ti.com/sdo-emu/gdbc6x.git;protocol=git;branch=${BRANCH}" | ||
8 | |||
9 | BRANCH = "master" | ||
diff --git a/meta-ti-bsp/recipes-devtools/gdbc6x/gdbc6x/0001-libbfd.h-suppress-GCC9-Wstringop-truncation.patch b/meta-ti-bsp/recipes-devtools/gdbc6x/gdbc6x/0001-libbfd.h-suppress-GCC9-Wstringop-truncation.patch new file mode 100644 index 00000000..1cc23b32 --- /dev/null +++ b/meta-ti-bsp/recipes-devtools/gdbc6x/gdbc6x/0001-libbfd.h-suppress-GCC9-Wstringop-truncation.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 0aa294e2bbd37a42266e59cb67687e57bfba4a88 Mon Sep 17 00:00:00 2001 | ||
2 | From: Denys Dmytriyenko <denys@ti.com> | ||
3 | Date: Sat, 15 Feb 2020 15:59:37 -0500 | ||
4 | Subject: [PATCH] libbfd.h: suppress GCC9 -Wstringop-truncation | ||
5 | |||
6 | Signed-off-by: Denys Dmytriyenko <denys@ti.com> | ||
7 | --- | ||
8 | gdbc6x/bfd/libbfd.h | 4 ++++ | ||
9 | 1 file changed, 4 insertions(+) | ||
10 | |||
11 | diff --git a/gdbc6x/bfd/libbfd.h b/gdbc6x/bfd/libbfd.h | ||
12 | index 72d3c50..3465f89 100644 | ||
13 | --- a/gdbc6x/bfd/libbfd.h | ||
14 | +++ b/gdbc6x/bfd/libbfd.h | ||
15 | @@ -34,6 +34,10 @@ | ||
16 | #pragma GCC diagnostic ignored "-Wcast-function-type" | ||
17 | #endif | ||
18 | |||
19 | +#if __GNUC__ >= 9 | ||
20 | +#pragma GCC diagnostic ignored "-Wstringop-truncation" | ||
21 | +#endif | ||
22 | + | ||
23 | #include "hashtab.h" | ||
24 | |||
25 | /* Align an address upward to a boundary, expressed as a number of bytes. | ||
26 | -- | ||
27 | 2.7.4 | ||
28 | |||
diff --git a/meta-ti-bsp/recipes-devtools/gdbc6x/gdbc6x/init b/meta-ti-bsp/recipes-devtools/gdbc6x/gdbc6x/init new file mode 100644 index 00000000..90210b82 --- /dev/null +++ b/meta-ti-bsp/recipes-devtools/gdbc6x/gdbc6x/init | |||
@@ -0,0 +1,48 @@ | |||
1 | #!/bin/bash | ||
2 | |||
3 | GDB_DEVICE_NAME='/dev/gdbtty$i' | ||
4 | DSP_FIRMWARE_NAME='/lib/firmware/dra7-dsp$[$i+1]-fw.xe66' | ||
5 | |||
6 | DSP_L2_GLOBAL_OFFSET="40000000" | ||
7 | DSP_L2_GLOBAL_SHIFT="00800000" | ||
8 | |||
9 | case "$1" in | ||
10 | start) | ||
11 | |||
12 | dsp_core_l2_offset=$DSP_L2_GLOBAL_OFFSET | ||
13 | |||
14 | i=0 | ||
15 | while [ -c "`eval echo $GDB_DEVICE_NAME`" ] | ||
16 | do | ||
17 | dsp_firmware=`eval echo $DSP_FIRMWARE_NAME` | ||
18 | |||
19 | if [ -f "`eval echo $DSP_FIRMWARE_NAME`" ] | ||
20 | then | ||
21 | eval echo "Initializing $GDB_DEVICE_NAME based on $DSP_FIRMWARE_NAME ..." | ||
22 | |||
23 | gdb_data_local=`eval readelf -s "$DSP_FIRMWARE_NAME" | \ | ||
24 | grep 'gdb_globalData' | \ | ||
25 | awk '{print $2}'` | ||
26 | |||
27 | echo "gdb_globalData (local) = $gdb_data_local" | ||
28 | printf "gdb_globalData (global) = %X\n" \ | ||
29 | $[0x$gdb_data_local + 0x$dsp_core_l2_offset] | ||
30 | |||
31 | |||
32 | printf "%X\n" $[0x$gdb_data_local + 0x$dsp_core_l2_offset] \ | ||
33 | >> `eval echo $GDB_DEVICE_NAME` | ||
34 | fi | ||
35 | i=$[$i + 1] | ||
36 | dsp_core_l2_offset=`printf "%X" $[0x$dsp_core_l2_offset + 0x$DSP_L2_GLOBAL_SHIFT]` | ||
37 | done | ||
38 | ;; | ||
39 | stop) | ||
40 | # Nothing to be done. | ||
41 | ;; | ||
42 | *) | ||
43 | echo "Usage: $0 {start|stop}" | ||
44 | exit 1 | ||
45 | ;; | ||
46 | esac | ||
47 | |||
48 | |||
diff --git a/meta-ti-bsp/recipes-devtools/gdbc6x/gdbc6x_git.bb b/meta-ti-bsp/recipes-devtools/gdbc6x/gdbc6x_git.bb new file mode 100644 index 00000000..df9aaee9 --- /dev/null +++ b/meta-ti-bsp/recipes-devtools/gdbc6x/gdbc6x_git.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | DESCRIPTION = "GNU debugger for TI C6X DSP." | ||
2 | SECTION = "devel" | ||
3 | LICENSE = "GPLv3+" | ||
4 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=bf0fe2872eb3dfeebb2cbe38206fe81f" | ||
5 | |||
6 | DEPENDS = "ncurses bison-native texinfo flex-native gettext" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "dra7xx" | ||
9 | |||
10 | PR = "${INC_PR}.1" | ||
11 | |||
12 | SRC_URI:append = " \ | ||
13 | file://init \ | ||
14 | file://0001-libbfd.h-suppress-GCC9-Wstringop-truncation.patch;striplevel=2 \ | ||
15 | " | ||
16 | |||
17 | S = "${WORKDIR}/git/gdbc6x" | ||
18 | |||
19 | inherit update-rc.d | ||
20 | inherit gettext | ||
21 | |||
22 | CFLAGS += "-fcommon" | ||
23 | |||
24 | do_configure () { | ||
25 | cd ${S} | ||
26 | ./configure --program-suffix=c6x --target=tic6x-elf-tirtos --host=${HOST_SYS} --prefix=${S}/install_gdb | ||
27 | } | ||
28 | |||
29 | do_install () { | ||
30 | make install | ||
31 | |||
32 | # Custom install to prevent conflict with standard GDB. | ||
33 | install -d ${D}${bindir} | ||
34 | install -d ${D}${includedir} | ||
35 | install -m 755 ${S}/install_gdb/bin/gdbc6x ${D}${bindir} | ||
36 | cp -rf ${S}/install_gdb/include/* ${D}${includedir} | ||
37 | |||
38 | install -d ${D}${sysconfdir}/init.d | ||
39 | install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/gdbserverproxy | ||
40 | } | ||
41 | |||
42 | RDEPENDS:${PN} = "gdbserverproxy-module-drv bash" | ||
43 | |||
44 | include gdbc6x.inc | ||
45 | |||
46 | INITSCRIPT_NAME = "gdbserverproxy" | ||
47 | INITSCRIPT_PARAMS = "defaults 95" | ||
48 | |||
49 | PARALLEL_MAKE = "" | ||
diff --git a/meta-ti-bsp/recipes-devtools/gdbc6x/gdbserver-c6x_git.bb b/meta-ti-bsp/recipes-devtools/gdbc6x/gdbserver-c6x_git.bb new file mode 100644 index 00000000..fab4fbd2 --- /dev/null +++ b/meta-ti-bsp/recipes-devtools/gdbc6x/gdbserver-c6x_git.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | DESCRIPTION = "TI gdb-server to be used with c6xgdb." | ||
2 | LICENSE = "BSD" | ||
3 | LIC_FILES_CHKSUM = "file://../debian/copyright;md5=82c616b6c8f9c11c46feaaf8f9a11495" | ||
4 | |||
5 | DEPENDS = "ti-xdais ti-framework-components ti-cgt6x-native ti-sysbios ti-xdctools-native" | ||
6 | |||
7 | PR = "${INC_PR}.0" | ||
8 | |||
9 | S = "${WORKDIR}/git/gdbserver-c6x/src" | ||
10 | |||
11 | PLATFORM = "" | ||
12 | PLATFORM:dra7xx = "DRA7xx_PLATFORM" | ||
13 | |||
14 | EXTRA_OEMAKE = "PLATFORM=${PLATFORM}" | ||
15 | |||
16 | export XDAIS_DIR = "${XDAIS_INSTALL_DIR}" | ||
17 | export FC_DIR = "${FC_INSTALL_DIR}" | ||
18 | export TI_CGT_INSTALL = "${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" | ||
19 | export BIOS_DIR = "${SYSBIOS_INSTALL_DIR}" | ||
20 | export XDC_DIR = "${XDC_INSTALL_DIR}" | ||
21 | |||
22 | # The following is to prevent an unused configure.ac from erroneously | ||
23 | # triggering the QA check for gettext. | ||
24 | EXTRA_OECONF = "--disable-nls" | ||
25 | do_configure() { | ||
26 | : | ||
27 | } | ||
28 | |||
29 | do_install() { | ||
30 | install -d ${D}${datadir}/ti/gdbc6x/include | ||
31 | install -d ${D}${datadir}/ti/gdbc6x/lib | ||
32 | cp -f ../include/* ${D}${datadir}/ti/gdbc6x/include | ||
33 | cp -f ../lib/* ${D}${datadir}/ti/gdbc6x/lib | ||
34 | } | ||
35 | |||
36 | COMPATIBLE_MACHINE = "dra7xx" | ||
37 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
38 | |||
39 | FILES:${PN}-dev += "\ | ||
40 | ${datadir}/ti/gdbc6x \ | ||
41 | " | ||
42 | |||
43 | include gdbc6x.inc | ||
44 | |||
45 | require recipes-ti/includes/ti-paths.inc | ||
46 | |||
47 | ALLOW_EMPTY:${PN} = "1" | ||
48 | |||
49 | PARALLEL_MAKE = "" | ||
diff --git a/meta-ti-bsp/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb b/meta-ti-bsp/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb new file mode 100644 index 00000000..168e4be3 --- /dev/null +++ b/meta-ti-bsp/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | DESCRIPTION = "Interface for GDB to commincate witha TI C66X DSP" | ||
2 | LICENSE = "GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=75859989545e37968a99b631ef42722e" | ||
4 | |||
5 | # This package builds a kernel module, use kernel PR as base and append a local | ||
6 | MACHINE_KERNEL_PR:append = "b" | ||
7 | PR = "${MACHINE_KERNEL_PR}" | ||
8 | PV:append = "+git${SRCPV}" | ||
9 | |||
10 | S = "${WORKDIR}/git/kernel_module/gdbproxy-mod" | ||
11 | |||
12 | inherit module | ||
13 | |||
14 | PLATFORM = "" | ||
15 | PLATFORM:dra7xx = "DRA7xx_PLATFORM" | ||
16 | |||
17 | EXTRA_OEMAKE = "PLATFORM=${PLATFORM} KVERSION=${KERNEL_VERSION} KERNEL_SRC=${STAGING_KERNEL_DIR}" | ||
18 | |||
19 | # The following is to prevent an unused configure.ac from erroneously | ||
20 | # triggering the QA check for gettext. | ||
21 | EXTRA_OECONF = "--disable-nls" | ||
22 | do_configure() { | ||
23 | : | ||
24 | } | ||
25 | |||
26 | COMPATIBLE_MACHINE = "dra7xx" | ||
27 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
28 | |||
29 | include gdbc6x.inc | ||
30 | |||
31 | KERNEL_MODULE_AUTOLOAD += "gdbserverproxy" | ||
diff --git a/meta-ti-bsp/recipes-devtools/ion/libion_git.bb b/meta-ti-bsp/recipes-devtools/ion/libion_git.bb new file mode 100644 index 00000000..f5ca8e82 --- /dev/null +++ b/meta-ti-bsp/recipes-devtools/ion/libion_git.bb | |||
@@ -0,0 +1,14 @@ | |||
1 | SUMMARY = "ION Userspace Memory Allocator Library" | ||
2 | HOMEPAGE = "https://github.com/glneo/libion" | ||
3 | LICENSE = "Apache-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" | ||
5 | |||
6 | PV = "1.0.0" | ||
7 | |||
8 | BRANCH = "master" | ||
9 | SRC_URI = "git://github.com/glneo/libion.git;protocol=https;branch=${BRANCH}" | ||
10 | SRCREV = "7e138fc31febbb67734792c1a911439bfd6d23eb" | ||
11 | |||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | inherit cmake pkgconfig | ||
diff --git a/meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb b/meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb new file mode 100644 index 00000000..0f2705b8 --- /dev/null +++ b/meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | SUMMARY = "Diagnostic tool for TI K3 processors" | ||
2 | |||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://common/k3conf.c;beginline=1;endline=34;md5=7154c0ffcd418064ffa528e34e70ca9d" | ||
5 | |||
6 | PV = "0.2+git${SRCPV}" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "k3" | ||
9 | |||
10 | BRANCH ?= "master" | ||
11 | SRCREV = "79f007cd462384ce22e750e9002b714878f56892" | ||
12 | |||
13 | SRC_URI = "git://git.ti.com/k3conf/k3conf.git;protocol=git;branch=${BRANCH}" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | do_compile () { | ||
18 | oe_runmake CC="${CC}" CROSS_COMPILE=${TARGET_PREFIX} all | ||
19 | } | ||
20 | |||
21 | do_install () { | ||
22 | install -d ${D}${bindir} | ||
23 | install ${S}/k3conf ${D}${bindir} | ||
24 | } | ||