diff options
Diffstat (limited to 'meta-ti-bsp/recipes-devtools/gdbc6x/gdbc6x_git.bb')
-rw-r--r-- | meta-ti-bsp/recipes-devtools/gdbc6x/gdbc6x_git.bb | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-devtools/gdbc6x/gdbc6x_git.bb b/meta-ti-bsp/recipes-devtools/gdbc6x/gdbc6x_git.bb new file mode 100644 index 00000000..df9aaee9 --- /dev/null +++ b/meta-ti-bsp/recipes-devtools/gdbc6x/gdbc6x_git.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | DESCRIPTION = "GNU debugger for TI C6X DSP." | ||
2 | SECTION = "devel" | ||
3 | LICENSE = "GPLv3+" | ||
4 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=bf0fe2872eb3dfeebb2cbe38206fe81f" | ||
5 | |||
6 | DEPENDS = "ncurses bison-native texinfo flex-native gettext" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "dra7xx" | ||
9 | |||
10 | PR = "${INC_PR}.1" | ||
11 | |||
12 | SRC_URI:append = " \ | ||
13 | file://init \ | ||
14 | file://0001-libbfd.h-suppress-GCC9-Wstringop-truncation.patch;striplevel=2 \ | ||
15 | " | ||
16 | |||
17 | S = "${WORKDIR}/git/gdbc6x" | ||
18 | |||
19 | inherit update-rc.d | ||
20 | inherit gettext | ||
21 | |||
22 | CFLAGS += "-fcommon" | ||
23 | |||
24 | do_configure () { | ||
25 | cd ${S} | ||
26 | ./configure --program-suffix=c6x --target=tic6x-elf-tirtos --host=${HOST_SYS} --prefix=${S}/install_gdb | ||
27 | } | ||
28 | |||
29 | do_install () { | ||
30 | make install | ||
31 | |||
32 | # Custom install to prevent conflict with standard GDB. | ||
33 | install -d ${D}${bindir} | ||
34 | install -d ${D}${includedir} | ||
35 | install -m 755 ${S}/install_gdb/bin/gdbc6x ${D}${bindir} | ||
36 | cp -rf ${S}/install_gdb/include/* ${D}${includedir} | ||
37 | |||
38 | install -d ${D}${sysconfdir}/init.d | ||
39 | install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/gdbserverproxy | ||
40 | } | ||
41 | |||
42 | RDEPENDS:${PN} = "gdbserverproxy-module-drv bash" | ||
43 | |||
44 | include gdbc6x.inc | ||
45 | |||
46 | INITSCRIPT_NAME = "gdbserverproxy" | ||
47 | INITSCRIPT_PARAMS = "defaults 95" | ||
48 | |||
49 | PARALLEL_MAKE = "" | ||