summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp/recipes-bsp')
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc4
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb18
-rw-r--r--meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc7
3 files changed, 27 insertions, 2 deletions
diff --git a/meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc b/meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc
index faf998dd..a00df108 100644
--- a/meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc
+++ b/meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc
@@ -19,12 +19,12 @@ CADENCE_MHDP_FW_VERSION = "1.2.17"
19IMG_DEC_FW_VERSION = "1.0" 19IMG_DEC_FW_VERSION = "1.0"
20CNM_WAVE521_FW_VERSION = "1.0.00" 20CNM_WAVE521_FW_VERSION = "1.0.00"
21 21
22TI_LINUX_FW_SRCREV ?= "0f4905088d24e474063f33777559149e11538be5" 22TI_LINUX_FW_SRCREV ?= "e13611ff1da6448d80279cc8c43b81cb2275cb0d"
23SRCREV = "${TI_LINUX_FW_SRCREV}" 23SRCREV = "${TI_LINUX_FW_SRCREV}"
24 24
25BRANCH ?= "ti-linux-firmware" 25BRANCH ?= "ti-linux-firmware"
26 26
27K3_IMAGE_GEN_SRCREV ?= "f1db75bdc506287a9d04b0afbbb3d853a0948179" 27K3_IMAGE_GEN_SRCREV ?= "b0386fe221fc9124fda0cd2efb03d62710b1d90f"
28SRCREV_imggen = "${K3_IMAGE_GEN_SRCREV}" 28SRCREV_imggen = "${K3_IMAGE_GEN_SRCREV}"
29SRCREV_FORMAT = "imggen" 29SRCREV_FORMAT = "imggen"
30 30
diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 33333e3c..530b25b8 100644
--- a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -6,6 +6,7 @@ DEPENDS:append:j7200-hs-evm-k3r5 = " virtual/bootloader"
6DEPENDS:append:j721s2-evm-k3r5 = " virtual/bootloader" 6DEPENDS:append:j721s2-evm-k3r5 = " virtual/bootloader"
7DEPENDS:append:am64xx-evm-k3r5 = " virtual/bootloader" 7DEPENDS:append:am64xx-evm-k3r5 = " virtual/bootloader"
8DEPENDS:append:am64xx-hs-evm-k3r5 = " virtual/bootloader" 8DEPENDS:append:am64xx-hs-evm-k3r5 = " virtual/bootloader"
9DEPENDS:append:am62xx-evm-k3r5 = " virtual/bootloader"
9 10
10CLEANBROKEN = "1" 11CLEANBROKEN = "1"
11PR = "${INC_PR}.2" 12PR = "${INC_PR}.2"
@@ -29,6 +30,7 @@ SYSFW_PREFIX:j721e-hs-evm-k3r5-sr1-1 = "ti-fs-firmware"
29SYSFW_PREFIX:j7200-evm-k3r5 = "ti-fs-firmware" 30SYSFW_PREFIX:j7200-evm-k3r5 = "ti-fs-firmware"
30SYSFW_PREFIX:j7200-hs-evm-k3r5 = "ti-fs-firmware" 31SYSFW_PREFIX:j7200-hs-evm-k3r5 = "ti-fs-firmware"
31SYSFW_PREFIX:j721s2-evm-k3r5 = "ti-fs-firmware" 32SYSFW_PREFIX:j721s2-evm-k3r5 = "ti-fs-firmware"
33SYSFW_PREFIX:am62xx-evm-k3r5 = "ti-fs-firmware"
32 34
33SYSFW_SUFFIX ?= "unknown" 35SYSFW_SUFFIX ?= "unknown"
34 36
@@ -63,6 +65,7 @@ EXTRA_OEMAKE:append:j7200-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-s
63EXTRA_OEMAKE:append:j721s2-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" 65EXTRA_OEMAKE:append:j721s2-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
64EXTRA_OEMAKE:append:am64xx-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" 66EXTRA_OEMAKE:append:am64xx-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
65EXTRA_OEMAKE:append:am64xx-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" 67EXTRA_OEMAKE:append:am64xx-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
68EXTRA_OEMAKE:append:am62xx-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
66 69
67do_compile() { 70do_compile() {
68 cd ${WORKDIR}/imggen/ 71 cd ${WORKDIR}/imggen/
@@ -170,4 +173,19 @@ do_deploy:am64xx-hs-evm-k3r5() {
170 install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/ 173 install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/
171} 174}
172 175
176do_install:am62xx-evm-k3r5() {
177 install -d ${D}/boot
178 install -m 644 ${WORKDIR}/imggen/${UBOOT_BINARY} ${D}/boot/${UBOOT_IMAGE}
179 ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_SYMLINK}
180 ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_BINARY}
181}
182
183do_deploy:am62xx-evm-k3r5() {
184 install -d ${DEPLOYDIR}
185 install -m 644 ${WORKDIR}/imggen/${UBOOT_BINARY} ${DEPLOYDIR}/${UBOOT_IMAGE}
186 ln -sf ${UBOOT_IMAGE} ${DEPLOYDIR}/${UBOOT_SYMLINK}
187 ln -sf ${UBOOT_IMAGE} ${DEPLOYDIR}/${UBOOT_BINARY}
188 install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/
189}
190
173addtask deploy before do_build after do_compile 191addtask deploy before do_build after do_compile
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
index a5b24f49..c3c32f9c 100644
--- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
+++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
@@ -41,6 +41,7 @@ PACKAGECONFIG[dm] = "DM=${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/pdk-i
41 41
42PACKAGECONFIG:append:aarch64 = " atf optee" 42PACKAGECONFIG:append:aarch64 = " atf optee"
43PACKAGECONFIG:append:j7 = " dm" 43PACKAGECONFIG:append:j7 = " dm"
44PACKAGECONFIG:append:am62xx = " dm"
44 45
45COMPATIBLE_MACHINE = "(ti-soc)" 46COMPATIBLE_MACHINE = "(ti-soc)"
46 47
@@ -68,6 +69,7 @@ SPL_UART_BINARY:j7200-hs-evm-k3r5 = "u-boot-spl.bin"
68SPL_UART_BINARY:j721s2-evm-k3r5 = "u-boot-spl.bin" 69SPL_UART_BINARY:j721s2-evm-k3r5 = "u-boot-spl.bin"
69SPL_UART_BINARY:am64xx-evm-k3r5 = "u-boot-spl.bin" 70SPL_UART_BINARY:am64xx-evm-k3r5 = "u-boot-spl.bin"
70SPL_UART_BINARY:am64xx-hs-evm-k3r5 = "u-boot-spl.bin" 71SPL_UART_BINARY:am64xx-hs-evm-k3r5 = "u-boot-spl.bin"
72SPL_UART_BINARY:am62xx-evm-k3r5 = "u-boot-spl.bin"
71 73
72SPL_UART_IMAGE ?= "${SPL_UART_BINARY}-${MACHINE}-${PV}-${PR}" 74SPL_UART_IMAGE ?= "${SPL_UART_BINARY}-${MACHINE}-${PV}-${PR}"
73SPL_UART_SYMLINK ?= "${SPL_UART_BINARY}-${MACHINE}" 75SPL_UART_SYMLINK ?= "${SPL_UART_BINARY}-${MACHINE}"
@@ -293,4 +295,9 @@ do_deploy:append:am64xx-hs-evm-k3r5 () {
293 mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true 295 mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true
294} 296}
295 297
298do_deploy:append:am62xx-evm-k3r5 () {
299 mv ${DEPLOYDIR}/tiboot3.bin ${DEPLOYDIR}/tiboot3-r5spl.bin || true
300 mv ${DEPLOYDIR}/u-boot-spl.bin ${DEPLOYDIR}/u-boot-spl-r5spl.bin || true
301}
302
296TOOLCHAIN = "gcc" 303TOOLCHAIN = "gcc"