summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch')
-rw-r--r--meta-ti-bsp/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch b/meta-ti-bsp/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch
new file mode 100644
index 00000000..a8db0770
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch
@@ -0,0 +1,29 @@
1From 3a8fc3ccf00796254d6cef4b6d4cd70dc37012e1 Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Fri, 10 Mar 2017 13:28:29 -0500
4Subject: [PATCH] Add Makefile to install firmware files
5
6Signed-off-by: Denys Dmytriyenko <denys@ti.com>
7---
8 Makefile | 9 +++++++++
9 1 file changed, 9 insertions(+)
10 create mode 100644 Makefile
11
12diff --git a/Makefile b/Makefile
13new file mode 100644
14index 0000000..1cf38e3
15--- /dev/null
16+++ b/Makefile
17@@ -0,0 +1,9 @@
18+# Installs the the ti-connectivity wlan firmware files into the root file system
19+
20+install:
21+ @if [ ! -d $(DESTDIR) ] ; then \
22+ echo "Target filesystem directory doesn't exist."; \
23+ exit 1; \
24+ fi
25+ install -d $(DEST_DIR)/lib/firmware/ti-connectivity
26+ cp *.bin $(DEST_DIR)/lib/firmware/ti-connectivity/
27--
282.7.4
29