diff options
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb')
-rw-r--r-- | meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb | 34 |
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb new file mode 100644 index 00000000..2d0d3f9e --- /dev/null +++ b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | SUMMARY = "PRU Ethernet Switch firmware for AM65xx SR2.0" | ||
2 | |||
3 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc | ||
4 | |||
5 | PV = "${PRUETH_FW_AM65X_SR2_VERSION}" | ||
6 | PR = "${INC_PR}.0" | ||
7 | |||
8 | CLEANBROKEN = "1" | ||
9 | |||
10 | COMPATIBLE_MACHINE = "am65xx-evm" | ||
11 | |||
12 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | TARGET = " \ | ||
17 | am65x-sr2-pru0-prusw-fw.elf \ | ||
18 | am65x-sr2-pru1-prusw-fw.elf \ | ||
19 | am65x-sr2-rtu0-prusw-fw.elf \ | ||
20 | am65x-sr2-rtu1-prusw-fw.elf \ | ||
21 | am65x-sr2-txpru0-prusw-fw.elf \ | ||
22 | am65x-sr2-txpru1-prusw-fw.elf \ | ||
23 | " | ||
24 | |||
25 | do_install() { | ||
26 | install -d ${D}${base_libdir}/firmware/ti-pruss | ||
27 | for f in ${TARGET}; do | ||
28 | install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f | ||
29 | done | ||
30 | } | ||
31 | |||
32 | FILES:${PN} = "${base_libdir}/firmware" | ||
33 | |||
34 | INSANE_SKIP:${PN} = "arch" | ||