summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb')
-rw-r--r--meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb
new file mode 100644
index 00000000..618b1ad6
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb
@@ -0,0 +1,31 @@
1SUMMARY = "PRU HSR firmware for AM335x/AM437x/AM57xx"
2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4
5PE = "1"
6PR = "${INC_PR}.0"
7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14S = "${WORKDIR}/git"
15
16TARGET = ""
17TARGET:ti33x = "am335x-pru0-pruhsr-fw.elf am335x-pru1-pruhsr-fw.elf"
18TARGET:ti43x = "am437x-pru0-pruhsr-fw.elf am437x-pru1-pruhsr-fw.elf"
19TARGET:am57xx-evm = "am57xx-pru0-pruhsr-fw.elf am57xx-pru1-pruhsr-fw.elf"
20TARGET:am57xx-hs-evm = "am57xx-pru0-pruhsr-fw.elf am57xx-pru1-pruhsr-fw.elf"
21
22do_install() {
23 install -d ${D}${base_libdir}/firmware/ti-pruss
24 for f in ${TARGET}; do
25 install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f
26 done
27}
28
29FILES:${PN} = "${base_libdir}/firmware"
30
31INSANE_SKIP:${PN} = "arch"