summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb')
-rw-r--r--meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
new file mode 100644
index 00000000..c31af832
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
@@ -0,0 +1,34 @@
1SUMMARY = "PRU HSR firmware for AM65xx SR2.0"
2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4
5PV = "${PRUETH_FW_AM65X_SR2_VERSION}"
6PR = "${INC_PR}.0"
7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14S = "${WORKDIR}/git"
15
16TARGET = " \
17 am65x-sr2-pru0-pruhsr-fw.elf \
18 am65x-sr2-pru1-pruhsr-fw.elf \
19 am65x-sr2-rtu0-pruhsr-fw.elf \
20 am65x-sr2-rtu1-pruhsr-fw.elf \
21 am65x-sr2-txpru0-pruhsr-fw.elf \
22 am65x-sr2-txpru1-pruhsr-fw.elf \
23"
24
25do_install() {
26 install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss
27 for f in ${TARGET}; do
28 install -m 0644 ${S}/ti-pruss/$f ${D}${nonarch_base_libdir}/firmware/ti-pruss/$f
29 done
30}
31
32FILES:${PN} = "${nonarch_base_libdir}/firmware"
33
34INSANE_SKIP:${PN} = "arch"