summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/dsptop
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/dsptop')
-rw-r--r--meta-ti-bsp/recipes-bsp/dsptop/debugss-module-drv_git.bb22
-rw-r--r--meta-ti-bsp/recipes-bsp/dsptop/dsptop.inc8
-rw-r--r--meta-ti-bsp/recipes-bsp/dsptop/dsptop_git.bb27
-rw-r--r--meta-ti-bsp/recipes-bsp/dsptop/libulm_git.bb45
4 files changed, 102 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/dsptop/debugss-module-drv_git.bb b/meta-ti-bsp/recipes-bsp/dsptop/debugss-module-drv_git.bb
new file mode 100644
index 00000000..a250b825
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/dsptop/debugss-module-drv_git.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Debug Sub-System (DebugSS) driver for Keystone and DRA7xx devices"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING.txt;md5=9d4316fe434ba450dca4da25348ca5a3"
4
5# This package builds a kernel module, use kernel PR as base and append a local
6MACHINE_KERNEL_PR:append = "d"
7PR = "${MACHINE_KERNEL_PR}"
8PV:append = "+git${SRCPV}"
9
10S = "${WORKDIR}/git/debugss_module/debugss-mod"
11
12inherit module
13
14PLATFORM = ""
15PLATFORM:dra7xx = "DRA7xx_PLATFORM"
16
17EXTRA_OEMAKE = "'PLATFORM=${PLATFORM}' KVERSION=${KERNEL_VERSION} KERNEL_SRC=${STAGING_KERNEL_DIR}"
18
19COMPATIBLE_MACHINE = "dra7xx"
20PACKAGE_ARCH = "${MACHINE_ARCH}"
21
22include dsptop.inc
diff --git a/meta-ti-bsp/recipes-bsp/dsptop/dsptop.inc b/meta-ti-bsp/recipes-bsp/dsptop/dsptop.inc
new file mode 100644
index 00000000..31f775e2
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/dsptop/dsptop.inc
@@ -0,0 +1,8 @@
1# This corresponds to version 1.4.0
2SRCREV = "816485e68430bbec643eac9498bfa5303eb2c2e1"
3PV = "1.4.0"
4INC_PR = "r2"
5
6SRC_URI = "git://git.ti.com/sdo-emu/dsptop.git;protocol=git;branch=${BRANCH}"
7
8BRANCH = "master"
diff --git a/meta-ti-bsp/recipes-bsp/dsptop/dsptop_git.bb b/meta-ti-bsp/recipes-bsp/dsptop/dsptop_git.bb
new file mode 100644
index 00000000..20818443
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/dsptop/dsptop_git.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "TI dsptop utility."
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://debian/copyright;md5=309825aa8f5edfcf2c44912ac094b979"
4
5DEPENDS = "libulm ncurses"
6
7PR = "${INC_PR}.2"
8
9S = "${WORKDIR}/git/dsptop"
10
11DEVICE = ""
12DEVICE:dra7xx = "DRA7xx"
13
14EXTRA_OEMAKE = "release DEVICE=${DEVICE} CROSS_COMPILE=${TARGET_PREFIX} CC="${CC}""
15
16do_install() {
17 oe_runmake install DESTDIR=${D}
18}
19
20COMPATIBLE_MACHINE = "dra7xx"
21PACKAGE_ARCH = "${MACHINE_ARCH}"
22
23RDEPENDS:${PN} = "debugss-module-drv bash"
24
25include dsptop.inc
26
27PARALLEL_MAKE = ""
diff --git a/meta-ti-bsp/recipes-bsp/dsptop/libulm_git.bb b/meta-ti-bsp/recipes-bsp/dsptop/libulm_git.bb
new file mode 100644
index 00000000..f3e7ec3c
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/dsptop/libulm_git.bb
@@ -0,0 +1,45 @@
1SUMMARY = "TI Usage & Load Monitor Implementation"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://../debian/copyright;md5=309825aa8f5edfcf2c44912ac094b979"
4
5inherit features_check
6
7REQUIRED_MACHINE_FEATURES = "dsp"
8
9DEPENDS = "ti-cgt6x-native"
10PR = "${INC_PR}.0"
11
12S = "${WORKDIR}/git/dsptop/ulm"
13
14DEVICE=""
15DEVICE:dra7xx = "DRA7xx"
16
17EXTRA_OEMAKE = "release DEVICE=${DEVICE} CROSS_COMPILE=${TARGET_PREFIX}"
18
19do_compile() {
20 oe_runmake arm XPORT_ONLY CC="${CC}"
21 oe_runmake dsp C6X_C_DIR=${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x/include
22}
23
24do_install() {
25 install -d ${D}${includedir}
26 install -d ${D}${libdir}
27 install -d ${D}${datadir}/ti/ulm
28 cp -f tiulm.h ${D}${includedir}
29 cp -f release/libtiulm.a ${D}${libdir}
30 cp -f tiulm.h ${D}${datadir}/ti/ulm
31 cp -f release/libtiulm.ae66 ${D}${datadir}/ti/ulm
32}
33
34COMPATIBLE_MACHINE = "dra7xx"
35PACKAGE_ARCH = "${MACHINE_ARCH}"
36
37FILES:${PN}-dev += "\
38 ${datadir}/ti/ulm \
39"
40
41include dsptop.inc
42
43ALLOW_EMPTY:${PN} = "1"
44
45PARALLEL_MAKE= ""