diff options
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/dspdce-fw/dspdce-fw_git.bb')
-rw-r--r-- | meta-ti-bsp/recipes-bsp/dspdce-fw/dspdce-fw_git.bb | 65 |
1 files changed, 65 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/dspdce-fw/dspdce-fw_git.bb b/meta-ti-bsp/recipes-bsp/dspdce-fw/dspdce-fw_git.bb new file mode 100644 index 00000000..4e863099 --- /dev/null +++ b/meta-ti-bsp/recipes-bsp/dspdce-fw/dspdce-fw_git.bb | |||
@@ -0,0 +1,65 @@ | |||
1 | SUMMARY = "Firmware for DSP for an example application called copycodectest" | ||
2 | LICENSE = "TI-TSPA" | ||
3 | LIC_FILES_CHKSUM = "file://src/ti/framework/dce/dce.c;startline=1;endline=31;md5=2c6e9aba6ed75f22b1a2b7544b1c809d" | ||
4 | |||
5 | COMPATIBLE_MACHINE = "dra7xx" | ||
6 | |||
7 | inherit features_check | ||
8 | |||
9 | REQUIRED_MACHINE_FEATURES = "dsp" | ||
10 | |||
11 | SRC_URI = "git://git.ti.com/glsdk/dspdce.git;protocol=git" | ||
12 | |||
13 | SRCREV = "de6e599f067b25c46cc0c8f74a22cc3b8aafbae8" | ||
14 | |||
15 | PV = "1.00.00.07" | ||
16 | |||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | require recipes-ti/includes/ti-paths.inc | ||
20 | |||
21 | PR = "r4" | ||
22 | inherit update-alternatives | ||
23 | |||
24 | DEPENDS = "ti-xdctools-native ti-sysbios ti-codec-engine ti-framework-components ti-xdais ti-ipc-rtos ti-osal ti-cgt6x-native" | ||
25 | |||
26 | export HWVERSION = "ES10" | ||
27 | export BIOSTOOLSROOT = "${STAGING_DIR_TARGET}/usr/share/ti" | ||
28 | |||
29 | export XDCVERSION = "ti-xdctools-tree" | ||
30 | export BIOSVERSION = "ti-sysbios-tree" | ||
31 | export IPCVERSION = "ti-ipc-tree" | ||
32 | export CEVERSION = "ti-codec-engine-tree" | ||
33 | export FCVERSION = "ti-framework-components-tree" | ||
34 | export XDAISVERSION = "ti-xdais-tree" | ||
35 | export OSALVERSION = "ti-osal-tree" | ||
36 | |||
37 | export IPCSRC = "${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree" | ||
38 | export C66XCGTOOLSPATH = "${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" | ||
39 | |||
40 | do_configure() { | ||
41 | cd ${S} | ||
42 | make unconfig | ||
43 | make vayu_config | ||
44 | } | ||
45 | |||
46 | do_compile() { | ||
47 | cd ${S} | ||
48 | make dspbin | ||
49 | } | ||
50 | |||
51 | TARGET = "dra7-dsp1-fw.xe66" | ||
52 | |||
53 | do_install() { | ||
54 | install -d ${D}${base_libdir}/firmware | ||
55 | install -m 0644 ${S}/dra7xx-c66x-dsp.xe66 ${D}${base_libdir}/firmware/${TARGET}.${BPN} | ||
56 | } | ||
57 | |||
58 | ALTERNATIVE:${PN} = "dra7-dsp1-fw.xe66" | ||
59 | ALTERNATIVE_LINK_NAME[dra7-dsp1-fw.xe66] = "${base_libdir}/firmware/${TARGET}" | ||
60 | ALTERNATIVE_TARGET[dra7-dsp1-fw.xe66] = "${base_libdir}/firmware/${TARGET}.${BPN}" | ||
61 | ALTERNATIVE_PRIORITY = "10" | ||
62 | |||
63 | INSANE_SKIP:${PN} = "arch" | ||
64 | |||
65 | FILES:${PN} += "${base_libdir}/firmware/*" | ||