summaryrefslogtreecommitdiffstats
path: root/extras/recipes-kernel/linux/linux-davinci_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'extras/recipes-kernel/linux/linux-davinci_git.bb')
-rw-r--r--extras/recipes-kernel/linux/linux-davinci_git.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/extras/recipes-kernel/linux/linux-davinci_git.bb b/extras/recipes-kernel/linux/linux-davinci_git.bb
new file mode 100644
index 00000000..e4b85d64
--- /dev/null
+++ b/extras/recipes-kernel/linux/linux-davinci_git.bb
@@ -0,0 +1,57 @@
1require multi-kernel.inc
2
3DESCRIPTION = "Linux kernel for DaVinci processors"
4KERNEL_IMAGETYPE = "uImage"
5
6COMPATIBLE_MACHINE = "hawkboard"
7
8DEFAULT_PREFERENCE_hawkboard = "1"
9
10BRANCH = "master"
11
12SRC_URI_append = " file://defconfig "
13
14S = "${WORKDIR}/git"
15
16# The main PR is now using MACHINE_KERNEL_PR, for davinci see conf/machine/include/davinci.inc
17
18# OMAPL tracking master branch - PSP 3.20.00.12
19
20ARAGO_L1_REV = "2acf935c01b9adb50164d421c40cdc5862b9e143"
21ARAGO_L1_BR = "master"
22ARAGO_L1_PV = "2.6.32+2.6.33-rc4-${PR}+gitr${SRCREV}"
23ARAGO_L1_URI = "git://arago-project.org/git/projects/linux-omapl1.git;protocol=git;branch=${BRANCH} "
24
25SRCREV_hawkboard = "${ARAGO_L1_REV}"
26
27PV_omapl138 = "${ARAGO_L1_PV}"
28
29BRANCH_omapl138 = "${ARAGO_L1_BR}"
30
31SRC_URI_append_omapl138 = "${ARAGO_L1_URI}"
32
33SRC_URI_append_omapl138 = " file://logo_linux_clut224.ppm \
34 file://0001-ahci-ti-Fix-currently-harmless-typo-in-SATA-PHY.patch \
35 file://0002-ahci-ti-Update-SATA-PHY-configuration-RXCDR.patch \
36 file://0001-board-da850-evm-Disable-NAND-SUBPAGE.patch \
37 file://0001-uio_pruss1-Core-driver-addition.patch \
38 file://0002-uio_pruss2-Platform-changes.patch \
39 file://0003-uio_pruss3-Workarounds-put-into-core-code.patch \
40 file://0001-cgroupfs-create-sys-fs-cgroup-to-mount-cgroupfs-on.patch \
41 file://0001-ARM-6329-1-wire-up-sys_accept4-on-ARM.patch \
42 "
43
44SRC_URI_append_hawkboard = " \
45 file://patch-2.6.33rc4-psp-to-hawkboard.patch \
46 file://0001-board-da850-hawk-Disable-NAND-SUBPAGE.patch \
47 "
48
49# Perf in 2.6.33rc has broken perl handling, so disable it
50do_compile_perf() {
51 :
52}
53
54do_install_perf() {
55 :
56}
57