summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-build-kbuild-Makefile.template-use-SECONDARY.patch35
-rw-r--r--meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.3.6512818.bb (renamed from meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb)4
-rw-r--r--meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.3.6512818.bb (renamed from meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.2.6460340.bb)6
3 files changed, 4 insertions, 41 deletions
diff --git a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-build-kbuild-Makefile.template-use-SECONDARY.patch b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-build-kbuild-Makefile.template-use-SECONDARY.patch
deleted file mode 100644
index 0989116e..00000000
--- a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-build-kbuild-Makefile.template-use-SECONDARY.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From 738dfc1b33a83e9995ed7f65ec41ebe2fc6a90ed Mon Sep 17 00:00:00 2001
2From: Ryan Eatmon <reatmon@ti.com>
3Date: Wed, 1 Nov 2023 10:04:29 -0500
4Subject: [PATCH] build: kbuild: Makefile.template: use SECONDARY
5
6For some reason on master we are seeing an error:
7
8| make[5]: *** .NOTINTERMEDIATE and .SECONDARY are mutually exclusive. Stop.
9
10Flip this back to .SECONDARY to fix this build issue.
11
12Signed-off-by: Ryan Eatmon <reatmon@ti.com>
13
14Upstream-Status: Pending
15
16---
17 build/linux/kbuild/Makefile.template | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/build/linux/kbuild/Makefile.template b/build/linux/kbuild/Makefile.template
21index aa19d66..31e37fb 100644
22--- a/build/linux/kbuild/Makefile.template
23+++ b/build/linux/kbuild/Makefile.template
24@@ -54,7 +54,7 @@
25
26 include $(OUT)/config_kernel.mk
27
28-.NOTINTERMEDIATE:
29+.SECONDARY:
30
31 define symlink-source-file
32 @if [ ! -e $(dir $@) ]; then mkdir -p $(dir $@); fi
33--
342.17.1
35
diff --git a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.3.6512818.bb
index 7b274312..bc59816a 100644
--- a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb
+++ b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.3.6512818.bb
@@ -20,11 +20,9 @@ BRANCH = "linuxws/kirkstone/k6.1/${PV}"
20 20
21SRC_URI = "git://git.ti.com/git/graphics/ti-img-rogue-driver.git;protocol=https;branch=${BRANCH}" 21SRC_URI = "git://git.ti.com/git/graphics/ti-img-rogue-driver.git;protocol=https;branch=${BRANCH}"
22 22
23SRC_URI:append = " file://0001-build-kbuild-Makefile.template-use-SECONDARY.patch"
24
25S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
26 24
27SRCREV = "2595524729c5acbabcbdee2185de64e7fcd6b36a" 25SRCREV = "41a494accb30aa2f247e6a4e123a4954982f2a88"
28 26
29TARGET_PRODUCT:j721e = "j721e_linux" 27TARGET_PRODUCT:j721e = "j721e_linux"
30TARGET_PRODUCT:j721s2 = "j721s2_linux" 28TARGET_PRODUCT:j721s2 = "j721s2_linux"
diff --git a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.2.6460340.bb b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.3.6512818.bb
index 5ad32d41..288eb52b 100644
--- a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.2.6460340.bb
+++ b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.3.6512818.bb
@@ -14,7 +14,7 @@ PR = "r3"
14 14
15BRANCH = "linuxws/kirkstone/k6.1/${PV}" 15BRANCH = "linuxws/kirkstone/k6.1/${PV}"
16SRC_URI = "git://git.ti.com/git/graphics/ti-img-rogue-umlibs.git;protocol=https;branch=${BRANCH}" 16SRC_URI = "git://git.ti.com/git/graphics/ti-img-rogue-umlibs.git;protocol=https;branch=${BRANCH}"
17SRCREV = "c2671c6eaf85ec6a1183c023bbb4d6e9e288fc10" 17SRCREV = "0b9e64254269be2fa95c4f3e1dd925d6e4d58199"
18S = "${WORKDIR}/git/targetfs/${TARGET_PRODUCT}/${PVR_WS}/${PVR_BUILD}" 18S = "${WORKDIR}/git/targetfs/${TARGET_PRODUCT}/${PVR_WS}/${PVR_BUILD}"
19 19
20TARGET_PRODUCT:j721e = "j721e_linux" 20TARGET_PRODUCT:j721e = "j721e_linux"
@@ -33,7 +33,7 @@ RDEPENDS:${PN} = " \
33" 33"
34 34
35PACKAGECONFIG ?= " \ 35PACKAGECONFIG ?= " \
36 ${@bb.utils.contains('DISTRO_FEATURES', 'vulkan x11 wayland', 'vulkan', '', d)} \ 36 ${@bb.utils.contains('DISTRO_FEATURES', 'vulkan wayland', 'vulkan', '', d)} \
37 ${@bb.utils.filter('DISTRO_FEATURES', 'opengl opencl', d)} \ 37 ${@bb.utils.filter('DISTRO_FEATURES', 'opengl opencl', d)} \
38" 38"
39 39
@@ -121,7 +121,7 @@ RDEPENDS:libgles2-rogue += "mesa-megadriver"
121 121
122# vulkan specific shared objects and configs 122# vulkan specific shared objects and configs
123FILES:libvk-rogue = "${libdir}/libVK_IMG.so* ${datadir}/vulkan" 123FILES:libvk-rogue = "${libdir}/libVK_IMG.so* ${datadir}/vulkan"
124RDEPENDS:libvk-rogue += "vulkan-loader libx11-xcb wayland libdrm" 124RDEPENDS:libvk-rogue += "vulkan-loader wayland libdrm"
125 125
126# opencl specific shared objects and configs 126# opencl specific shared objects and configs
127FILES:libopencl-rogue = "${libdir}/libPVROCL.so* ${sysconfdir}/OpenCL" 127FILES:libopencl-rogue = "${libdir}/libPVROCL.so* ${sysconfdir}/OpenCL"