diff options
-rw-r--r-- | recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_1.5.bb | 61 |
1 files changed, 61 insertions, 0 deletions
diff --git a/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_1.5.bb b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_1.5.bb new file mode 100644 index 00000000..5a7fd213 --- /dev/null +++ b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_1.5.bb | |||
@@ -0,0 +1,61 @@ | |||
1 | SUMMARY = "ARM Trusted Firmware" | ||
2 | DESCRIPTION = "ARM Trusted Firmware provides a reference implementation of \ | ||
3 | Secure World software for ARMv8-A, including Exception Level 3 (EL3) software. \ | ||
4 | It provides implementations of various ARM interface standards such as the \ | ||
5 | Power State Coordination Interface (PSCI), Trusted Board Boot Requirements \ | ||
6 | (TBBR) and Secure monitor code." | ||
7 | HOMEPAGE = "http://infocenter.arm.com/help/topic/com.arm.doc.dui0928e/CJHIDGJF.html" | ||
8 | |||
9 | LICENSE = "BSD" | ||
10 | LIC_FILES_CHKSUM = "file://license.rst;md5=e927e02bca647e14efd87e9e914b2443" | ||
11 | |||
12 | inherit deploy | ||
13 | |||
14 | DEPENDS += "dtc-native" | ||
15 | |||
16 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
17 | |||
18 | S = "${WORKDIR}/git" | ||
19 | |||
20 | PV_append = "+git${SRCPV}" | ||
21 | |||
22 | BRANCH = "ti-atf" | ||
23 | SRC_URI = "git://git.ti.com/atf/arm-trusted-firmware.git;branch=${BRANCH}" | ||
24 | |||
25 | SRCREV ?= "5a0daebab6bf72b27cc74151d4e596247f804e44" | ||
26 | |||
27 | # Make ATF "aware" of OPTEE, no build dependency | ||
28 | PACKAGECONFIG[optee] = "SPD=opteed" | ||
29 | |||
30 | COMPATIBLE_MACHINE = "k3" | ||
31 | ATFPLATFORM_k3 = "k3" | ||
32 | ATFBOARD_k3 = "generic" | ||
33 | |||
34 | PACKAGECONFIG_k3 = "optee" | ||
35 | |||
36 | CFLAGS[unexport] = "1" | ||
37 | LDFLAGS[unexport] = "1" | ||
38 | AS[unexport] = "1" | ||
39 | LD[unexport] = "1" | ||
40 | |||
41 | do_configure[noexec] = "1" | ||
42 | |||
43 | EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" PLAT="${ATFPLATFORM}" TARGET_BOARD="${ATFBOARD}" ${PACKAGECONFIG_CONFARGS}' | ||
44 | |||
45 | do_compile() { | ||
46 | oe_runmake all | ||
47 | } | ||
48 | |||
49 | do_install() { | ||
50 | install -d ${D}/boot | ||
51 | install -m 0644 ${S}/build/${ATFPLATFORM}/${ATFBOARD}/release/bl31.bin ${D}/boot/ | ||
52 | } | ||
53 | |||
54 | do_deploy() { | ||
55 | install -d ${DEPLOYDIR} | ||
56 | install -m 0644 ${S}/build/${ATFPLATFORM}/${ATFBOARD}/release/bl31.bin ${DEPLOYDIR}/ | ||
57 | } | ||
58 | addtask deploy before do_build after do_compile | ||
59 | |||
60 | FILES_${PN} = "/boot" | ||
61 | SYSROOT_DIRS += "/boot" | ||