summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-ti-bsp/conf/machine/am65xx-evm.conf2
-rw-r--r--meta-ti-bsp/conf/machine/include/am64xx.inc2
-rw-r--r--meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb24
-rw-r--r--meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb24
4 files changed, 18 insertions, 34 deletions
diff --git a/meta-ti-bsp/conf/machine/am65xx-evm.conf b/meta-ti-bsp/conf/machine/am65xx-evm.conf
index 3d8e11b4..7df93db7 100644
--- a/meta-ti-bsp/conf/machine/am65xx-evm.conf
+++ b/meta-ti-bsp/conf/machine/am65xx-evm.conf
@@ -6,4 +6,4 @@ require conf/machine/include/am65xx.inc
6 6
7UBOOT_MACHINE = "am65x_evm_a53_defconfig" 7UBOOT_MACHINE = "am65x_evm_a53_defconfig"
8 8
9MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "prueth-fw pruhsr-fw-am65x-sr2 prusw-fw-am65x-sr2" 9MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "prueth-fw pruhsr-fw prusw-fw-am65x-sr2"
diff --git a/meta-ti-bsp/conf/machine/include/am64xx.inc b/meta-ti-bsp/conf/machine/include/am64xx.inc
index fb71d271..de65829c 100644
--- a/meta-ti-bsp/conf/machine/include/am64xx.inc
+++ b/meta-ti-bsp/conf/machine/include/am64xx.inc
@@ -21,4 +21,4 @@ TFA_BOARD = "lite"
21 21
22OPTEEMACHINE = "k3-am64x" 22OPTEEMACHINE = "k3-am64x"
23 23
24MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "prueth-fw pruhsr-fw-am65x-sr2 prusw-fw-am65x-sr2" 24MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "prueth-fw pruhsr-fw prusw-fw-am65x-sr2"
diff --git a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
deleted file mode 100644
index bc731094..00000000
--- a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1SUMMARY = "PRU HSR firmware for AM65xx SR2.0"
2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4
5PV = "${PRUETH_FW_AM65X_SR2_VERSION}"
6PR = "${INC_PR}.0"
7
8COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
9
10TARGET = " \
11 am65x-sr2-pru0-pruhsr-fw.elf \
12 am65x-sr2-pru1-pruhsr-fw.elf \
13 am65x-sr2-rtu0-pruhsr-fw.elf \
14 am65x-sr2-rtu1-pruhsr-fw.elf \
15 am65x-sr2-txpru0-pruhsr-fw.elf \
16 am65x-sr2-txpru1-pruhsr-fw.elf \
17"
18
19do_install() {
20 install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss
21 for f in ${TARGET}; do
22 install -m 0644 ${S}/ti-pruss/$f ${D}${nonarch_base_libdir}/firmware/ti-pruss/$f
23 done
24}
diff --git a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb
index fe99cb3e..3b06de9c 100644
--- a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb
+++ b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb
@@ -1,18 +1,26 @@
1SUMMARY = "PRU HSR firmware for AM335x/AM437x/AM57xx" 1SUMMARY = "PRU HSR firmware"
2 2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc 3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4 4
5PE = "1" 5PE = "1"
6PR = "${INC_PR}.0" 6PR = "${INC_PR}.0"
7 7
8COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx" 8COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx|am65xx|am64xx"
9 9
10PACKAGE_ARCH = "${MACHINE_ARCH}" 10TARGET = " \
11 11 am335x-pru0-pruhsr-fw.elf \
12TARGET = "" 12 am335x-pru1-pruhsr-fw.elf \
13TARGET:ti33x = "am335x-pru0-pruhsr-fw.elf am335x-pru1-pruhsr-fw.elf" 13 am437x-pru0-pruhsr-fw.elf \
14TARGET:ti43x = "am437x-pru0-pruhsr-fw.elf am437x-pru1-pruhsr-fw.elf" 14 am437x-pru1-pruhsr-fw.elf \
15TARGET:am57xx = "am57xx-pru0-pruhsr-fw.elf am57xx-pru1-pruhsr-fw.elf" 15 am57xx-pru0-pruhsr-fw.elf \
16 am57xx-pru1-pruhsr-fw.elf \
17 am65x-sr2-pru0-pruhsr-fw.elf \
18 am65x-sr2-pru1-pruhsr-fw.elf \
19 am65x-sr2-rtu0-pruhsr-fw.elf \
20 am65x-sr2-rtu1-pruhsr-fw.elf \
21 am65x-sr2-txpru0-pruhsr-fw.elf \
22 am65x-sr2-txpru1-pruhsr-fw.elf \
23"
16 24
17do_install() { 25do_install() {
18 install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss 26 install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss