summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/ivshmem-uio/ivshmem-uio-tests_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/ivshmem-uio/ivshmem-uio-tests_git.bb b/recipes-bsp/ivshmem-uio/ivshmem-uio-tests_git.bb
new file mode 100644
index 00000000..997b8c48
--- /dev/null
+++ b/recipes-bsp/ivshmem-uio/ivshmem-uio-tests_git.bb
@@ -0,0 +1,23 @@
1SUMMARY = "UIO tests for IVSHMEM based UIO driver"
2DESCRIPTION = "Test programs which use UIO (userspace io) device for inter VM communication"
3HOMEPAGE = "https://github.com/henning-schild-work/ivshmem-guest-code"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/git/COPYING;md5=0546a27aad86c83b75ad4ee6133e9d5e"
6
7inherit cmake
8
9PROTOCOL = "git"
10BRANCH = "jailhouse"
11SRCREV = "f3ad79881bebb6c6068966ee3d265d8034c20492"
12SRC_URI = "git://github.com/henning-schild-work/ivshmem-guest-code.git;protocol=${PROTOCOL};branch=${BRANCH}"
13
14S = "${WORKDIR}/git/uio/tests/Interrupts/VM"
15
16COMPATIBLE_MACHINE = "(ti-soc)"
17OECMAKE_TARGET_COMPILE = "uio_send uio_read"
18
19do_install() {
20 install -d ${D}/${bindir}
21 install -m 755 ${B}/uio_send ${D}/${bindir}/
22 install -m 755 ${B}/uio_read ${D}/${bindir}/
23}