summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/vps-lld/vps-lld-rtos_git.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes-bsp/vps-lld/vps-lld-rtos_git.bb b/recipes-bsp/vps-lld/vps-lld-rtos_git.bb
new file mode 100644
index 00000000..f13e2fcd
--- /dev/null
+++ b/recipes-bsp/vps-lld/vps-lld-rtos_git.bb
@@ -0,0 +1,52 @@
1SUMMARY = "TI RTOS Low level driver for Video Processing Subsystem (VPS) "
2
3require recipes-ti/includes/ti-paths.inc
4inherit ti-pdk
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://COPYING.txt;beginline=1;endline=32;md5=4303d306ea53eb66132983d6901c137d"
8
9COMPATIBLE_MACHINE = "omap-a15"
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11
12VPS_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/vps.git"
13VPS_LLD_GIT_PROTOCOL = "git"
14VPS_LLD_GIT_BRANCH = "master"
15VPS_LLD_GIT_DESTSUFFIX = "git/ti/drv/vps"
16
17# Below commit ID corresponds to "DEV.VPS_LLD.01.00.01.06B"
18VPS_LLD_SRCREV = "58729317b65bdb24d4343cbb1f7f6cb90ca2faf0"
19
20BRANCH = "${VPS_LLD_GIT_BRANCH}"
21SRC_URI = "${VPS_LLD_GIT_URI};destsuffix=${VPS_LLD_GIT_DESTSUFFIX};protocol=${VPS_LLD_GIT_PROTOCOL};branch=${BRANCH}"
22
23SRCREV = "${VPS_LLD_SRCREV}"
24PV = "01.00.01.06B"
25PR = "r0"
26
27S = "${WORKDIR}/${VPS_LLD_GIT_DESTSUFFIX}"
28
29DEPENDS = " ti-sysbios \
30 osal-rtos \
31 edma3-lld-rtos \
32 board-rtos \
33 uart-lld-rtos \
34 i2c-lld-rtos \
35 pm-lld-rtos \
36"
37export PDK_VPS_COMP_PATH = "${WORKDIR}/build"
38export DEST_ROOT="${S}"
39
40# Build with make instead of XDC
41TI_PDK_XDCMAKE = "0"
42
43do_compile_append() {
44 # Delete archive created by XDC release command since it does not contain all content
45 find -name "*.tar" -exec rm -f {} \;
46
47 # Archive from build/ to capture ti/drv/pm/ in archive
48 cd ${B}
49 tar -cf pm_lld.tar --exclude='*.tar' ./*
50}
51
52INSANE_SKIP_${PN} = "arch ldflags"