summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-ti33x-psp-3.1/0004-da8xx-fb-add-DVI-support-for-beaglebone.patch38
-rw-r--r--recipes-kernel/linux/linux-ti33x-psp_3.1.bb1
2 files changed, 39 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.1/0004-da8xx-fb-add-DVI-support-for-beaglebone.patch b/recipes-kernel/linux/linux-ti33x-psp-3.1/0004-da8xx-fb-add-DVI-support-for-beaglebone.patch
new file mode 100644
index 00000000..fe4ccac9
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti33x-psp-3.1/0004-da8xx-fb-add-DVI-support-for-beaglebone.patch
@@ -0,0 +1,38 @@
1From 27c26386a0152b7d0c2b4f173bcbe30805f42749 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Thu, 3 Nov 2011 17:35:50 +0100
4Subject: [PATCH 4/4] da8xx-fb: add DVI support for beaglebone
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 drivers/video/da8xx-fb.c | 14 ++++++++++++++
9 1 files changed, 14 insertions(+), 0 deletions(-)
10
11diff --git a/drivers/video/da8xx-fb.c b/drivers/video/da8xx-fb.c
12index 4347421..9619518 100644
13--- a/drivers/video/da8xx-fb.c
14+++ b/drivers/video/da8xx-fb.c
15@@ -266,6 +266,20 @@ static struct da8xx_panel known_lcd_panels[] = {
16 .pxl_clk = 30000000,
17 .invert_pxl_clk = 0,
18 },
19+ [3] = {
20+ /* 1024 x 768 @ 60 Hz Reduced blanking VESA CVT 0.79M3-R */
21+ .name = "1024x768@60",
22+ .width = 1024,
23+ .height = 768,
24+ .hfp = 48,
25+ .hbp = 80,
26+ .hsw = 32,
27+ .vfp = 3,
28+ .vbp = 15,
29+ .vsw = 4,
30+ .pxl_clk = 56000000,
31+ .invert_pxl_clk = 0,
32+ },
33 };
34
35 /* Enable the Raster Engine of the LCD Controller */
36--
371.7.2.5
38
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.1.bb b/recipes-kernel/linux/linux-ti33x-psp_3.1.bb
index 953b5749..317e53c7 100644
--- a/recipes-kernel/linux/linux-ti33x-psp_3.1.bb
+++ b/recipes-kernel/linux/linux-ti33x-psp_3.1.bb
@@ -29,6 +29,7 @@ PATCHES_OVER_PSP = " \
29 file://0001-ARM-omap-am335x-BeagleBone-version-detection-and-sup.patch \ 29 file://0001-ARM-omap-am335x-BeagleBone-version-detection-and-sup.patch \
30 file://0002-ARM-OMAP2-beaglebone-add-LED-support.patch \ 30 file://0002-ARM-OMAP2-beaglebone-add-LED-support.patch \
31 file://0003-ARM-OMAP2-beaglebone-add-DVI-support-needs-cleanup.patch \ 31 file://0003-ARM-OMAP2-beaglebone-add-DVI-support-needs-cleanup.patch \
32 file://0004-da8xx-fb-add-DVI-support-for-beaglebone.patch \
32 " 33 "
33 34
34SRC_URI += "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "", "${PATCHES_OVER_PSP}", d)}" 35SRC_URI += "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "", "${PATCHES_OVER_PSP}", d)}"