diff options
-rwxr-xr-x | recipes-bsp/qmss-lld/files/init_qmss.sh | 47 | ||||
-rw-r--r-- | recipes-bsp/qmss-lld/qmss-lld-test_git.bb | 3 | ||||
-rw-r--r-- | recipes-bsp/qmss-lld/qmss-lld.inc | 7 | ||||
-rw-r--r-- | recipes-bsp/qmss-lld/qmss-lld_git.bb | 23 |
4 files changed, 16 insertions, 64 deletions
diff --git a/recipes-bsp/qmss-lld/files/init_qmss.sh b/recipes-bsp/qmss-lld/files/init_qmss.sh deleted file mode 100755 index af695318..00000000 --- a/recipes-bsp/qmss-lld/files/init_qmss.sh +++ /dev/null | |||
@@ -1,47 +0,0 @@ | |||
1 | #* | ||
2 | #* Copyright (C) 2015 Texas Instruments Incorporated - http://www.ti.com/ | ||
3 | #* | ||
4 | #* | ||
5 | #* Redistribution and use in source and binary forms, with or without | ||
6 | #* modification, are permitted provided that the following conditions | ||
7 | #* are met: | ||
8 | #* | ||
9 | #* Redistributions of source code must retain the above copyright | ||
10 | #* notice, this list of conditions and the following disclaimer. | ||
11 | #* | ||
12 | #* Redistributions in binary form must reproduce the above copyright | ||
13 | #* notice, this list of conditions and the following disclaimer in the | ||
14 | #* documentation and/or other materials provided with the | ||
15 | #* distribution. | ||
16 | #* | ||
17 | #* Neither the name of Texas Instruments Incorporated nor the names of | ||
18 | #* its contributors may be used to endorse or promote products derived | ||
19 | #* from this software without specific prior written permission. | ||
20 | #* | ||
21 | |||
22 | #! /bin/sh | ||
23 | compatible=$(cat /proc/device-tree/compatible) | ||
24 | |||
25 | cd /usr/lib | ||
26 | case "$compatible" in | ||
27 | *k2hk*) | ||
28 | device=k2hk | ||
29 | ln -sf libqmss_k2h.so.1.0.0 libqmss_device.so.1 | ||
30 | ;; | ||
31 | *k2l*) | ||
32 | device=k2l | ||
33 | ln -sf libqmss_k2l.so.1.0.0 libqmss_device.so.1 | ||
34 | ;; | ||
35 | *k2e*) | ||
36 | device=k2e | ||
37 | ln -sf libqmss_k2e.so.1.0.0 libqmss_device.so.1 | ||
38 | ;; | ||
39 | *) | ||
40 | device=unknown | ||
41 | ;; | ||
42 | esac | ||
43 | |||
44 | if [ $device != unknown ]; then | ||
45 | ln -sf libqmss_device.so.1 libqmss_device.so | ||
46 | echo qmss library link established for device : $device | ||
47 | fi | ||
diff --git a/recipes-bsp/qmss-lld/qmss-lld-test_git.bb b/recipes-bsp/qmss-lld/qmss-lld-test_git.bb index 7c19364f..60a35b12 100644 --- a/recipes-bsp/qmss-lld/qmss-lld-test_git.bb +++ b/recipes-bsp/qmss-lld/qmss-lld-test_git.bb | |||
@@ -1,11 +1,10 @@ | |||
1 | DESCRIPTION = "TI QMSS low level driver unit test and example binaries" | 1 | DESCRIPTION = "TI QMSS low level driver unit test and example binaries" |
2 | COMPATIBLE_MACHINE = "keystone" | ||
3 | 2 | ||
4 | DEPENDS="common-csl-ip rm-lld cppi-lld qmss-lld" | 3 | DEPENDS="common-csl-ip rm-lld cppi-lld qmss-lld" |
5 | 4 | ||
6 | include qmss-lld.inc | 5 | include qmss-lld.inc |
7 | 6 | ||
8 | PR = "${INC_PR}.0" | 7 | PR = "${INC_PR}.1" |
9 | 8 | ||
10 | CHOICELIST = "yes no" | 9 | CHOICELIST = "yes no" |
11 | 10 | ||
diff --git a/recipes-bsp/qmss-lld/qmss-lld.inc b/recipes-bsp/qmss-lld/qmss-lld.inc index efd681e4..1cf9b0b2 100644 --- a/recipes-bsp/qmss-lld/qmss-lld.inc +++ b/recipes-bsp/qmss-lld/qmss-lld.inc | |||
@@ -1,6 +1,9 @@ | |||
1 | LICENSE = "BSD-3-Clause" | 1 | LICENSE = "BSD-3-Clause" |
2 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/qmss/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d" | 2 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/qmss/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d" |
3 | 3 | ||
4 | COMPATIBLE_MACHINE = "keystone" | ||
5 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
6 | |||
4 | QMSS_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/qmss-lld.git" | 7 | QMSS_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/qmss-lld.git" |
5 | QMSS_LLD_GIT_PROTOCOL = "git" | 8 | QMSS_LLD_GIT_PROTOCOL = "git" |
6 | QMSS_LLD_GIT_BRANCH = "master" | 9 | QMSS_LLD_GIT_BRANCH = "master" |
@@ -16,6 +19,8 @@ SRCREV = "${QMSS_LLD_SRCREV}" | |||
16 | PV = "02.01.00.11" | 19 | PV = "02.01.00.11" |
17 | INC_PR = "r1" | 20 | INC_PR = "r1" |
18 | 21 | ||
19 | DEVICELIST = "k2h k2k k2l k2e" | 22 | DEVICELIST_k2hk-evm = "k2h k2k" |
23 | DEVICELIST_k2l-evm = "k2l" | ||
24 | DEVICELIST_k2e-evm = "k2e" | ||
20 | 25 | ||
21 | S = "${WORKDIR}/${QMSS_LLD_GIT_DESTSUFFIX}" | 26 | S = "${WORKDIR}/${QMSS_LLD_GIT_DESTSUFFIX}" |
diff --git a/recipes-bsp/qmss-lld/qmss-lld_git.bb b/recipes-bsp/qmss-lld/qmss-lld_git.bb index 83c9a7e3..813929ec 100644 --- a/recipes-bsp/qmss-lld/qmss-lld_git.bb +++ b/recipes-bsp/qmss-lld/qmss-lld_git.bb | |||
@@ -1,18 +1,10 @@ | |||
1 | DESCRIPTION = "TI QMSS low level driver library" | 1 | DESCRIPTION = "TI QMSS low level driver library" |
2 | COMPATIBLE_MACHINE = "keystone" | ||
3 | 2 | ||
4 | DEPENDS="common-csl-ip rm-lld" | 3 | DEPENDS="common-csl-ip rm-lld" |
5 | 4 | ||
6 | include qmss-lld.inc | 5 | include qmss-lld.inc |
7 | 6 | ||
8 | PR = "${INC_PR}.0" | 7 | PR = "${INC_PR}.1" |
9 | |||
10 | SRC_URI += "file://init_qmss.sh" | ||
11 | |||
12 | inherit update-rc.d | ||
13 | |||
14 | INITSCRIPT_NAME = "init_qmss.sh" | ||
15 | INITSCRIPT_PARAMS = "defaults 10" | ||
16 | 8 | ||
17 | do_compile () { | 9 | do_compile () { |
18 | # Now build the lld | 10 | # Now build the lld |
@@ -27,11 +19,14 @@ do_compile () { | |||
27 | do_install () { | 19 | do_install () { |
28 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} | 20 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} |
29 | 21 | ||
30 | # Set the generic device library symbolic link to default k2h | 22 | # Set the generic device library symbolic link to default k2h |
31 | cd ${D}${libdir} | 23 | cd ${D}${libdir} |
32 | ln -sf libqmss_k2h.so.1.0.0 libqmss_device.so.1 | 24 | |
25 | # Link only the first device in the list | ||
26 | for device in ${DEVICELIST} | ||
27 | do | ||
28 | ln -sf libqmss_${device}.so.1.0.0 libqmss_device.so.1 | ||
29 | break | ||
30 | done | ||
33 | ln -sf libqmss_device.so.1 libqmss_device.so | 31 | ln -sf libqmss_device.so.1 libqmss_device.so |
34 | # Copy init scripts | ||
35 | install -d ${D}${sysconfdir}/init.d/ | ||
36 | install -c -m 755 ${WORKDIR}/init_qmss.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
37 | } | 32 | } |