summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README7
-rw-r--r--recipes-core/packagegroups/packagegroup-ti-test.bb (renamed from recipes-ti/packagegroup/packagegroup-ti-test.bb)8
-rw-r--r--recipes-misc/images/cloud9-gfx-image.bb15
-rw-r--r--recipes-misc/images/cloud9-gnome-image.bb19
-rw-r--r--recipes-misc/images/cloud9-image.bb37
-rw-r--r--recipes-misc/images/ti-hw-bringup-image.bb32
-rw-r--r--recipes-misc/packagegroup/packagegroup-ti-drivers.bb34
-rw-r--r--recipes-ti/README1
-rw-r--r--recipes-ti/beagleboard/beaglebone-getting-started.bb (renamed from recipes-misc/payload/beaglebone-getting-started.bb)0
-rw-r--r--recipes-ti/beagleboard/bonescript.bb (renamed from recipes-misc/payload/bonescript.bb)0
-rw-r--r--recipes-ti/beagleboard/bonescript/bone101.service (renamed from recipes-misc/payload/bonescript/bone101.service)0
-rw-r--r--recipes-ti/beagleboard/bonescript/bonescript-git (renamed from recipes-misc/payload/bonescript/bonescript-git)0
-rw-r--r--recipes-ti/matrix/README5
-rw-r--r--recipes-ti/matrix/files/0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch31
14 files changed, 6 insertions, 183 deletions
diff --git a/README b/README
index 0df391f1..61ed5a37 100644
--- a/README
+++ b/README
@@ -11,12 +11,6 @@ layers: meta
11branch: master 11branch: master
12 12
13 13
14When not depending on meta-openembedded and not using systemd, you may need to
15mask few miscellaneous recipes requiring systemd, by adding this to local.conf:
16
17BBMASK = "meta-ti/recipes-misc"
18
19
20The base BSP part of meta-ti should work with different OpenEmbedded/Yocto 14The base BSP part of meta-ti should work with different OpenEmbedded/Yocto
21distributions and layer stacks, such as: 15distributions and layer stacks, such as:
22distro-less (only with OE-Core), with Yocto/Poky, with Angstrom or Arago. 16distro-less (only with OE-Core), with Yocto/Poky, with Angstrom or Arago.
@@ -27,4 +21,3 @@ Please follow the recommended setup procedures of your OE distribution.
27Send pull requests, patches, comments or questions to meta-ti@yoctoproject.org 21Send pull requests, patches, comments or questions to meta-ti@yoctoproject.org
28 22
29Maintainers: Denys Dmytriyenko <denys@ti.com> 23Maintainers: Denys Dmytriyenko <denys@ti.com>
30 Koen Kooi <koen@dominion.thruhere.net>
diff --git a/recipes-ti/packagegroup/packagegroup-ti-test.bb b/recipes-core/packagegroups/packagegroup-ti-test.bb
index fc19bc56..6971f07d 100644
--- a/recipes-ti/packagegroup/packagegroup-ti-test.bb
+++ b/recipes-core/packagegroups/packagegroup-ti-test.bb
@@ -1,8 +1,8 @@
1DESCRIPTION = "Extended task to get System Test specific apps" 1DESCRIPTION = "Extended task to get System Test specific apps"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" 3PR = "r1"
4 4
5inherit allarch packagegroup 5inherit packagegroup
6 6
7TEST = "\ 7TEST = "\
8 bonnie++ \ 8 bonnie++ \
@@ -11,6 +11,9 @@ TEST = "\
11 iperf \ 11 iperf \
12 lmbench \ 12 lmbench \
13 rt-tests \ 13 rt-tests \
14 evtest \
15 bc \
16 memtester \
14 " 17 "
15 18
16TI_TEST = "\ 19TI_TEST = "\
@@ -21,4 +24,3 @@ RDEPENDS_${PN} = "\
21 ${TEST} \ 24 ${TEST} \
22 ${TI_TEST} \ 25 ${TI_TEST} \
23 " 26 "
24
diff --git a/recipes-misc/images/cloud9-gfx-image.bb b/recipes-misc/images/cloud9-gfx-image.bb
deleted file mode 100644
index 67423f61..00000000
--- a/recipes-misc/images/cloud9-gfx-image.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1# Image with cloud9 ide, gfx and hw tools installed
2
3require cloud9-image.bb
4
5IMAGE_INSTALL += " \
6 packagegroup-core-x11-xserver \
7 angstrom-gnome-icon-theme-enable gtk-engine-clearlooks gtk-theme-clearlooks angstrom-clearlooks-theme-enable \
8 e-wm-config-default e-wm-config-standard e-wm-config-illume2 \
9 xserver-nodm-init \
10 xserver-common \
11 ttf-dejavu-sans ttf-dejavu-sans-mono ttf-dejavu-common \
12 "
13
14export IMAGE_BASENAME = "Cloud9-IDE-gfx"
15
diff --git a/recipes-misc/images/cloud9-gnome-image.bb b/recipes-misc/images/cloud9-gnome-image.bb
deleted file mode 100644
index c1832446..00000000
--- a/recipes-misc/images/cloud9-gnome-image.bb
+++ /dev/null
@@ -1,19 +0,0 @@
1# Image with cloud9 ide, gfx and hw tools installed
2
3require cloud9-image.bb
4
5# SoC specific packages, mostly 3D or multimedia related
6SOCSUPPORT = ""
7SOCSUPPORT_omap3 = "xbmc libgles-omap3-x11demos gstreamer-ti omapfbplay"
8SOCSUPPORT_ti33x = "xbmc libgles-omap3-x11demos gst-ffmpeg mplayer2 beaglebone-capes"
9
10IMAGE_INSTALL += " \
11 angstrom-packagegroup-gnome gimp abiword gedit midori epiphany firefox matchbox-terminal \
12 ${SOCSUPPORT} \
13 ttf-dejavu-sans ttf-dejavu-sans-mono ttf-dejavu-common \
14 xinput-calibrator \
15 xterm \
16 "
17
18export IMAGE_BASENAME = "Cloud9-IDE-GNOME"
19
diff --git a/recipes-misc/images/cloud9-image.bb b/recipes-misc/images/cloud9-image.bb
deleted file mode 100644
index 519a8bba..00000000
--- a/recipes-misc/images/cloud9-image.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1# Image with cloud9 ide and hw tools installed
2
3require ti-hw-bringup-image.bb
4
5FATPAYLOAD = "${datadir}/beaglebone-getting-started/*"
6
7ROOTFSTYPE_beaglebone = "ext4"
8
9IMAGE_INSTALL += " \
10 systemd-analyze \
11 cloud9 \
12 packagegroup-sdk-target \
13 vim vim-vimrc \
14 procps \
15 beaglebone-tester \
16 screen minicom \
17 git \
18 beaglebone-getting-started bonescript \
19 led-config \
20 opencv-dev \
21 cronie-systemd ntpdate \
22 nano \
23 minicom \
24 hicolor-icon-theme \
25 gateone \
26 tar \
27 gdb gdbserver \
28 nodejs-dev \
29 mplayer2 \
30 tslib-tests tslib-calibrate \
31 iproute2 canutils \
32 connman-tests \
33 rsync \
34"
35
36export IMAGE_BASENAME = "Cloud9-IDE"
37
diff --git a/recipes-misc/images/ti-hw-bringup-image.bb b/recipes-misc/images/ti-hw-bringup-image.bb
deleted file mode 100644
index 62b4c73f..00000000
--- a/recipes-misc/images/ti-hw-bringup-image.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1# Image for assisting in hardware bringup
2
3include recipes-images/angstrom/systemd-image.bb
4
5EXTRA_MACHINE_IMAGE_INSTALL ?= ""
6
7# Hokey-pokey workaround for MUSB bugs
8EXTRA_MACHINE_IMAGE_INSTALL_ti33x = "gadget-init"
9
10IMAGE_INSTALL += " \
11 usbutils \
12 i2c-tools \
13 alsa-utils \
14 devmem2 \
15 iw \
16 bonnie++ \
17 hdparm \
18 iozone3 \
19 iperf \
20 lmbench \
21 rt-tests \
22 evtest \
23 bc \
24 packagegroup-ti-test \
25 kernel-modules \
26 ${EXTRA_MACHINE_IMAGE_INSTALL} \
27"
28
29export IMAGE_BASENAME = "TI-hw-bringup"
30
31# This doesn't work with the current genext2fs in oe-core
32# inherit sdcard_image
diff --git a/recipes-misc/packagegroup/packagegroup-ti-drivers.bb b/recipes-misc/packagegroup/packagegroup-ti-drivers.bb
deleted file mode 100644
index b391fac4..00000000
--- a/recipes-misc/packagegroup/packagegroup-ti-drivers.bb
+++ /dev/null
@@ -1,34 +0,0 @@
1DESCRIPTION = "Task for extra drivers for Texas Instruments SoCs"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
4
5inherit packagegroup
6
7RDEPENDS_${PN} = "\
8 zd1211-firmware \
9 linux-firmware-wl12xx \
10 rfkill \
11 cpufrequtils \
12 "
13
14RRECOMMENDS_${PN} = "\
15 \
16 kernel-module-bluetooth \
17 kernel-module-hci-usb \
18 kernel-module-hci-uart \
19 \
20 kernel-module-wl12xx \
21 kernel-module-wl12xx-sdio \
22 kernel-module-wl12xx-spi \
23 \
24 kernel-module-wl1271 \
25 kernel-module-wl1271-sdio \
26 kernel-module-wl1271-spi \
27 kernel-module-btwilink \
28 \
29 kernel-module-rt73usb \
30 kernel-module-rt2x00usb \
31 kernel-module-zd1211rw \
32 \
33 omap3-sgx-modules \
34 "
diff --git a/recipes-ti/README b/recipes-ti/README
new file mode 100644
index 00000000..9907901a
--- /dev/null
+++ b/recipes-ti/README
@@ -0,0 +1 @@
Note: many of the packages in this area are not actively maintained.
diff --git a/recipes-misc/payload/beaglebone-getting-started.bb b/recipes-ti/beagleboard/beaglebone-getting-started.bb
index 603a01a7..603a01a7 100644
--- a/recipes-misc/payload/beaglebone-getting-started.bb
+++ b/recipes-ti/beagleboard/beaglebone-getting-started.bb
diff --git a/recipes-misc/payload/bonescript.bb b/recipes-ti/beagleboard/bonescript.bb
index b9dfbe63..b9dfbe63 100644
--- a/recipes-misc/payload/bonescript.bb
+++ b/recipes-ti/beagleboard/bonescript.bb
diff --git a/recipes-misc/payload/bonescript/bone101.service b/recipes-ti/beagleboard/bonescript/bone101.service
index 49562ba4..49562ba4 100644
--- a/recipes-misc/payload/bonescript/bone101.service
+++ b/recipes-ti/beagleboard/bonescript/bone101.service
diff --git a/recipes-misc/payload/bonescript/bonescript-git b/recipes-ti/beagleboard/bonescript/bonescript-git
index d9e66cfb..d9e66cfb 100644
--- a/recipes-misc/payload/bonescript/bonescript-git
+++ b/recipes-ti/beagleboard/bonescript/bonescript-git
diff --git a/recipes-ti/matrix/README b/recipes-ti/matrix/README
deleted file mode 100644
index ed775960..00000000
--- a/recipes-ti/matrix/README
+++ /dev/null
@@ -1,5 +0,0 @@
1Matrix app has been moved to meta-arago-extras layer of the meta-arago repo:
2git://arago-project.org/git/meta-arago.git
3
4This meta-arago-extras layer is distro-agnostic and not Arago-specific, so
5it can be used with any OE-Core based distribution.
diff --git a/recipes-ti/matrix/files/0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch b/recipes-ti/matrix/files/0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch
deleted file mode 100644
index 324f9808..00000000
--- a/recipes-ti/matrix/files/0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From 420cadec0f7a6048a0fafccf4c658d543b7dbf19 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <k-kooi@ti.com>
3Date: Tue, 26 Jul 2011 14:25:39 +0200
4Subject: [PATCH] matrix_gui.pro: add dbus to QT features to fix linking with -Wl,--as-needed
5
6This fixes:
7
8| ccache arm-angstrom-linux-gnueabi-g++ -march=armv7-a -mtune=cortex-a8 -mfpu=neon -mfloat-abi=softfp -fno-tree-vectorize -mthumb-interwork -mno-thumb --sysroot=/home/koen/angstrom-core/build/tmp-angstrom_2010_x-eglibc/sysroots/beagleboard -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,-rpath-link,/home/koen/angstrom-core/build/tmp-angstrom_2010_x-eglibc/sysroots/beagleboard/usr/lib -o matrix_gui main.o mainwindow.o buttonfactory.o buttonlaunch.o customstyle.o menupage.o osdmanager.o matrixcontrol.o moc_mainwindow.o moc_buttonfactory.o moc_buttonlaunch.o moc_customstyle.o moc_menupage.o moc_osdmanager.o moc_matrixcontrol.o -L/home/koen/angstrom-core/build/tmp-angstrom_2010_x-eglibc/sysroots/beagleboard/usr/lib -lpng -lfreetype -lz -lgthread-2.0 -lQtWebKit -lQtGui -lQtNetwork -lQtCore -lpthread
9| ux-gnueabi/4.5.4/ld: }: invalid DSO for symbol `QDBusConnection::registerService(QString const&)' definition
10| /home/koen/angstrom-core/build/tmp-angstrom_2010_x-eglibc/sysroots/beagleboard/usr/lib/libQtDBus.so.4: could not read symbols: Bad value
11| collect2: ld returned 1 exit status
12
13Signed-off-by: Koen Kooi <k-kooi@ti.com>
14---
15 matrix_gui.pro | 3 ++-
16 1 files changed, 2 insertions(+), 1 deletions(-)
17
18diff --git a/matrix_gui.pro b/matrix_gui.pro
19index 5463310..908e8a7 100644
20--- a/matrix_gui.pro
21+++ b/matrix_gui.pro
22@@ -1,4 +1,5 @@
23-QT += webkit \
24+QT += dbus \
25+ webkit \
26 network
27 LIBS += -lpng -lfreetype -lz -lgthread-2.0
28 HEADERS = mainwindow.h \
29--
301.7.4.4
31