diff options
-rw-r--r-- | conf/machine/include/ti33x.inc | 2 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti33x-psp-3.1/beaglebone/defconfig | 8 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti33x-psp_3.1.bb | 6 |
3 files changed, 9 insertions, 7 deletions
diff --git a/conf/machine/include/ti33x.inc b/conf/machine/include/ti33x.inc index 7cc694f0..3807fbbe 100644 --- a/conf/machine/include/ti33x.inc +++ b/conf/machine/include/ti33x.inc | |||
@@ -3,7 +3,7 @@ SOC_FAMILY = "ti33x" | |||
3 | require conf/machine/include/tune-cortexa8.inc | 3 | require conf/machine/include/tune-cortexa8.inc |
4 | PREFERRED_PROVIDER_virtual/kernel = "linux-ti33x-psp" | 4 | PREFERRED_PROVIDER_virtual/kernel = "linux-ti33x-psp" |
5 | # Increase this everytime you change something in the kernel | 5 | # Increase this everytime you change something in the kernel |
6 | MACHINE_KERNEL_PR = "r1" | 6 | MACHINE_KERNEL_PR = "r2" |
7 | 7 | ||
8 | KERNEL_IMAGETYPE = "uImage" | 8 | KERNEL_IMAGETYPE = "uImage" |
9 | 9 | ||
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.1/beaglebone/defconfig b/recipes-kernel/linux/linux-ti33x-psp-3.1/beaglebone/defconfig index f1a014cb..c29060f8 100644 --- a/recipes-kernel/linux/linux-ti33x-psp-3.1/beaglebone/defconfig +++ b/recipes-kernel/linux/linux-ti33x-psp-3.1/beaglebone/defconfig | |||
@@ -990,7 +990,7 @@ CONFIG_MISC_DEVICES=y | |||
990 | # CONFIG_HMC6352 is not set | 990 | # CONFIG_HMC6352 is not set |
991 | # CONFIG_DS1682 is not set | 991 | # CONFIG_DS1682 is not set |
992 | # CONFIG_TI_DAC7512 is not set | 992 | # CONFIG_TI_DAC7512 is not set |
993 | # CONFIG_BMP085 is not set | 993 | CONFIG_BMP085=m |
994 | # CONFIG_USB_SWITCH_FSA9480 is not set | 994 | # CONFIG_USB_SWITCH_FSA9480 is not set |
995 | # CONFIG_C2PORT is not set | 995 | # CONFIG_C2PORT is not set |
996 | 996 | ||
@@ -1390,7 +1390,9 @@ CONFIG_INPUT_TWL4030_PWRBUTTON=y | |||
1390 | # CONFIG_INPUT_UINPUT is not set | 1390 | # CONFIG_INPUT_UINPUT is not set |
1391 | # CONFIG_INPUT_PCF8574 is not set | 1391 | # CONFIG_INPUT_PCF8574 is not set |
1392 | # CONFIG_INPUT_GPIO_ROTARY_ENCODER is not set | 1392 | # CONFIG_INPUT_GPIO_ROTARY_ENCODER is not set |
1393 | # CONFIG_INPUT_ADXL34X is not set | 1393 | CONFIG_INPUT_ADXL34X=m |
1394 | CONFIG_INPUT_ADXL34X_I2C=m | ||
1395 | CONFIG_INPUT_ADXL34X_SPI=m | ||
1394 | # CONFIG_INPUT_CMA3000 is not set | 1396 | # CONFIG_INPUT_CMA3000 is not set |
1395 | 1397 | ||
1396 | # | 1398 | # |
@@ -1703,7 +1705,7 @@ CONFIG_HWMON=y | |||
1703 | # CONFIG_SENSORS_ADS7871 is not set | 1705 | # CONFIG_SENSORS_ADS7871 is not set |
1704 | # CONFIG_SENSORS_AMC6821 is not set | 1706 | # CONFIG_SENSORS_AMC6821 is not set |
1705 | # CONFIG_SENSORS_THMC50 is not set | 1707 | # CONFIG_SENSORS_THMC50 is not set |
1706 | # CONFIG_SENSORS_TMP102 is not set | 1708 | CONFIG_SENSORS_TMP102=m |
1707 | # CONFIG_SENSORS_TMP401 is not set | 1709 | # CONFIG_SENSORS_TMP401 is not set |
1708 | # CONFIG_SENSORS_TMP421 is not set | 1710 | # CONFIG_SENSORS_TMP421 is not set |
1709 | # CONFIG_SENSORS_VT1211 is not set | 1711 | # CONFIG_SENSORS_VT1211 is not set |
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.1.bb b/recipes-kernel/linux/linux-ti33x-psp_3.1.bb index bbe66ff7..096fbb28 100644 --- a/recipes-kernel/linux/linux-ti33x-psp_3.1.bb +++ b/recipes-kernel/linux/linux-ti33x-psp_3.1.bb | |||
@@ -9,9 +9,9 @@ S = "${WORKDIR}/git" | |||
9 | 9 | ||
10 | MULTI_CONFIG_BASE_SUFFIX = "" | 10 | MULTI_CONFIG_BASE_SUFFIX = "" |
11 | 11 | ||
12 | BRANCH = "v3.1-staging" | 12 | BRANCH = "v3.1-meta-ti-r1r+gitr1d84d8853fa30cf3db2571a5aec572accca4e29d" |
13 | SRCREV = "1d84d8853fa30cf3db2571a5aec572accca4e29d" | 13 | SRCREV = "1d84d8853fa30cf3db2571a5aec572accca4e29d" |
14 | MACHINE_KERNEL_PR_append = "t+gitr${SRCREV}" | 14 | MACHINE_KERNEL_PR_append = "a+gitr${SRCREV}" |
15 | 15 | ||
16 | COMPATIBLE_MACHINE = "(ti33x)" | 16 | COMPATIBLE_MACHINE = "(ti33x)" |
17 | 17 | ||
@@ -21,7 +21,7 @@ ${@base_set_filespath(["${THISDIR}/${PN}/tipspkernel"], d)}:\ | |||
21 | ${@base_set_filespath(["${THISDIR}/files/tipspkernel"], d)}:" | 21 | ${@base_set_filespath(["${THISDIR}/files/tipspkernel"], d)}:" |
22 | FILESPATH =. "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "${CONFIGS_PSP}", "", d)}" | 22 | FILESPATH =. "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "${CONFIGS_PSP}", "", d)}" |
23 | 23 | ||
24 | SRC_URI += "git://arago-project.org/git/projects/linux-am33x.git;protocol=git;branch=${BRANCH} \ | 24 | SRC_URI += "git://github.com/beagleboard/linux.git;branch=${BRANCH} \ |
25 | file://defconfig" | 25 | file://defconfig" |
26 | 26 | ||
27 | PATCHES_OVER_PSP = " \ | 27 | PATCHES_OVER_PSP = " \ |