summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/ti-pdk.bbclass2
-rw-r--r--recipes-bsp/ipumm-fw/ipumm-fw_git.bb2
-rw-r--r--recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb6
-rw-r--r--recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb6
-rw-r--r--recipes-kernel/linux/cmem.inc16
-rw-r--r--recipes-ti/devtools/ti-cgt6x_8.2.2.bb8
-rw-r--r--recipes-ti/includes/ti-unpack.inc12
7 files changed, 26 insertions, 26 deletions
diff --git a/classes/ti-pdk.bbclass b/classes/ti-pdk.bbclass
index 540a665c..7ad6205d 100644
--- a/classes/ti-pdk.bbclass
+++ b/classes/ti-pdk.bbclass
@@ -67,7 +67,7 @@ PARALLEL_XDC = "--jobs=${BB_NUMBER_THREADS}"
67PARALLEL_MAKE = "" 67PARALLEL_MAKE = ""
68 68
69def get_doxygen_support(d): 69def get_doxygen_support(d):
70 if d.getVar('TI_PDK_DOXYGEN_SUPPORT', True) == '1': 70 if d.getVar('TI_PDK_DOXYGEN_SUPPORT') == '1':
71 return '' 71 return ''
72 return 'DOXYGEN_SUPPORT=no' 72 return 'DOXYGEN_SUPPORT=no'
73 73
diff --git a/recipes-bsp/ipumm-fw/ipumm-fw_git.bb b/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
index 761210e7..22a8c4f8 100644
--- a/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
+++ b/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
@@ -1,5 +1,5 @@
1python __anonymous() { 1python __anonymous() {
2 features = d.getVar("MACHINE_FEATURES", d, 1) 2 features = d.getVar("MACHINE_FEATURES")
3 if not features: 3 if not features:
4 return 4 return
5 if "mmip" not in features: 5 if "mmip" not in features:
diff --git a/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb b/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
index 52df495d..dafaac1e 100644
--- a/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
+++ b/recipes-graphics/libgal/ti-gc320-libs_5.0.11.p7.bb
@@ -14,11 +14,11 @@ SRCREV = "c0afab259de59909cfe74c01f3f7fbaa147f94b5"
14 14
15# There's only hardfp version available 15# There's only hardfp version available
16python __anonymous() { 16python __anonymous() {
17 tunes = d.getVar("TUNE_FEATURES", d, 1) 17 tunes = d.getVar("TUNE_FEATURES")
18 if not tunes: 18 if not tunes:
19 return 19 return
20 pkgn = d.getVar("PN", d, 1) 20 pkgn = d.getVar("PN")
21 pkgv = d.getVar("PV", d, 1) 21 pkgv = d.getVar("PV")
22 if "callconvention-hard" not in tunes: 22 if "callconvention-hard" not in tunes:
23 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) 23 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
24 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) 24 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
diff --git a/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb b/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
index 282a4ab2..d17411ec 100644
--- a/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
+++ b/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb
@@ -12,11 +12,11 @@ SRCREV = "358fe42d34a7570896e5d1639869da564ddd0484"
12 12
13# There's only hardfp version available 13# There's only hardfp version available
14python __anonymous() { 14python __anonymous() {
15 tunes = d.getVar("TUNE_FEATURES", d, 1) 15 tunes = d.getVar("TUNE_FEATURES")
16 if not tunes: 16 if not tunes:
17 return 17 return
18 pkgn = d.getVar("PN", d, 1) 18 pkgn = d.getVar("PN")
19 pkgv = d.getVar("PV", d, 1) 19 pkgv = d.getVar("PV")
20 if "callconvention-hard" not in tunes: 20 if "callconvention-hard" not in tunes:
21 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) 21 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
22 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) 22 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
diff --git a/recipes-kernel/linux/cmem.inc b/recipes-kernel/linux/cmem.inc
index ad122799..8325c00f 100644
--- a/recipes-kernel/linux/cmem.inc
+++ b/recipes-kernel/linux/cmem.inc
@@ -39,13 +39,13 @@ python do_unpack() {
39 # Initialize with empty string to simplify logic to append to SRC_URI 39 # Initialize with empty string to simplify logic to append to SRC_URI
40 cmem_dtsi = set(['']) 40 cmem_dtsi = set([''])
41 41
42 for cmem_machine in (d.getVar('CMEM_MACHINE', True) or '').split(): 42 for cmem_machine in (d.getVar('CMEM_MACHINE') or '').split():
43 # Create copy of data for additional override 43 # Create copy of data for additional override
44 localdata = bb.data.createCopy(d) 44 localdata = bb.data.createCopy(d)
45 localdata.setVar('OVERRIDES', '%s:%s' % (cmem_machine, old_overrides)) 45 localdata.setVar('OVERRIDES', '%s:%s' % (cmem_machine, old_overrides))
46 bb.data.update_data(localdata) 46 bb.data.update_data(localdata)
47 47
48 cmem_dtsi.add(localdata.getVar('CMEM_DTSI', True)) 48 cmem_dtsi.add(localdata.getVar('CMEM_DTSI'))
49 49
50 d.appendVar('SRC_URI', ' file://'.join(cmem_dtsi)) 50 d.appendVar('SRC_URI', ' file://'.join(cmem_dtsi))
51 bb.build.exec_func('base_do_unpack', d) 51 bb.build.exec_func('base_do_unpack', d)
@@ -56,27 +56,27 @@ python do_setup_cmem() {
56 56
57 old_overrides = d.getVar('OVERRIDES', False) 57 old_overrides = d.getVar('OVERRIDES', False)
58 58
59 if d.getVar('RESERVE_CMEM', True) is '1': 59 if d.getVar('RESERVE_CMEM') is '1':
60 for cmem_machine in (d.getVar('CMEM_MACHINE', True) or '').split(): 60 for cmem_machine in (d.getVar('CMEM_MACHINE') or '').split():
61 # Create copy of data for additional override 61 # Create copy of data for additional override
62 localdata = bb.data.createCopy(d) 62 localdata = bb.data.createCopy(d)
63 localdata.setVar('OVERRIDES', '%s:%s' % (cmem_machine, old_overrides)) 63 localdata.setVar('OVERRIDES', '%s:%s' % (cmem_machine, old_overrides))
64 bb.data.update_data(localdata) 64 bb.data.update_data(localdata)
65 65
66 # Get source directory and dtsi filename 66 # Get source directory and dtsi filename
67 src_dir = localdata.getVar('WORKDIR', True) 67 src_dir = localdata.getVar('WORKDIR')
68 src_dtsi = localdata.getVar('CMEM_DTSI', True) 68 src_dtsi = localdata.getVar('CMEM_DTSI')
69 69
70 # Get destination directory and destination dtsi filename which adds 70 # Get destination directory and destination dtsi filename which adds
71 # the MACHINE prefix. 71 # the MACHINE prefix.
72 dst_dir = os.path.join(localdata.getVar('S', True), 'arch/arm/boot/dts') 72 dst_dir = os.path.join(localdata.getVar('S'), 'arch/arm/boot/dts')
73 dst_dtsi = localdata.expand('${MACHINE}-${CMEM_DTSI}') 73 dst_dtsi = localdata.expand('${MACHINE}-${CMEM_DTSI}')
74 74
75 # Copy cmem.dtsi into source tree 75 # Copy cmem.dtsi into source tree
76 shutil.copy(os.path.join(src_dir,src_dtsi), os.path.join(dst_dir,dst_dtsi)) 76 shutil.copy(os.path.join(src_dir,src_dtsi), os.path.join(dst_dir,dst_dtsi))
77 77
78 # Inject dtsi into each dts in list 78 # Inject dtsi into each dts in list
79 for dtb in (localdata.getVar('CMEM_DEVICETREE', True) or '').split(): 79 for dtb in (localdata.getVar('CMEM_DEVICETREE') or '').split():
80 dts = dtb[:-4] + '.dts' 80 dts = dtb[:-4] + '.dts'
81 81
82 with open(os.path.join(dst_dir,dts), 'a') as dts_file: 82 with open(os.path.join(dst_dir,dts), 'a') as dts_file:
diff --git a/recipes-ti/devtools/ti-cgt6x_8.2.2.bb b/recipes-ti/devtools/ti-cgt6x_8.2.2.bb
index 04e55ae9..53f52526 100644
--- a/recipes-ti/devtools/ti-cgt6x_8.2.2.bb
+++ b/recipes-ti/devtools/ti-cgt6x_8.2.2.bb
@@ -13,14 +13,14 @@ COMPATIBLE_HOST_class-target = "arm.*-linux"
13 13
14# For now we only have hardfp version for target class 14# For now we only have hardfp version for target class
15python __anonymous() { 15python __anonymous() {
16 c = d.getVar("CLASSOVERRIDE", d, 1) 16 c = d.getVar("CLASSOVERRIDE")
17 17
18 if c == "class-target": 18 if c == "class-target":
19 tunes = d.getVar("TUNE_FEATURES", d, 1) 19 tunes = d.getVar("TUNE_FEATURES")
20 if not tunes: 20 if not tunes:
21 return 21 return
22 pkgn = d.getVar("PN", d, 1) 22 pkgn = d.getVar("PN")
23 pkgv = d.getVar("PV", d, 1) 23 pkgv = d.getVar("PV")
24 if "callconvention-hard" not in tunes: 24 if "callconvention-hard" not in tunes:
25 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) 25 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
26 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) 26 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
diff --git a/recipes-ti/includes/ti-unpack.inc b/recipes-ti/includes/ti-unpack.inc
index cc315dff..a571fd5d 100644
--- a/recipes-ti/includes/ti-unpack.inc
+++ b/recipes-ti/includes/ti-unpack.inc
@@ -29,21 +29,21 @@ python ti_bin_do_unpack() {
29 localdata = bb.data.createCopy(d) 29 localdata = bb.data.createCopy(d)
30 bb.data.update_data(localdata) 30 bb.data.update_data(localdata)
31 31
32 binfile = d.getVar('BINFILE', localdata) 32 binfile = localdata.getVar('BINFILE')
33 binfile = bb.data.expand(binfile, localdata) 33 binfile = bb.data.expand(binfile, localdata)
34 34
35 # Change to the working directory 35 # Change to the working directory
36 save_cwd = os.getcwd() 36 save_cwd = os.getcwd()
37 workdir = d.getVar('WORKDIR', localdata) 37 workdir = localdata.getVar('WORKDIR')
38 workdir = bb.data.expand(workdir, localdata) 38 workdir = bb.data.expand(workdir, localdata)
39 os.chdir(workdir) 39 os.chdir(workdir)
40 40
41 # Get unpack args 41 # Get unpack args
42 arg_string = d.getVar('TI_BIN_UNPK_ARGS', localdata) 42 arg_string = localdata.getVar('TI_BIN_UNPK_ARGS')
43 arg_string = bb.data.expand(arg_string, localdata) 43 arg_string = bb.data.expand(arg_string, localdata)
44 44
45 # Get unpack commands 45 # Get unpack commands
46 cmd_string = d.getVar('TI_BIN_UNPK_CMDS', localdata) 46 cmd_string = localdata.getVar('TI_BIN_UNPK_CMDS')
47 cmd_list = cmd_string.split( ":" ) 47 cmd_list = cmd_string.split( ":" )
48 48
49 # Make the InstallJammer binary executable so we can run it 49 # Make the InstallJammer binary executable so we can run it
@@ -61,14 +61,14 @@ python ti_bin_do_unpack() {
61 f = os.popen(filename,'w') 61 f = os.popen(filename,'w')
62 for cmd in cmd_list: 62 for cmd in cmd_list:
63 if cmd == "workdir": 63 if cmd == "workdir":
64 wdext = d.getVar('TI_BIN_UNPK_WDEXT', localdata) 64 wdext = localdata.getVar('TI_BIN_UNPK_WDEXT')
65 wdext = bb.data.expand(wdext, localdata) 65 wdext = bb.data.expand(wdext, localdata)
66 cmd = workdir+wdext 66 cmd = workdir+wdext
67 f.write(cmd+'\n'); 67 f.write(cmd+'\n');
68 f.close() 68 f.close()
69 69
70 # Expand the tarball that was created if required 70 # Expand the tarball that was created if required
71 tarfile = d.getVar('TARFILE', localdata) 71 tarfile = localdata.getVar('TARFILE')
72 if bool(tarfile) == True: 72 if bool(tarfile) == True:
73 tarfile = bb.data.expand(tarfile, localdata) 73 tarfile = bb.data.expand(tarfile, localdata)
74 tcmd = 'tar x --no-same-owner -f %s -C %s' % (tarfile, workdir) 74 tcmd = 'tar x --no-same-owner -f %s -C %s' % (tarfile, workdir)