diff options
-rw-r--r-- | recipes-ti/devtools/ti-cgt-pru_2.1.1.bb | 45 | ||||
-rw-r--r-- | recipes-ti/includes/ti-paths.inc | 3 |
2 files changed, 48 insertions, 0 deletions
diff --git a/recipes-ti/devtools/ti-cgt-pru_2.1.1.bb b/recipes-ti/devtools/ti-cgt-pru_2.1.1.bb new file mode 100644 index 00000000..3cffd241 --- /dev/null +++ b/recipes-ti/devtools/ti-cgt-pru_2.1.1.bb | |||
@@ -0,0 +1,45 @@ | |||
1 | DESCRIPTION = "TI PRU Code Generation Tools" | ||
2 | HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm" | ||
3 | LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Hewlett-Packard & AFL-3.0 & MIT & BSD-2-Clause & PD" | ||
4 | |||
5 | LIC_FILES_CHKSUM = "file://ti-cgt-pru_${PV}/LICENSE.txt;md5=b6311962635a4f15630e36ec2d875eca" | ||
6 | LIC_FILES_CHKSUM_class-target = "file://usr/share/doc/ti/cgt-pru/LICENSE.txt;md5=b6311962635a4f15630e36ec2d875eca" | ||
7 | |||
8 | require recipes-ti/includes/ti-paths.inc | ||
9 | require recipes-ti/includes/ti-unpack.inc | ||
10 | |||
11 | BINFILE = "ti_cgt_pru_${PV}_linux_installer_x86.bin" | ||
12 | BINFILE_NAME = "cgt-pru-x86" | ||
13 | TI_BIN_UNPK_ARGS = "--prefix ${S}" | ||
14 | TI_BIN_UNPK_CMDS = "" | ||
15 | |||
16 | BINFILE_class-target = "ti_cgt_pru_${PV}_armlinuxa8hf_busybox_installer.sh" | ||
17 | BINFILE_NAME_class-target = "cgt-pru-arm" | ||
18 | |||
19 | SRC_URI = "http://software-dl.ti.com/codegen/esd/cgt_public_sw/PRU/${PV}/${BINFILE};name=${BINFILE_NAME}" | ||
20 | |||
21 | SRC_URI[cgt-pru-x86.md5sum] = "d9923acea12dc41fc975c381804bd5ed" | ||
22 | SRC_URI[cgt-pru-x86.sha256sum] = "bbea68a6e793156cfb4874777bfd41a32b20172d3a8f61db6aed33a697a58e30" | ||
23 | |||
24 | SRC_URI[cgt-pru-arm.md5sum] = "3b97df4966715bdb50f9a9fc58fe6b24" | ||
25 | SRC_URI[cgt-pru-arm.sha256sum] = "819a4680296fabf1ae0d4e0184276f8ab5324621d35388026d1b678ea71040c9" | ||
26 | |||
27 | do_install() { | ||
28 | install -d ${D}${TI_CGT_PRU_INSTALL_DIR_RECIPE} | ||
29 | cp -r ${S}/ti-cgt-pru_${PV}/. \ | ||
30 | ${D}${TI_CGT_PRU_INSTALL_DIR_RECIPE}/ | ||
31 | } | ||
32 | |||
33 | do_install_class-target() { | ||
34 | ${WORKDIR}/${BINFILE} --prefix ${D} | ||
35 | } | ||
36 | |||
37 | FILES_${PN} += "${datadir}/ti/*" | ||
38 | |||
39 | FILES_${PN}-dbg = "${TI_CGT_PRU_INSTALL_DIR_RECIPE}/bin/.debug \ | ||
40 | ${TI_CGT_PRU_INSTALL_DIR_RECIPE}/lib/.debug \ | ||
41 | " | ||
42 | |||
43 | INSANE_SKIP_${PN} += "arch staticdev" | ||
44 | |||
45 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/recipes-ti/includes/ti-paths.inc b/recipes-ti/includes/ti-paths.inc index 88805916..ad4ff783 100644 --- a/recipes-ti/includes/ti-paths.inc +++ b/recipes-ti/includes/ti-paths.inc | |||
@@ -48,6 +48,8 @@ export OSAL_INSTALL_DIR_RECIPE = "${installdir}/ti-osal-tree" | |||
48 | export M4_TOOLCHAIN_INSTALL_DIR_RECIPE = "${installdir}/ti-cgt-arm" | 48 | export M4_TOOLCHAIN_INSTALL_DIR_RECIPE = "${installdir}/ti-cgt-arm" |
49 | export CCSV6_INSTALL_DIR_RECIPE = "${installdir}/ccsv6" | 49 | export CCSV6_INSTALL_DIR_RECIPE = "${installdir}/ccsv6" |
50 | export GCC_ARM_NONE_TOOLCHAIN_RECIPE = "${installdir}/gcc-arm-none-eabi" | 50 | export GCC_ARM_NONE_TOOLCHAIN_RECIPE = "${installdir}/gcc-arm-none-eabi" |
51 | export TI_CGT_PRU_INSTALL_DIR_RECIPE = "${installdir}/cgt-pru" | ||
52 | |||
51 | 53 | ||
52 | # This is where the tools will end up in sysroot | 54 | # This is where the tools will end up in sysroot |
53 | export BIOS_INSTALL_DIR = "${STAGING_DIR_TARGET}${BIOS_INSTALL_DIR_RECIPE}" | 55 | export BIOS_INSTALL_DIR = "${STAGING_DIR_TARGET}${BIOS_INSTALL_DIR_RECIPE}" |
@@ -86,6 +88,7 @@ export OSAL_INSTALL_DIR = "${STAGING_DIR_TARGET}${OSAL_INSTALL_DIR_RECIPE} | |||
86 | export M4_TOOLCHAIN_INSTALL_DIR = "${STAGING_DIR_NATIVE}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}" | 88 | export M4_TOOLCHAIN_INSTALL_DIR = "${STAGING_DIR_NATIVE}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}" |
87 | export CCSV6_INSTALL_DIR = "${STAGING_DIR_NATIVE}${CCSV6_INSTALL_DIR_RECIPE}" | 89 | export CCSV6_INSTALL_DIR = "${STAGING_DIR_NATIVE}${CCSV6_INSTALL_DIR_RECIPE}" |
88 | export GCC_ARM_NONE_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}" | 90 | export GCC_ARM_NONE_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}" |
91 | export TI_CGT_PRU_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT_PRU_INSTALL_DIR_RECIPE}" | ||
89 | 92 | ||
90 | DSPSUFFIX_omapl137 = "x674" | 93 | DSPSUFFIX_omapl137 = "x674" |
91 | DSPSUFFIX_omapl138 = "x674" | 94 | DSPSUFFIX_omapl138 = "x674" |