diff options
-rw-r--r-- | recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb | 25 | ||||
-rw-r--r-- | recipes-bsp/vpe-tests/vpe-tests_git.bb (renamed from recipes-bsp/vpe-vpdma/vpe-vpdma_git.bb) | 10 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti-staging_3.12.bb | 2 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti-staging_3.14.bb | 2 |
4 files changed, 28 insertions, 11 deletions
diff --git a/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb b/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb new file mode 100644 index 00000000..4707f179 --- /dev/null +++ b/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | DESCRIPTION = "VPDMA firmware for Video Input Port and Video Processing Engine" | ||
2 | |||
3 | LICENSE = "TI-TSPA" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=fd463c9500441ed91d07a0331baa635c" | ||
5 | |||
6 | COMPATIBLE_MACHINE = "dra7xx" | ||
7 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
8 | |||
9 | DEPENDS += "virtual/kernel" | ||
10 | |||
11 | SRC_URI = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/vpdma-fw/03-2012/exports/vpdma-fw_03-2012.tar.gz;protocol=http;name=dra7xx-evm" | ||
12 | SRC_URI[dra7xx-evm.md5sum] = "80176df1350c21d9efa90171789c546e" | ||
13 | SRC_URI[dra7xx-evm.sha256sum] = "a0b254ffd0c7f481cb3989e632088f5e4a233c73a1c676faa3061721ea60dc90" | ||
14 | |||
15 | S = "${WORKDIR}/vpdma-fw-${PV}" | ||
16 | TARGET = "vpdma-1b8.bin" | ||
17 | |||
18 | do_install() { | ||
19 | mkdir -p ${D}${base_libdir}/firmware | ||
20 | cp ${S}/${TARGET} ${D}${base_libdir}/firmware/${TARGET} | ||
21 | } | ||
22 | |||
23 | FILES_${PN} += "${base_libdir}/firmware/${TARGET}" | ||
24 | |||
25 | PR = "r1" | ||
diff --git a/recipes-bsp/vpe-vpdma/vpe-vpdma_git.bb b/recipes-bsp/vpe-tests/vpe-tests_git.bb index f7a63abe..a8ee7f89 100644 --- a/recipes-bsp/vpe-vpdma/vpe-vpdma_git.bb +++ b/recipes-bsp/vpe-tests/vpe-tests_git.bb | |||
@@ -1,15 +1,10 @@ | |||
1 | DESCRIPTION = "VPE VPDMA firmware and test program" | 1 | DESCRIPTION = "VPE test program" |
2 | |||
3 | DEPENDS += "virtual/kernel" | ||
4 | 2 | ||
5 | LICENSE = "BSD" | 3 | LICENSE = "BSD" |
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=74d2f71d8898c54e3d1c9d0058c484aa" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=74d2f71d8898c54e3d1c9d0058c484aa" |
7 | 5 | ||
8 | COMPATIBLE_MACHINE = "dra7xx" | 6 | COMPATIBLE_MACHINE = "dra7xx" |
9 | 7 | ||
10 | PV = "1b8" | ||
11 | PR = "r2" | ||
12 | |||
13 | SRCREV = "e3d8db1aa935775f9d196ad7428e0cd9864a36ca" | 8 | SRCREV = "e3d8db1aa935775f9d196ad7428e0cd9864a36ca" |
14 | BRANCH ?= "master" | 9 | BRANCH ?= "master" |
15 | 10 | ||
@@ -26,6 +21,3 @@ do_install() { | |||
26 | oe_runmake DESTDIR="${D}" install | 21 | oe_runmake DESTDIR="${D}" install |
27 | } | 22 | } |
28 | 23 | ||
29 | # Separate the firmware into it's own package. | ||
30 | PACKAGES =+ "${PN}-fw" | ||
31 | FILES_${PN}-fw += "${base_libdir}/firmware" | ||
diff --git a/recipes-kernel/linux/linux-ti-staging_3.12.bb b/recipes-kernel/linux/linux-ti-staging_3.12.bb index 27a3f356..358bd1be 100644 --- a/recipes-kernel/linux/linux-ti-staging_3.12.bb +++ b/recipes-kernel/linux/linux-ti-staging_3.12.bb | |||
@@ -21,7 +21,7 @@ RDEPENDS_kernel-base_append_ti43x = " am33x-cm3" | |||
21 | 21 | ||
22 | # Add a run-time dependency for the VPE VPDMA firmware to be installed | 22 | # Add a run-time dependency for the VPE VPDMA firmware to be installed |
23 | # on the target file system. | 23 | # on the target file system. |
24 | RDEPENDS_kernel-base_append_dra7xx = " vpe-vpdma-fw" | 24 | RDEPENDS_kernel-base_append_dra7xx = " vpdma-fw" |
25 | 25 | ||
26 | # Default is to package all dtb files for ti33x devices unless building | 26 | # Default is to package all dtb files for ti33x devices unless building |
27 | # for the specific beaglebone machine. | 27 | # for the specific beaglebone machine. |
diff --git a/recipes-kernel/linux/linux-ti-staging_3.14.bb b/recipes-kernel/linux/linux-ti-staging_3.14.bb index 2192e3cf..c8cbc93f 100644 --- a/recipes-kernel/linux/linux-ti-staging_3.14.bb +++ b/recipes-kernel/linux/linux-ti-staging_3.14.bb | |||
@@ -22,7 +22,7 @@ RDEPENDS_kernel-base_append_ti43x = " am33x-cm3" | |||
22 | 22 | ||
23 | # Add a run-time dependency for the VPE VPDMA firmware to be installed | 23 | # Add a run-time dependency for the VPE VPDMA firmware to be installed |
24 | # on the target file system. | 24 | # on the target file system. |
25 | RDEPENDS_kernel-base_append_dra7xx = " vpe-vpdma-fw" | 25 | RDEPENDS_kernel-base_append_dra7xx = " vpdma-fw" |
26 | 26 | ||
27 | # Default is to package all dtb files for ti33x devices unless building | 27 | # Default is to package all dtb files for ti33x devices unless building |
28 | # for the specific beaglebone machine. | 28 | # for the specific beaglebone machine. |