summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/ti-pdk.bbclass2
-rw-r--r--recipes-bsp/dspdce-fw/dspdce-fw_git.bb2
-rw-r--r--recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb2
-rw-r--r--recipes-bsp/ipumm-fw/ipumm-fw_git.bb4
-rw-r--r--recipes-devtools/gdbc6x/gdbserver-c6x_git.bb2
-rw-r--r--recipes-ti/c6accel/ti-c6accel.inc2
-rw-r--r--recipes-ti/devtools/ti-xdctools_3.50.03.33.bb4
-rw-r--r--recipes-ti/dmai/ti-dmai.inc2
-rw-r--r--recipes-ti/dsplink/ti-dsplink.inc2
-rw-r--r--recipes-ti/includes/ti-paths.inc2
-rw-r--r--recipes-ti/ipc/ti-ipc-examples-linux_git.bb2
-rw-r--r--recipes-ti/ipc/ti-ipc-examples_git.bb2
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_git.bb2
-rw-r--r--recipes-ti/local-power-manager/ti-local-power-manager.inc2
-rw-r--r--recipes-ti/openmp-rtos/openmp-rtos_git.bb2
-rw-r--r--recipes-ti/syslink/ti-syslink.inc2
16 files changed, 21 insertions, 15 deletions
diff --git a/classes/ti-pdk.bbclass b/classes/ti-pdk.bbclass
index 801c495b..ab730a90 100644
--- a/classes/ti-pdk.bbclass
+++ b/classes/ti-pdk.bbclass
@@ -3,7 +3,7 @@ require recipes-ti/includes/ti-staging.inc
3 3
4inherit perlnative 4inherit perlnative
5 5
6DEPENDS = "ti-xdctools ti-cg-xml-native ti-sysbios common-csl-ip-rtos libxml-simple-perl-native gcc-arm-none-eabi-native ti-cgt6x-native ti-cgt-pru-native ti-pdk-build-rtos doxygen-native" 6DEPENDS = "ti-xdctools-native ti-cg-xml-native ti-sysbios common-csl-ip-rtos libxml-simple-perl-native gcc-arm-none-eabi-native ti-cgt6x-native ti-cgt-pru-native ti-pdk-build-rtos doxygen-native"
7 7
8DEPENDS_append_omap-a15 = " ti-cgt-arm-native" 8DEPENDS_append_omap-a15 = " ti-cgt-arm-native"
9DEPENDS_remove_ti33x = "ti-cgt6x-native" 9DEPENDS_remove_ti33x = "ti-cgt6x-native"
diff --git a/recipes-bsp/dspdce-fw/dspdce-fw_git.bb b/recipes-bsp/dspdce-fw/dspdce-fw_git.bb
index 2bada7b6..2756c2d8 100644
--- a/recipes-bsp/dspdce-fw/dspdce-fw_git.bb
+++ b/recipes-bsp/dspdce-fw/dspdce-fw_git.bb
@@ -17,7 +17,7 @@ require recipes-ti/includes/ti-paths.inc
17PR = "r4" 17PR = "r4"
18inherit update-alternatives 18inherit update-alternatives
19 19
20DEPENDS = "ti-xdctools ti-sysbios ti-codec-engine ti-framework-components ti-xdais ti-ipc-rtos ti-osal ti-cgt6x-native" 20DEPENDS = "ti-xdctools-native ti-sysbios ti-codec-engine ti-framework-components ti-xdais ti-ipc-rtos ti-osal ti-cgt6x-native"
21 21
22export HWVERSION = "ES10" 22export HWVERSION = "ES10"
23export BIOSTOOLSROOT = "${STAGING_DIR_TARGET}/usr/share/ti" 23export BIOSTOOLSROOT = "${STAGING_DIR_TARGET}/usr/share/ti"
diff --git a/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb b/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb
index 071a51a5..71c4fce4 100644
--- a/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb
+++ b/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb
@@ -3,7 +3,7 @@ require recipes-ti/includes/ti-paths.inc
3 3
4PR = "${INC_PR}.1" 4PR = "${INC_PR}.1"
5 5
6DEPENDS = "ti-sysbios ti-xdctools gcc-arm-none-eabi-native ti-cgt-arm-native ti-cgt6x-native" 6DEPENDS = "ti-sysbios ti-xdctools-native gcc-arm-none-eabi-native ti-cgt-arm-native ti-cgt6x-native"
7 7
8COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|c66x|omapl1" 8COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|c66x|omapl1"
9PACKAGE_ARCH = "${MACHINE_ARCH}" 9PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/ipumm-fw/ipumm-fw_git.bb b/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
index 2a36271a..4895955c 100644
--- a/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
+++ b/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
@@ -28,7 +28,7 @@ require recipes-ti/includes/ti-paths.inc
28 28
29inherit update-alternatives 29inherit update-alternatives
30 30
31DEPENDS = "ti-xdctools ti-sysbios ti-codec-engine ti-framework-components ti-xdais ti-cgt-arm-native ti-ipc-rtos" 31DEPENDS = "ti-xdctools-native ti-sysbios ti-codec-engine ti-framework-components ti-xdais ti-cgt-arm-native ti-ipc-rtos"
32 32
33export HWVERSION="ES10" 33export HWVERSION="ES10"
34export BIOSTOOLSROOT="${STAGING_DIR_TARGET}/usr/share/ti" 34export BIOSTOOLSROOT="${STAGING_DIR_TARGET}/usr/share/ti"
@@ -43,6 +43,8 @@ export XDAISVERSION="ti-xdais-tree"
43export TMS470CGTOOLPATH="${M4_TOOLCHAIN_INSTALL_DIR}" 43export TMS470CGTOOLPATH="${M4_TOOLCHAIN_INSTALL_DIR}"
44export IPCSRC="${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree" 44export IPCSRC="${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree"
45 45
46EXTRA_OEMAKE += "XDCDIST_TREE=${STAGING_DIR_NATIVE}/usr/share/ti/${XDCVERSION}"
47
46do_configure() { 48do_configure() {
47 oe_runmake unconfig 49 oe_runmake unconfig
48 oe_runmake vayu_smp_config 50 oe_runmake vayu_smp_config
diff --git a/recipes-devtools/gdbc6x/gdbserver-c6x_git.bb b/recipes-devtools/gdbc6x/gdbserver-c6x_git.bb
index f4dc51dc..79b584be 100644
--- a/recipes-devtools/gdbc6x/gdbserver-c6x_git.bb
+++ b/recipes-devtools/gdbc6x/gdbserver-c6x_git.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "TI gdb-server to be used with c6xgdb."
2LICENSE = "BSD" 2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://../debian/copyright;md5=82c616b6c8f9c11c46feaaf8f9a11495" 3LIC_FILES_CHKSUM = "file://../debian/copyright;md5=82c616b6c8f9c11c46feaaf8f9a11495"
4 4
5DEPENDS = "ti-xdais ti-framework-components ti-cgt6x-native ti-sysbios ti-xdctools" 5DEPENDS = "ti-xdais ti-framework-components ti-cgt6x-native ti-sysbios ti-xdctools-native"
6 6
7PR = "${INC_PR}.0" 7PR = "${INC_PR}.0"
8 8
diff --git a/recipes-ti/c6accel/ti-c6accel.inc b/recipes-ti/c6accel/ti-c6accel.inc
index 65990a85..7e7fb296 100644
--- a/recipes-ti/c6accel/ti-c6accel.inc
+++ b/recipes-ti/c6accel/ti-c6accel.inc
@@ -29,7 +29,7 @@ BINFILE="c6accel_${PV}_Linux-x86_Setup.bin"
29TI_BIN_UNPK_CMDS="Y:workdir" 29TI_BIN_UNPK_CMDS="Y:workdir"
30 30
31DEPENDS = "ti-codec-engine ti-xdais ti-dsplink ti-dspbios" 31DEPENDS = "ti-codec-engine ti-xdais ti-dsplink ti-dspbios"
32DEPENDS += "ti-edma3lld ti-cgt6x ti-xdctools ti-framework-components" 32DEPENDS += "ti-edma3lld ti-cgt6x ti-xdctools-native ti-framework-components"
33DEPENDS += "ti-biosutils" 33DEPENDS += "ti-biosutils"
34 34
35TIARGS = ' \ 35TIARGS = ' \
diff --git a/recipes-ti/devtools/ti-xdctools_3.50.03.33.bb b/recipes-ti/devtools/ti-xdctools_3.50.03.33.bb
index 73ab3bdf..6ab2b94a 100644
--- a/recipes-ti/devtools/ti-xdctools_3.50.03.33.bb
+++ b/recipes-ti/devtools/ti-xdctools_3.50.03.33.bb
@@ -7,3 +7,7 @@ LIC_FILES_CHKSUM = "file://docs/license/xdc/shelf/package.html;beginline=1;endli
7 7
8SRC_URI[xdczip.md5sum] = "21310b647275a7c7dd5b37dcb96c0b1b" 8SRC_URI[xdczip.md5sum] = "21310b647275a7c7dd5b37dcb96c0b1b"
9SRC_URI[xdczip.sha256sum] = "afe8616773e63b01e79e8cfacaf4d2c8d3b92c798c7f8cf5d1c7b5fe2060bbe4" 9SRC_URI[xdczip.sha256sum] = "afe8616773e63b01e79e8cfacaf4d2c8d3b92c798c7f8cf5d1c7b5fe2060bbe4"
10
11FILES_${PN} += "${XDC_INSTALL_DIR_RECIPE}"
12
13BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-ti/dmai/ti-dmai.inc b/recipes-ti/dmai/ti-dmai.inc
index f81b4cff..50621184 100644
--- a/recipes-ti/dmai/ti-dmai.inc
+++ b/recipes-ti/dmai/ti-dmai.inc
@@ -29,7 +29,7 @@ SRC_URI = "svn://gforge.ti.com/svn/dmai/;module=${DMAIBRANCH};protocol=https;use
29 file://arago-tdox \ 29 file://arago-tdox \
30 " 30 "
31 31
32DEPENDS = "virtual/kernel alsa-lib ti-framework-components ti-codec-engine ti-xdctools" 32DEPENDS = "virtual/kernel alsa-lib ti-framework-components ti-codec-engine ti-xdctools-native"
33 33
34DEPENDS_append_dm6446 = " ti-codecs-dm6446 ti-dspbios ti-cgt6x ti-linuxutils" 34DEPENDS_append_dm6446 = " ti-codecs-dm6446 ti-dspbios ti-cgt6x ti-linuxutils"
35DEPENDS_append_dm6467 = " ti-codecs-dm6467 ti-dspbios ti-cgt6x ti-linuxutils" 35DEPENDS_append_dm6467 = " ti-codecs-dm6467 ti-dspbios ti-cgt6x ti-linuxutils"
diff --git a/recipes-ti/dsplink/ti-dsplink.inc b/recipes-ti/dsplink/ti-dsplink.inc
index 78b53cf0..e0096155 100644
--- a/recipes-ti/dsplink/ti-dsplink.inc
+++ b/recipes-ti/dsplink/ti-dsplink.inc
@@ -30,7 +30,7 @@ SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/${PV_DL_PATH}/dsplink_l
30 file://ti-dsplink-examples-loadmodules.sh \ 30 file://ti-dsplink-examples-loadmodules.sh \
31 file://ti-dsplink-examples-unloadmodules.sh " 31 file://ti-dsplink-examples-unloadmodules.sh "
32 32
33DEPENDS = "ti-dspbios ti-xdctools ti-cgt6x" 33DEPENDS = "ti-dspbios ti-xdctools-native ti-cgt6x"
34DEPENDS += "virtual/kernel perl-native" 34DEPENDS += "virtual/kernel perl-native"
35 35
36# SOC_FAMILY configuration 36# SOC_FAMILY configuration
diff --git a/recipes-ti/includes/ti-paths.inc b/recipes-ti/includes/ti-paths.inc
index ebd4b8a5..3745ec07 100644
--- a/recipes-ti/includes/ti-paths.inc
+++ b/recipes-ti/includes/ti-paths.inc
@@ -88,7 +88,7 @@ export SYSBIOS_INSTALL_DIR = "${STAGING_DIR_TARGET}${SYSBIOS_INSTALL_DIR_RECI
88export SYSLINK_INSTALL_DIR = "${STAGING_DIR_TARGET}${SYSLINK_INSTALL_DIR_RECIPE}" 88export SYSLINK_INSTALL_DIR = "${STAGING_DIR_TARGET}${SYSLINK_INSTALL_DIR_RECIPE}"
89export UIA_INSTALL_DIR = "${STAGING_DIR_TARGET}${UIA_INSTALL_DIR_RECIPE}" 89export UIA_INSTALL_DIR = "${STAGING_DIR_TARGET}${UIA_INSTALL_DIR_RECIPE}"
90export XDAIS_INSTALL_DIR = "${STAGING_DIR_TARGET}${XDAIS_INSTALL_DIR_RECIPE}" 90export XDAIS_INSTALL_DIR = "${STAGING_DIR_TARGET}${XDAIS_INSTALL_DIR_RECIPE}"
91export XDC_INSTALL_DIR = "${STAGING_DIR_TARGET}${XDC_INSTALL_DIR_RECIPE}" 91export XDC_INSTALL_DIR = "${STAGING_DIR_NATIVE}${XDC_INSTALL_DIR_RECIPE}"
92export PDK_INSTALL_DIR = "${STAGING_DIR_TARGET}${PDK_INSTALL_DIR_RECIPE}" 92export PDK_INSTALL_DIR = "${STAGING_DIR_TARGET}${PDK_INSTALL_DIR_RECIPE}"
93export OSAL_INSTALL_DIR = "${STAGING_DIR_TARGET}${OSAL_INSTALL_DIR_RECIPE}" 93export OSAL_INSTALL_DIR = "${STAGING_DIR_TARGET}${OSAL_INSTALL_DIR_RECIPE}"
94export M4_TOOLCHAIN_INSTALL_DIR = "${STAGING_DIR_NATIVE}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}" 94export M4_TOOLCHAIN_INSTALL_DIR = "${STAGING_DIR_NATIVE}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}"
diff --git a/recipes-ti/ipc/ti-ipc-examples-linux_git.bb b/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
index 4701ebaa..ddbe48f5 100644
--- a/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
+++ b/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
@@ -1,7 +1,7 @@
1DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running bios" 1DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running bios"
2require ti-ipc-examples.inc 2require ti-ipc-examples.inc
3 3
4DEPENDS = "ti-ipc ti-xdctools ti-sysbios ti-ipc-rtos zip-native" 4DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native"
5 5
6do_compile_append() { 6do_compile_append() {
7 7
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb
index d728983e..8aad69c9 100644
--- a/recipes-ti/ipc/ti-ipc-examples_git.bb
+++ b/recipes-ti/ipc/ti-ipc-examples_git.bb
@@ -1,7 +1,7 @@
1DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running linux" 1DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running linux"
2require ti-ipc-examples.inc 2require ti-ipc-examples.inc
3 3
4DEPENDS = "ti-ipc ti-xdctools ti-sysbios ti-ipc-rtos zip-native" 4DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native"
5 5
6do_compile_append() { 6do_compile_append() {
7 7
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb
index 886beb9a..4040c4d9 100644
--- a/recipes-ti/ipc/ti-ipc-rtos_git.bb
+++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb
@@ -2,7 +2,7 @@ require ti-ipc.inc
2require ti-ipc-common.inc 2require ti-ipc-common.inc
3require ti-ipc-rtos.inc 3require ti-ipc-rtos.inc
4 4
5DEPENDS = "ti-xdctools ti-sysbios zip-native" 5DEPENDS = "ti-xdctools-native ti-sysbios doxygen-native zip-native"
6 6
7PACKAGES =+ "${PN}-fw" 7PACKAGES =+ "${PN}-fw"
8FILES_${PN}-fw = "${base_libdir}/firmware/*" 8FILES_${PN}-fw = "${base_libdir}/firmware/*"
diff --git a/recipes-ti/local-power-manager/ti-local-power-manager.inc b/recipes-ti/local-power-manager/ti-local-power-manager.inc
index 2f2b5256..0e5d4f29 100644
--- a/recipes-ti/local-power-manager/ti-local-power-manager.inc
+++ b/recipes-ti/local-power-manager/ti-local-power-manager.inc
@@ -21,7 +21,7 @@ S = "${WORKDIR}/local_power_manager_linux_${PV}"
21 21
22SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/lpm/${PV}/exports/local_power_manager_linux_${PV}.tar.gz;name=lpmtarball" 22SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/lpm/${PV}/exports/local_power_manager_linux_${PV}.tar.gz;name=lpmtarball"
23 23
24DEPENDS = "ti-dsplink ti-xdctools" 24DEPENDS = "ti-dsplink ti-xdctools-native"
25DEPENDS += "virtual/kernel" 25DEPENDS += "virtual/kernel"
26 26
27# SOC_FAMILY configuration 27# SOC_FAMILY configuration
diff --git a/recipes-ti/openmp-rtos/openmp-rtos_git.bb b/recipes-ti/openmp-rtos/openmp-rtos_git.bb
index df082ea9..4dd02141 100644
--- a/recipes-ti/openmp-rtos/openmp-rtos_git.bb
+++ b/recipes-ti/openmp-rtos/openmp-rtos_git.bb
@@ -19,7 +19,7 @@ SRCREV = "a2a518dcc9154a372b38bd5be8a483359123823c"
19 19
20LIC_FILES_CHKSUM = "file://docs/license/omp_manifest_template.html;md5=61a6972303c0447b7c056195d7ebafee" 20LIC_FILES_CHKSUM = "file://docs/license/omp_manifest_template.html;md5=61a6972303c0447b7c056195d7ebafee"
21 21
22DEPENDS = "common-csl-ip-rtos doxygen-native libulm ti-xdctools ti-ipc-rtos ti-sysbios ti-cgt6x-native zip-native" 22DEPENDS = "common-csl-ip-rtos doxygen-native libulm ti-xdctools-native ti-ipc-rtos ti-sysbios ti-cgt6x-native zip-native"
23DEPENDS_append_k2hk = " qmss-lld-rtos cppi-lld-rtos" 23DEPENDS_append_k2hk = " qmss-lld-rtos cppi-lld-rtos"
24DEPENDS_append_k2e = " qmss-lld-rtos cppi-lld-rtos" 24DEPENDS_append_k2e = " qmss-lld-rtos cppi-lld-rtos"
25DEPENDS_append_k2l-evm = " qmss-lld-rtos cppi-lld-rtos" 25DEPENDS_append_k2l-evm = " qmss-lld-rtos cppi-lld-rtos"
diff --git a/recipes-ti/syslink/ti-syslink.inc b/recipes-ti/syslink/ti-syslink.inc
index af5f896a..5ff6af7c 100644
--- a/recipes-ti/syslink/ti-syslink.inc
+++ b/recipes-ti/syslink/ti-syslink.inc
@@ -31,7 +31,7 @@ SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/sy
31 file://syslink.pc \ 31 file://syslink.pc \
32 " 32 "
33 33
34DEPENDS = "ti-sysbios ti-xdctools ti-cgt6x ti-ipc ti-cgt470" 34DEPENDS = "ti-sysbios ti-xdctools-native ti-cgt6x ti-ipc ti-cgt470"
35DEPENDS += "virtual/kernel" 35DEPENDS += "virtual/kernel"
36 36
37#common frameq gateMP heapBufMP heapMemMP knlNotify listMP messageQ notify ringIO ringIO_gpp sharedRegion slaveLoader tilerDaemon 37#common frameq gateMP heapBufMP heapMemMP knlNotify listMP messageQ notify ringIO ringIO_gpp sharedRegion slaveLoader tilerDaemon