diff options
-rw-r--r-- | conf/layer.conf | 4 | ||||
-rw-r--r-- | recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb (renamed from recipes-bsp/powervr-drivers/omapdrm-pvr_1.14.3699939.bb) | 8 | ||||
-rw-r--r-- | recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb (renamed from recipes-graphics/libgles/omap5-sgx-ddk-um-linux_1.14.3699939.bb) | 29 |
3 files changed, 35 insertions, 6 deletions
diff --git a/conf/layer.conf b/conf/layer.conf index 95ffe8e6..4ad5022b 100644 --- a/conf/layer.conf +++ b/conf/layer.conf | |||
@@ -11,8 +11,8 @@ BBFILE_PRIORITY_meta-ti = "6" | |||
11 | LICENSE_PATH += "${LAYERDIR}/licenses" | 11 | LICENSE_PATH += "${LAYERDIR}/licenses" |
12 | 12 | ||
13 | SIGGEN_EXCLUDERECIPES_ABISAFE += " \ | 13 | SIGGEN_EXCLUDERECIPES_ABISAFE += " \ |
14 | omapdrm-pvr \ | 14 | ti-sgx-ddk-km \ |
15 | omap5-sgx-ddk-um-linux \ | 15 | ti-sgx-ddk-um \ |
16 | ti-ipc \ | 16 | ti-ipc \ |
17 | ti-ipc-rtos \ | 17 | ti-ipc-rtos \ |
18 | cmem-mod \ | 18 | cmem-mod \ |
diff --git a/recipes-bsp/powervr-drivers/omapdrm-pvr_1.14.3699939.bb b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb index e6e4e5db..0e99791f 100644 --- a/recipes-bsp/powervr-drivers/omapdrm-pvr_1.14.3699939.bb +++ b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb | |||
@@ -12,6 +12,14 @@ PR = "${MACHINE_KERNEL_PR}" | |||
12 | 12 | ||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 13 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
14 | 14 | ||
15 | DEPENDS = "virtual/kernel" | ||
16 | |||
17 | PROVIDES = "omapdrm-pvr" | ||
18 | |||
19 | RPROVIDES_${PN} = "omapdrm-pvr" | ||
20 | RREPLACES_${PN} = "omapdrm-pvr" | ||
21 | RCONFLICTS_${PN} = "omapdrm-pvr" | ||
22 | |||
15 | BRANCH = "ti-img-sgx/${PV}/k4.1" | 23 | BRANCH = "ti-img-sgx/${PV}/k4.1" |
16 | 24 | ||
17 | SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-linux.git;protocol=git;branch=${BRANCH}" | 25 | SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-linux.git;protocol=git;branch=${BRANCH}" |
diff --git a/recipes-graphics/libgles/omap5-sgx-ddk-um-linux_1.14.3699939.bb b/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb index a79c61fb..c29b9fee 100644 --- a/recipes-graphics/libgles/omap5-sgx-ddk-um-linux_1.14.3699939.bb +++ b/recipes-graphics/libgles/ti-sgx-ddk-um_1.14.3699939.bb | |||
@@ -10,6 +10,18 @@ BRANCH = "ti-img-sgx/${PV}" | |||
10 | SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-um-linux.git;protocol=git;branch=${BRANCH}" | 10 | SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-um-linux.git;protocol=git;branch=${BRANCH}" |
11 | SRCREV = "626c4f773b7c704f1d9a55ca80f60a79f809186d" | 11 | SRCREV = "626c4f773b7c704f1d9a55ca80f60a79f809186d" |
12 | 12 | ||
13 | # There's only hardfp version available | ||
14 | python __anonymous() { | ||
15 | tunes = bb.data.getVar("TUNE_FEATURES", d, 1) | ||
16 | if not tunes: | ||
17 | return | ||
18 | pkgn = bb.data.getVar("PN", d, 1) | ||
19 | pkgv = bb.data.getVar("PV", d, 1) | ||
20 | if "callconvention-hard" not in tunes: | ||
21 | bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) | ||
22 | raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) | ||
23 | } | ||
24 | |||
13 | TARGET_PRODUCT_omap-a15 = "jacinto6evm" | 25 | TARGET_PRODUCT_omap-a15 = "jacinto6evm" |
14 | TARGET_PRODUCT_ti33x = "ti335x" | 26 | TARGET_PRODUCT_ti33x = "ti335x" |
15 | TARGET_PRODUCT_ti43x = "ti437x" | 27 | TARGET_PRODUCT_ti43x = "ti437x" |
@@ -20,13 +32,21 @@ INITSCRIPT_PARAMS = "defaults 8" | |||
20 | inherit update-rc.d | 32 | inherit update-rc.d |
21 | 33 | ||
22 | PR = "r8" | 34 | PR = "r8" |
23 | PROVIDES += "virtual/egl virtual/libgles1 virtual/libgles2" | 35 | PROVIDES += "virtual/egl virtual/libgles1 virtual/libgles2 omap5-sgx-ddk-um-linux" |
24 | 36 | ||
25 | RDEPENDS_${PN} += "libdrm libudev libgbm wayland libffi libdrm-omap" | 37 | RDEPENDS_${PN} += "libdrm libudev libgbm wayland libffi libdrm-omap" |
26 | 38 | ||
27 | RREPLACES_${PN} = "libegl libgles1 libgles2" | 39 | RPROVIDES_${PN} = "libegl libgles1 libgles2 omap5-sgx-ddk-um-linux" |
28 | RREPLACES_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev" | 40 | RPROVIDES_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev omap5-sgx-ddk-um-linux-dev" |
29 | RREPLACES_${PN}-dbg = "libegl-dbg" | 41 | RPROVIDES_${PN}-dbg = "libegl-dbg libgles1-dbg libgles2-dbg omap5-sgx-ddk-um-linux-dbg" |
42 | |||
43 | RREPLACES_${PN} = "libegl libgles1 libgles2 omap5-sgx-ddk-um-linux" | ||
44 | RREPLACES_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev omap5-sgx-ddk-um-linux-dev" | ||
45 | RREPLACES_${PN}-dbg = "libegl-dbg libgles1-dbg libgles2-dbg omap5-sgx-ddk-um-linux-dbg" | ||
46 | |||
47 | RCONFLICTS_${PN} = "libegl libgles1 libgles2 omap5-sgx-ddk-um-linux" | ||
48 | RCONFLICTS_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev omap5-sgx-ddk-um-linux-dev" | ||
49 | RCONFLICTS_${PN}-dbg = "libegl-dbg libgles1-dbg libgles2-dbg omap5-sgx-ddk-um-linux-dbg" | ||
30 | 50 | ||
31 | S = "${WORKDIR}/git" | 51 | S = "${WORKDIR}/git" |
32 | 52 | ||
@@ -48,6 +68,7 @@ RDEPENDS_${PN} += "${PN}-plugins" | |||
48 | ALLOW_EMPTY_${PN}-plugins = "1" | 68 | ALLOW_EMPTY_${PN}-plugins = "1" |
49 | 69 | ||
50 | INHIBIT_PACKAGE_STRIP = "1" | 70 | INHIBIT_PACKAGE_STRIP = "1" |
71 | INHIBIT_SYSROOT_STRIP = "1" | ||
51 | 72 | ||
52 | INSANE_SKIP_${PN} += "dev-so ldflags useless-rpaths" | 73 | INSANE_SKIP_${PN} += "dev-so ldflags useless-rpaths" |
53 | INSANE_SKIP_${PN}-plugins = "dev-so" | 74 | INSANE_SKIP_${PN}-plugins = "dev-so" |