diff options
-rw-r--r-- | recipes-bsp/ti/files/0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch | 31 | ||||
-rw-r--r-- | recipes-bsp/ti/matrix-gui_1.3.bb | 4 |
2 files changed, 34 insertions, 1 deletions
diff --git a/recipes-bsp/ti/files/0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch b/recipes-bsp/ti/files/0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch new file mode 100644 index 00000000..324f9808 --- /dev/null +++ b/recipes-bsp/ti/files/0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 420cadec0f7a6048a0fafccf4c658d543b7dbf19 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <k-kooi@ti.com> | ||
3 | Date: Tue, 26 Jul 2011 14:25:39 +0200 | ||
4 | Subject: [PATCH] matrix_gui.pro: add dbus to QT features to fix linking with -Wl,--as-needed | ||
5 | |||
6 | This fixes: | ||
7 | |||
8 | | ccache arm-angstrom-linux-gnueabi-g++ -march=armv7-a -mtune=cortex-a8 -mfpu=neon -mfloat-abi=softfp -fno-tree-vectorize -mthumb-interwork -mno-thumb --sysroot=/home/koen/angstrom-core/build/tmp-angstrom_2010_x-eglibc/sysroots/beagleboard -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,-rpath-link,/home/koen/angstrom-core/build/tmp-angstrom_2010_x-eglibc/sysroots/beagleboard/usr/lib -o matrix_gui main.o mainwindow.o buttonfactory.o buttonlaunch.o customstyle.o menupage.o osdmanager.o matrixcontrol.o moc_mainwindow.o moc_buttonfactory.o moc_buttonlaunch.o moc_customstyle.o moc_menupage.o moc_osdmanager.o moc_matrixcontrol.o -L/home/koen/angstrom-core/build/tmp-angstrom_2010_x-eglibc/sysroots/beagleboard/usr/lib -lpng -lfreetype -lz -lgthread-2.0 -lQtWebKit -lQtGui -lQtNetwork -lQtCore -lpthread | ||
9 | | ux-gnueabi/4.5.4/ld: }: invalid DSO for symbol `QDBusConnection::registerService(QString const&)' definition | ||
10 | | /home/koen/angstrom-core/build/tmp-angstrom_2010_x-eglibc/sysroots/beagleboard/usr/lib/libQtDBus.so.4: could not read symbols: Bad value | ||
11 | | collect2: ld returned 1 exit status | ||
12 | |||
13 | Signed-off-by: Koen Kooi <k-kooi@ti.com> | ||
14 | --- | ||
15 | matrix_gui.pro | 3 ++- | ||
16 | 1 files changed, 2 insertions(+), 1 deletions(-) | ||
17 | |||
18 | diff --git a/matrix_gui.pro b/matrix_gui.pro | ||
19 | index 5463310..908e8a7 100644 | ||
20 | --- a/matrix_gui.pro | ||
21 | +++ b/matrix_gui.pro | ||
22 | @@ -1,4 +1,5 @@ | ||
23 | -QT += webkit \ | ||
24 | +QT += dbus \ | ||
25 | + webkit \ | ||
26 | network | ||
27 | LIBS += -lpng -lfreetype -lz -lgthread-2.0 | ||
28 | HEADERS = mainwindow.h \ | ||
29 | -- | ||
30 | 1.7.4.4 | ||
31 | |||
diff --git a/recipes-bsp/ti/matrix-gui_1.3.bb b/recipes-bsp/ti/matrix-gui_1.3.bb index 483c6d67..f91d8817 100644 --- a/recipes-bsp/ti/matrix-gui_1.3.bb +++ b/recipes-bsp/ti/matrix-gui_1.3.bb | |||
@@ -1,4 +1,6 @@ | |||
1 | require matrix-gui.inc | 1 | require matrix-gui.inc |
2 | 2 | ||
3 | SRCREV = "275" | 3 | SRCREV = "275" |
4 | PR = "${INC_PR}.0" | 4 | SRC_URI += "file://0001-matrix_gui.pro-add-dbus-to-QT-features-to-fix-linkin.patch" |
5 | |||
6 | PR = "${INC_PR}.1" | ||