summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/udev/udev/omap-tty.rules17
-rw-r--r--recipes-core/udev/udev_%.bbappend9
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes-core/udev/udev/omap-tty.rules b/recipes-core/udev/udev/omap-tty.rules
new file mode 100644
index 00000000..989d60f8
--- /dev/null
+++ b/recipes-core/udev/udev/omap-tty.rules
@@ -0,0 +1,17 @@
1# There are a number of modifiers that are allowed to be used in some
2# of the different fields. They provide the following subsitutions:
3#
4# %n the "kernel number" of the device.
5# For example, 'sda3' has a "kernel number" of '3'
6# %e the smallest number for that name which does not matches an existing node
7# %k the kernel name for the device
8# %M the kernel major number for the device
9# %m the kernel minor number for the device
10# %b the bus id for the device
11# %c the string returned by the PROGRAM
12# %s{filename} the content of a sysfs attribute
13# %% the '%' char itself
14#
15
16# Backward compatibility with old OMAP UART-style ttyO0 naming
17SUBSYSTEM=="tty", ATTR{uartclk}!="0", KERNEL=="ttyS[0-9]", SYMLINK+="ttyO%n"
diff --git a/recipes-core/udev/udev_%.bbappend b/recipes-core/udev/udev_%.bbappend
new file mode 100644
index 00000000..fd0d99bc
--- /dev/null
+++ b/recipes-core/udev/udev_%.bbappend
@@ -0,0 +1,9 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI_append = " file://omap-tty.rules"
4
5PR_append = ".0"
6
7do_install_append() {
8 install -m 0644 ${WORKDIR}/omap-tty.rules ${D}${sysconfdir}/udev/rules.d/
9}