summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-ti/includes/ti-paths.inc2
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb28
2 files changed, 30 insertions, 0 deletions
diff --git a/recipes-ti/includes/ti-paths.inc b/recipes-ti/includes/ti-paths.inc
index b660c11b..31427a6d 100644
--- a/recipes-ti/includes/ti-paths.inc
+++ b/recipes-ti/includes/ti-paths.inc
@@ -54,6 +54,7 @@ export MATHLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-mathlib-c66x-tree"
54export IMGLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-imglib-c66x-tree" 54export IMGLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-imglib-c66x-tree"
55export CG_XML_INSTALL_DIR_RECIPE = "${installdir}/ti-cg-xml-tree" 55export CG_XML_INSTALL_DIR_RECIPE = "${installdir}/ti-cg-xml-tree"
56export OMP_INSTALL_DIR_RECIPE = "${installdir}/ti-omp-tree" 56export OMP_INSTALL_DIR_RECIPE = "${installdir}/ti-omp-tree"
57export MPM_INSTALL_DIR_RECIPE = "${installdir}/ti-mpm-tree"
57 58
58 59
59# This is where the tools will end up in sysroot 60# This is where the tools will end up in sysroot
@@ -99,6 +100,7 @@ export MATHLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${MATHLIB_C66_INSTALL
99export IMGLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${IMGLIB_C66_INSTALL_DIR_RECIPE}" 100export IMGLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${IMGLIB_C66_INSTALL_DIR_RECIPE}"
100export CG_XML_INSTALL_DIR = "${STAGING_DIR_NATIVE}${CG_XML_INSTALL_DIR_RECIPE}" 101export CG_XML_INSTALL_DIR = "${STAGING_DIR_NATIVE}${CG_XML_INSTALL_DIR_RECIPE}"
101export OMP_INSTALL_DIR = "${STAGING_DIR_TARGET}${OMP_INSTALL_DIR_RECIPE}" 102export OMP_INSTALL_DIR = "${STAGING_DIR_TARGET}${OMP_INSTALL_DIR_RECIPE}"
103export MPM_INSTALL_DIR = "${STAGING_DIR_TARGET}${MPM_INSTALL_DIR_RECIPE}"
102 104
103DSPSUFFIX_omapl137 = "x674" 105DSPSUFFIX_omapl137 = "x674"
104DSPSUFFIX_omapl138 = "x674" 106DSPSUFFIX_omapl138 = "x674"
diff --git a/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb b/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb
new file mode 100644
index 00000000..50e50493
--- /dev/null
+++ b/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb
@@ -0,0 +1,28 @@
1SUMMARY = "TI Multiproc Manager (RTOS) for KeyStone II"
2DESCRIPTION = "Provides download, debug and other utilities for other cores in the SOC like DSP"
3
4require recipes-ti/includes/ti-paths.inc
5require recipes-ti/multiprocmgr/multiprocmgr.inc
6
7DEPENDS = "ti-cgt6x-native"
8
9PR = "${INC_PR}.0"
10
11export LOCAL_SYSROOT="${STAGING_DIR_TARGET}"
12export C6X_GEN_INSTALL_PATH="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x"
13
14do_compile() {
15 make c66x
16 make test_c66x
17 sourceipk_do_create_srcipk
18}
19
20do_install() {
21 install -d ${D}${MPM_INSTALL_DIR_RECIPE}
22 cp -pPrf ${S}/* ${D}${MPM_INSTALL_DIR_RECIPE}
23}
24
25FILES_${PN}-dev += "${MPM_INSTALL_DIR_RECIPE}"
26INSANE_SKIP_${PN}-dev = "arch"
27
28ALLOW_EMPTY_${PN} = "1"