summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-ti/includes/ti-paths.inc2
-rw-r--r--recipes-ti/vlib/vlib-c66x.inc28
-rw-r--r--recipes-ti/vlib/vlib-c66x_3.2.1.0.bb9
3 files changed, 39 insertions, 0 deletions
diff --git a/recipes-ti/includes/ti-paths.inc b/recipes-ti/includes/ti-paths.inc
index 31427a6d..e7d3e82f 100644
--- a/recipes-ti/includes/ti-paths.inc
+++ b/recipes-ti/includes/ti-paths.inc
@@ -52,6 +52,7 @@ export TI_CGT_PRU_INSTALL_DIR_RECIPE = "${installdir}/cgt-pru"
52export DSPLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-dsplib-c66x-tree" 52export DSPLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-dsplib-c66x-tree"
53export MATHLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-mathlib-c66x-tree" 53export MATHLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-mathlib-c66x-tree"
54export IMGLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-imglib-c66x-tree" 54export IMGLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-imglib-c66x-tree"
55export VLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-vlib-c66x-tree"
55export CG_XML_INSTALL_DIR_RECIPE = "${installdir}/ti-cg-xml-tree" 56export CG_XML_INSTALL_DIR_RECIPE = "${installdir}/ti-cg-xml-tree"
56export OMP_INSTALL_DIR_RECIPE = "${installdir}/ti-omp-tree" 57export OMP_INSTALL_DIR_RECIPE = "${installdir}/ti-omp-tree"
57export MPM_INSTALL_DIR_RECIPE = "${installdir}/ti-mpm-tree" 58export MPM_INSTALL_DIR_RECIPE = "${installdir}/ti-mpm-tree"
@@ -98,6 +99,7 @@ export TI_CGT_PRU_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT_PRU_INSTALL_
98export DSPLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${DSPLIB_C66_INSTALL_DIR_RECIPE}" 99export DSPLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${DSPLIB_C66_INSTALL_DIR_RECIPE}"
99export MATHLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${MATHLIB_C66_INSTALL_DIR_RECIPE}" 100export MATHLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${MATHLIB_C66_INSTALL_DIR_RECIPE}"
100export IMGLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${IMGLIB_C66_INSTALL_DIR_RECIPE}" 101export IMGLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${IMGLIB_C66_INSTALL_DIR_RECIPE}"
102export VLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${VLIB_C66_INSTALL_DIR_RECIPE}"
101export CG_XML_INSTALL_DIR = "${STAGING_DIR_NATIVE}${CG_XML_INSTALL_DIR_RECIPE}" 103export CG_XML_INSTALL_DIR = "${STAGING_DIR_NATIVE}${CG_XML_INSTALL_DIR_RECIPE}"
102export OMP_INSTALL_DIR = "${STAGING_DIR_TARGET}${OMP_INSTALL_DIR_RECIPE}" 104export OMP_INSTALL_DIR = "${STAGING_DIR_TARGET}${OMP_INSTALL_DIR_RECIPE}"
103export MPM_INSTALL_DIR = "${STAGING_DIR_TARGET}${MPM_INSTALL_DIR_RECIPE}" 105export MPM_INSTALL_DIR = "${STAGING_DIR_TARGET}${MPM_INSTALL_DIR_RECIPE}"
diff --git a/recipes-ti/vlib/vlib-c66x.inc b/recipes-ti/vlib/vlib-c66x.inc
new file mode 100644
index 00000000..2e573470
--- /dev/null
+++ b/recipes-ti/vlib/vlib-c66x.inc
@@ -0,0 +1,28 @@
1DESCRIPTION = "TI Vision Library (VLIB) for C66x"
2HOMEPAGE = "http://software-dl.ti.com/libs/vlib/latest/index_FDS.html"
3SECTION = "devel"
4LICENSE = "TI-TSPA & BSD-3-Clause"
5
6require ../includes/ti-paths.inc
7require ../includes/ti-staging.inc
8require ../includes/ti-eula-unpack.inc
9
10COMPATIBLE_MACHINE = "omap-a15|keystone"
11
12SRC_URI = "http://software-dl.ti.com/libs/vlib/${PV}//exports/vlib_c66x_obj_${PV}_Linux.bin;name=vlibbin"
13
14S = "${WORKDIR}/vlib_c66x_${PV}"
15
16BINFILE="vlib_c66x_obj_${PV}_Linux.bin"
17TI_BIN_UNPK_ARGS = "--mode silent --prefix ${S}"
18TI_BIN_UNPK_CMDS=""
19
20do_install() {
21 install -d ${D}${VLIB_C66_INSTALL_DIR_RECIPE}
22 cp -pPrf ${S}/* ${D}${VLIB_C66_INSTALL_DIR_RECIPE}
23}
24
25ALLOW_EMPTY_${PN} = "1"
26FILES_${PN}-dev += "${VLIB_C66_INSTALL_DIR_RECIPE}"
27
28INSANE_SKIP_${PN}-dev = "installed-vs-shipped arch"
diff --git a/recipes-ti/vlib/vlib-c66x_3.2.1.0.bb b/recipes-ti/vlib/vlib-c66x_3.2.1.0.bb
new file mode 100644
index 00000000..e3742d10
--- /dev/null
+++ b/recipes-ti/vlib/vlib-c66x_3.2.1.0.bb
@@ -0,0 +1,9 @@
1require vlib-c66x.inc
2
3PV = "3_2_1_0"
4PR = "r0"
5
6LIC_FILES_CHKSUM = "file://docs/VLIB_Software_Manifest.html;md5=75151b04457c8a1ae3c2172ada0eedda"
7
8SRC_URI[vlibbin.md5sum] = "e292fa3f74be60b9110e0ebcc6840fe7"
9SRC_URI[vlibbin.sha256sum] = "05bf16473d60e0252d3a73a7c3d268e540783a226b4bda930e5f6042e7b01bd8"