summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/include/keystone.inc6
-rw-r--r--recipes-kernel/linux/linux-ti-staging-4.1/keystone/configs/systest1
-rw-r--r--recipes-kernel/linux/linux-ti-staging-4.1/keystone/defconfig1
-rw-r--r--recipes-kernel/linux/linux-ti-staging_4.1.bb11
4 files changed, 12 insertions, 7 deletions
diff --git a/conf/machine/include/keystone.inc b/conf/machine/include/keystone.inc
index 820fe12a..79204478 100644
--- a/conf/machine/include/keystone.inc
+++ b/conf/machine/include/keystone.inc
@@ -4,14 +4,14 @@ require conf/machine/include/soc-family.inc
4DEFAULTTUNE ?= "cortexa15thf-neon" 4DEFAULTTUNE ?= "cortexa15thf-neon"
5require conf/machine/include/tune-cortexa15.inc 5require conf/machine/include/tune-cortexa15.inc
6 6
7PREFERRED_PROVIDER_virtual/kernel = "linux-keystone" 7PREFERRED_PROVIDER_virtual/kernel = "linux-ti-staging"
8PREFERRED_PROVIDER_virtual/bootloader = "u-boot-keystone" 8PREFERRED_PROVIDER_virtual/bootloader = "u-boot-keystone"
9PREFERRED_PROVIDER_u-boot = "u-boot-keystone" 9PREFERRED_PROVIDER_u-boot = "u-boot-keystone"
10 10
11# Increase this everytime you change something in the kernel 11# Increase this everytime you change something in the kernel
12MACHINE_KERNEL_PR = "r8" 12MACHINE_KERNEL_PR = "r9"
13 13
14KERNEL_IMAGETYPE = "uImage" 14KERNEL_IMAGETYPE = "zImage"
15 15
16UBOOT_ENTRYPOINT = "0x80008000" 16UBOOT_ENTRYPOINT = "0x80008000"
17UBOOT_LOADADDRESS = "0x80008000" 17UBOOT_LOADADDRESS = "0x80008000"
diff --git a/recipes-kernel/linux/linux-ti-staging-4.1/keystone/configs/systest b/recipes-kernel/linux/linux-ti-staging-4.1/keystone/configs/systest
new file mode 100644
index 00000000..68cfc252
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging-4.1/keystone/configs/systest
@@ -0,0 +1 @@
use-combined-config=ti_config_fragments/multi_core_system_test_defconfig_fragment
diff --git a/recipes-kernel/linux/linux-ti-staging-4.1/keystone/defconfig b/recipes-kernel/linux/linux-ti-staging-4.1/keystone/defconfig
new file mode 100644
index 00000000..470cf114
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging-4.1/keystone/defconfig
@@ -0,0 +1 @@
use-combined-config=ti_config_fragments/multi_core_defconfig_fragment
diff --git a/recipes-kernel/linux/linux-ti-staging_4.1.bb b/recipes-kernel/linux/linux-ti-staging_4.1.bb
index 67fba2ca..f912d570 100644
--- a/recipes-kernel/linux/linux-ti-staging_4.1.bb
+++ b/recipes-kernel/linux/linux-ti-staging_4.1.bb
@@ -38,20 +38,23 @@ KERNEL_DEVICETREE_am3517-evm = "am3517-evm.dtb"
38KERNEL_DEVICETREE_am37x-evm = "omap3-evm-37xx.dtb" 38KERNEL_DEVICETREE_am37x-evm = "omap3-evm-37xx.dtb"
39KERNEL_DEVICETREE_beagleboard = "omap3-beagle.dtb omap3-beagle-xm.dtb" 39KERNEL_DEVICETREE_beagleboard = "omap3-beagle.dtb omap3-beagle-xm.dtb"
40KERNEL_DEVICETREE_pandaboard = "omap4-panda.dtb omap4-panda-es.dtb" 40KERNEL_DEVICETREE_pandaboard = "omap4-panda.dtb omap4-panda-es.dtb"
41KERNEL_DEVICETREE_k2hk-evm = "k2hk-evm.dtb"
42KERNEL_DEVICETREE_k2e-evm = "k2e-evm.dtb"
43KERNEL_DEVICETREE_k2l-evm = "k2l-evm.dtb"
41 44
42KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}" 45KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
43 46
44COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|omap3|omap4" 47COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|omap3|omap4|keystone"
45 48
46S = "${WORKDIR}/git" 49S = "${WORKDIR}/git"
47 50
48BRANCH = "ti-linux-4.1.y" 51BRANCH = "ti-lsk-linux-4.1.y"
49 52
50SRCREV = "583d3e9ad9f1610b3ac0c531b10fed1cad466b5c" 53SRCREV = "fcd02dfa3a0aeec916697c15ff7652e445733950"
51PV = "4.1.4+git${SRCPV}" 54PV = "4.1.4+git${SRCPV}"
52 55
53# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild 56# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
54MACHINE_KERNEL_PR_append = "a" 57MACHINE_KERNEL_PR_append = "b"
55PR = "${MACHINE_KERNEL_PR}" 58PR = "${MACHINE_KERNEL_PR}"
56 59
57KERNEL_CONFIG_DIR = "${S}/ti_config_fragments" 60KERNEL_CONFIG_DIR = "${S}/ti_config_fragments"