diff options
-rw-r--r-- | conf/machine/am57xx-evm.conf | 1 | ||||
-rw-r--r-- | conf/machine/dra7xx-evm.conf | 2 | ||||
-rw-r--r-- | conf/machine/include/omap-a15.inc | 3 | ||||
-rw-r--r-- | recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb | 5 |
4 files changed, 6 insertions, 5 deletions
diff --git a/conf/machine/am57xx-evm.conf b/conf/machine/am57xx-evm.conf index 6e2eedf3..18325481 100644 --- a/conf/machine/am57xx-evm.conf +++ b/conf/machine/am57xx-evm.conf | |||
@@ -42,4 +42,5 @@ MKUBIFS_ARGS = "-F -m 2048 -e 126976 -c 8192" | |||
42 | UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512 -O 2048" | 42 | UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512 -O 2048" |
43 | 43 | ||
44 | # Set the list of device targets for ti-pdk class recipes | 44 | # Set the list of device targets for ti-pdk class recipes |
45 | TI_PDK_LIMIT_SOCS = "am571x am572x am574x" | ||
45 | TI_PDK_LIMIT_BOARDS = "evmAM571x evmAM572x idkAM571x idkAM572x idkAM574x" | 46 | TI_PDK_LIMIT_BOARDS = "evmAM571x evmAM572x idkAM571x idkAM572x idkAM574x" |
diff --git a/conf/machine/dra7xx-evm.conf b/conf/machine/dra7xx-evm.conf index 91afd855..7db9ff69 100644 --- a/conf/machine/dra7xx-evm.conf +++ b/conf/machine/dra7xx-evm.conf | |||
@@ -40,4 +40,4 @@ UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512 -O 2048" | |||
40 | 40 | ||
41 | # Set the list of device targets for ti-pdk class recipes | 41 | # Set the list of device targets for ti-pdk class recipes |
42 | TI_PDK_LIMIT_BOARDS = "evmDRA72x evmDRA75x evmDRA78x" | 42 | TI_PDK_LIMIT_BOARDS = "evmDRA72x evmDRA75x evmDRA78x" |
43 | TI_PDK_LIMIT_SOCS_append = " dra72x dra75x dra78x" | 43 | TI_PDK_LIMIT_SOCS = "dra72x dra75x dra78x" |
diff --git a/conf/machine/include/omap-a15.inc b/conf/machine/include/omap-a15.inc index cda9e0c9..6dcff82b 100644 --- a/conf/machine/include/omap-a15.inc +++ b/conf/machine/include/omap-a15.inc | |||
@@ -34,6 +34,3 @@ UBI_VOLNAME = "rootfs" | |||
34 | 34 | ||
35 | # List common SoC features, may need to add touchscreen for specific machines | 35 | # List common SoC features, may need to add touchscreen for specific machines |
36 | MACHINE_FEATURES = "kernel26 apm usbgadget usbhost vfat ext2 screen alsa ethernet sgx mmip dsp" | 36 | MACHINE_FEATURES = "kernel26 apm usbgadget usbhost vfat ext2 screen alsa ethernet sgx mmip dsp" |
37 | |||
38 | # Set the list of device targets for ti-pdk class recipes | ||
39 | TI_PDK_LIMIT_SOCS = "am571x am572x am574x" | ||
diff --git a/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb b/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb index f4496b96..100d2f4d 100644 --- a/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb +++ b/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb | |||
@@ -1,5 +1,5 @@ | |||
1 | require common-csl-ip.inc | 1 | require common-csl-ip.inc |
2 | PR = "${INC_PR}.5" | 2 | PR = "${INC_PR}.6" |
3 | 3 | ||
4 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 4 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
5 | COMPATIBLE_MACHINE_append = "|c66x" | 5 | COMPATIBLE_MACHINE_append = "|c66x" |
@@ -16,3 +16,6 @@ export DEST_ROOT="${S}" | |||
16 | 16 | ||
17 | # HTML doc link params | 17 | # HTML doc link params |
18 | PDK_COMP_LINK_TEXT = "CSL-Chip Support Library" | 18 | PDK_COMP_LINK_TEXT = "CSL-Chip Support Library" |
19 | |||
20 | # Workaround: dra7xx build requires am57xx CSL libraries for opencl-monitor | ||
21 | TI_PDK_LIMIT_SOCS_append_dra7xx = " am571x am572x" | ||