diff options
-rw-r--r-- | recipes-bsp/dspdce-fw/dspdce-fw_1.00.00.05.bb | 26 | ||||
-rw-r--r-- | recipes-bsp/dspdce-fw/dspdce-fw_git.bb | 61 |
2 files changed, 61 insertions, 26 deletions
diff --git a/recipes-bsp/dspdce-fw/dspdce-fw_1.00.00.05.bb b/recipes-bsp/dspdce-fw/dspdce-fw_1.00.00.05.bb deleted file mode 100644 index 777c221c..00000000 --- a/recipes-bsp/dspdce-fw/dspdce-fw_1.00.00.05.bb +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | DESCRIPTION = "Firmware for DSP for an example application called copycodectest" | ||
2 | LICENSE = "TI-TSPA" | ||
3 | LIC_FILES_CHKSUM = "file://DSPDCE-${PV}-Manifest.doc;md5=386d1802eefc2fcf00ab01a5b4556277" | ||
4 | |||
5 | COMPATIBLE_MACHINE = "dra7xx-evm" | ||
6 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
7 | |||
8 | SRC_URI = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/dspdce/1_00_00_05/exports/dspdce-${MACHINE}-1.00.00.05.tar.gz;protocol=ftp" | ||
9 | |||
10 | S = "${WORKDIR}/dspdce-${MACHINE}-${PV}" | ||
11 | |||
12 | SRC_URI[md5sum] = "4f3d5c6ef088019aa4804eaaedc8e949" | ||
13 | SRC_URI[sha256sum] = "8d99c4f149613448a6d72c62a18cc7445c63c687b786658da1762c4e1c03a6a0" | ||
14 | |||
15 | TARGET = "dra7-dsp1-fw.xe66" | ||
16 | |||
17 | do_install() { | ||
18 | mkdir -p ${D}${base_libdir}/firmware | ||
19 | cp ${S}/firmware/${TARGET} ${D}${base_libdir}/firmware/${TARGET} | ||
20 | } | ||
21 | |||
22 | FILES_${PN} += "${base_libdir}/firmware/${TARGET}" | ||
23 | |||
24 | INSANE_SKIP_${PN} = "arch" | ||
25 | |||
26 | PR = "r1" | ||
diff --git a/recipes-bsp/dspdce-fw/dspdce-fw_git.bb b/recipes-bsp/dspdce-fw/dspdce-fw_git.bb new file mode 100644 index 00000000..3beb4fbe --- /dev/null +++ b/recipes-bsp/dspdce-fw/dspdce-fw_git.bb | |||
@@ -0,0 +1,61 @@ | |||
1 | DESCRIPTION = "Firmware for DSP for an example application called copycodectest" | ||
2 | LICENSE = "TI-TSPA" | ||
3 | LIC_FILES_CHKSUM = "file://src/ti/framework/dce/dce.c;startline=1;endline=31;md5=2c6e9aba6ed75f22b1a2b7544b1c809d" | ||
4 | |||
5 | COMPATIBLE_MACHINE = "dra7xx" | ||
6 | |||
7 | SRC_URI = "git://git.ti.com/glsdk/dspdce.git;protocol=git" | ||
8 | |||
9 | SRCREV = "71e8fbf8e4f91b60680cf18a0c202a222e9ae3ba" | ||
10 | |||
11 | PV = "1.00.00.06" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | require recipes-ti/includes/ti-paths.inc | ||
16 | require recipes-ti/includes/ti-staging.inc | ||
17 | |||
18 | PR = "r0" | ||
19 | inherit update-alternatives | ||
20 | |||
21 | DEPENDS = "ti-xdctools ti-sysbios ti-codec-engine ti-framework-components ti-xdais ti-ipc-rtos ti-osal ti-cgt6x-native" | ||
22 | |||
23 | export HWVERSION = "ES10" | ||
24 | export BIOSTOOLSROOT = "${STAGING_DIR_TARGET}/usr/share/ti" | ||
25 | |||
26 | export XDCVERSION = "ti-xdctools-tree" | ||
27 | export BIOSVERSION = "ti-sysbios-tree" | ||
28 | export IPCVERSION = "ti-ipc-tree" | ||
29 | export CEVERSION = "ti-codec-engine-tree" | ||
30 | export FCVERSION = "ti-framework-components-tree" | ||
31 | export XDAISVERSION = "ti-xdais-tree" | ||
32 | export OSALVERSION = "ti-osal-tree" | ||
33 | |||
34 | export IPCSRC = "${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree" | ||
35 | export C66XCGTOOLSPATH = "${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" | ||
36 | |||
37 | do_configure() { | ||
38 | cd ${S} | ||
39 | make unconfig | ||
40 | make vayu_config | ||
41 | } | ||
42 | |||
43 | do_compile() { | ||
44 | cd ${S} | ||
45 | make dspbin | ||
46 | } | ||
47 | |||
48 | TARGET = "dra7-dsp1-fw.xe66" | ||
49 | |||
50 | do_install() { | ||
51 | mkdir -p ${D}${base_libdir}/firmware | ||
52 | cp ${S}/dra7xx-c66x-dsp.xe66 ${D}${base_libdir}/firmware/${TARGET} | ||
53 | } | ||
54 | |||
55 | ALTERNATIVE_${PN} = "dra7-dsp1-fw.xe66" | ||
56 | ALTERNATIVE_LINK_NAME[dra7-dsp1-fw.xe66] = "/lib/firmware/${TARGET}" | ||
57 | ALTERNATIVE_PRIORITY = "10" | ||
58 | |||
59 | INSANE_SKIP_${PN} = "arch" | ||
60 | |||
61 | FILES_${PN} += "${base_libdir}/firmware/*" | ||