summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-keystone-rt/defconfig1
-rw-r--r--recipes-kernel/linux/linux-keystone-rt_3.10.bb32
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-keystone-rt/defconfig b/recipes-kernel/linux/linux-keystone-rt/defconfig
new file mode 100644
index 00000000..731bb00d
--- /dev/null
+++ b/recipes-kernel/linux/linux-keystone-rt/defconfig
@@ -0,0 +1 @@
use-kernel-config=keystone2_fullrt_defconfig
diff --git a/recipes-kernel/linux/linux-keystone-rt_3.10.bb b/recipes-kernel/linux/linux-keystone-rt_3.10.bb
new file mode 100644
index 00000000..9c2f9042
--- /dev/null
+++ b/recipes-kernel/linux/linux-keystone-rt_3.10.bb
@@ -0,0 +1,32 @@
1SECTION = "kernel"
2DESCRIPTION = "Linux RT kernel for TI Keystone devices"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5
6COMPATIBLE_MACHINE = "keystone"
7
8inherit kernel
9
10require recipes-kernel/linux/linux-dtb.inc
11require recipes-kernel/linux/setup-defconfig.inc
12
13MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}"
14PR = "${MACHINE_KERNEL_PR}"
15
16KERNEL_DEVICETREE_keystone-evm = "k2hk-evm.dtb"
17
18KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
19
20#This commit corresponds to "K2_RT_LINUX_03.10.10_13.12"
21SRCREV = "8fa9091d0f9c91a048a975ddebbf2f492e73bf61"
22PV = "3.10.10"
23
24BRANCH = "master-rt"
25SRC_URI = "git://git.ti.com/keystone-linux/linux.git;protocol=git;branch=${BRANCH}\
26 file://defconfig\
27 "
28
29S = "${WORKDIR}/git"
30
31RDEPENDS_kernel-base = ""
32