diff options
-rw-r--r-- | recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb | 3 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-ti.inc | 24 |
2 files changed, 26 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb b/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb index 5fbd0c97..ea72e4df 100644 --- a/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb +++ b/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb | |||
@@ -2,7 +2,7 @@ require u-boot-ti.inc | |||
2 | 2 | ||
3 | DESCRIPTION = "u-boot bootloader for TI devices" | 3 | DESCRIPTION = "u-boot bootloader for TI devices" |
4 | 4 | ||
5 | PR = "r4+gitr${SRCPV}" | 5 | PR = "r5+gitr${SRCPV}" |
6 | 6 | ||
7 | SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}" | 7 | SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}" |
8 | 8 | ||
@@ -12,3 +12,4 @@ BRANCH ?= "ti-u-boot-2013.01.01" | |||
12 | SRCREV = "7552b4c906b0a50fbc5225dc43ed0192618e9d5d" | 12 | SRCREV = "7552b4c906b0a50fbc5225dc43ed0192618e9d5d" |
13 | 13 | ||
14 | SPL_BINARY = "MLO" | 14 | SPL_BINARY = "MLO" |
15 | SPL_UART_BINARY = "u-boot-spl.bin" | ||
diff --git a/recipes-bsp/u-boot/u-boot-ti.inc b/recipes-bsp/u-boot/u-boot-ti.inc index 968f3e41..c024e963 100644 --- a/recipes-bsp/u-boot/u-boot-ti.inc +++ b/recipes-bsp/u-boot/u-boot-ti.inc | |||
@@ -15,3 +15,27 @@ PKG_${PN}-dbg = "u-boot-dbg" | |||
15 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |
16 | 16 | ||
17 | UBOOT_SUFFIX = "img" | 17 | UBOOT_SUFFIX = "img" |
18 | |||
19 | # SPL (Second Program Loader) to be loaded over UART | ||
20 | SPL_UART_BINARY ?= "" | ||
21 | SPL_UART_IMAGE ?= "${SPL_UART_BINARY}-${MACHINE}-${PV}-${PR}" | ||
22 | SPL_UART_SYMLINK ?= "${SPL_UART_BINARY}-${MACHINE}" | ||
23 | |||
24 | do_install_append () { | ||
25 | if [ "x${SPL_UART_BINARY}" != "x" ] | ||
26 | then | ||
27 | install ${S}/spl/${SPL_UART_BINARY} ${D}/boot/${SPL_UART_IMAGE} | ||
28 | ln -sf ${SPL_UART_IMAGE} ${D}/boot/${SPL_UART_BINARY} | ||
29 | fi | ||
30 | } | ||
31 | |||
32 | do_deploy_append () { | ||
33 | cd ${DEPLOYDIR} | ||
34 | if [ "x${SPL_UART_BINARY}" != "x" ] | ||
35 | then | ||
36 | install ${S}/spl/${SPL_UART_BINARY} ${DEPLOYDIR}/${SPL_UART_IMAGE} | ||
37 | rm -f ${DEPLOYDIR}/${SPL_UART_BINARY} ${DEPLOYDIR}/${SPL_UART_SYMLINK} | ||
38 | ln -sf ${SPL_UART_IMAGE} ${DEPLOYDIR}/${SPL_UART_BINARY} | ||
39 | ln -sf ${SPL_UART_IMAGE} ${DEPLOYDIR}/${SPL_UART_SYMLINK} | ||
40 | fi | ||
41 | } | ||