diff options
-rw-r--r-- | recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0001-arm-boot-compressed-default-asm-arch-to-armv7-a.patch | 36 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti33x-psp_3.2.bb | 1 |
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0001-arm-boot-compressed-default-asm-arch-to-armv7-a.patch b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0001-arm-boot-compressed-default-asm-arch-to-armv7-a.patch new file mode 100644 index 00000000..5037880f --- /dev/null +++ b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0001-arm-boot-compressed-default-asm-arch-to-armv7-a.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | From 6b87752bd00d12ac7c8db994480c077857e23bf0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Denys Dmytriyenko <denys@ti.com> | ||
3 | Date: Thu, 3 May 2012 16:04:16 -0400 | ||
4 | Subject: [PATCH] arch/arm/boot/compressed: set default Asm architecture to armv7-a | ||
5 | |||
6 | This enables building compressed kernel with newer binutils-2.22 when kernel is | ||
7 | built in Thumb2 mode. Otherwise it fails with the following Assembler error: | ||
8 | |||
9 | | arch/arm/boot/compressed/head.S: Assembler messages: | ||
10 | | arch/arm/boot/compressed/head.S:127: Error: selected processor does not support requested special purpose register -- `mrs r2,cpsr' | ||
11 | | arch/arm/boot/compressed/head.S:134: Error: selected processor does not support requested special purpose register -- `mrs r2,cpsr' | ||
12 | | arch/arm/boot/compressed/head.S:136: Error: selected processor does not support requested special purpose register -- `msr cpsr_c,r2' | ||
13 | | make[2]: *** [arch/arm/boot/compressed/head.o] Error 1 | ||
14 | | make[1]: *** [arch/arm/boot/compressed/vmlinux] Error 2 | ||
15 | |||
16 | Signed-off-by: Denys Dmytriyenko <denys@ti.com> | ||
17 | --- | ||
18 | arch/arm/boot/compressed/Makefile | 2 +- | ||
19 | 1 files changed, 1 insertions(+), 1 deletions(-) | ||
20 | |||
21 | diff --git a/arch/arm/boot/compressed/Makefile b/arch/arm/boot/compressed/Makefile | ||
22 | index 21f56ff..e01d370 100644 | ||
23 | --- a/arch/arm/boot/compressed/Makefile | ||
24 | +++ b/arch/arm/boot/compressed/Makefile | ||
25 | @@ -123,7 +123,7 @@ KBUILD_CFLAGS = $(subst -pg, , $(ORIG_CFLAGS)) | ||
26 | endif | ||
27 | |||
28 | ccflags-y := -fpic -fno-builtin -I$(obj) | ||
29 | -asflags-y := -Wa,-march=all | ||
30 | +asflags-y := -Wa,-march=armv7-a | ||
31 | |||
32 | # Supply kernel BSS size to the decompressor via a linker symbol. | ||
33 | KBSS_SZ = $(shell size $(obj)/../../../../vmlinux | awk 'END{print $$3}') | ||
34 | -- | ||
35 | 1.7.8.5 | ||
36 | |||
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb index 63c0532d..d1dfaaf1 100644 --- a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb +++ b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb | |||
@@ -958,4 +958,5 @@ PATCHES_OVER_PSP = " \ | |||
958 | file://beaglebone/0031-beaglebone-fix-3.5-cape-support.patch \ | 958 | file://beaglebone/0031-beaglebone-fix-3.5-cape-support.patch \ |
959 | file://beaglebone/0032-beaglebone-connect-batterycape-GPIO-to-gpio-charger.patch \ | 959 | file://beaglebone/0032-beaglebone-connect-batterycape-GPIO-to-gpio-charger.patch \ |
960 | file://beaglebone/0033-beaglebone-add-support-for-CAN-and-RS232-cape.patch \ | 960 | file://beaglebone/0033-beaglebone-add-support-for-CAN-and-RS232-cape.patch \ |
961 | file://beaglebone/0001-arm-boot-compressed-default-asm-arch-to-armv7-a.patch \ | ||
961 | " | 962 | " |