summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/u-boot/0001-config-Always-use-GNU-ld.patch8
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch10
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.09.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.12.bb2
4 files changed, 11 insertions, 11 deletions
diff --git a/recipes-bsp/u-boot/u-boot/0001-config-Always-use-GNU-ld.patch b/recipes-bsp/u-boot/u-boot/0001-config-Always-use-GNU-ld.patch
index 2564d1d4..64685e39 100644
--- a/recipes-bsp/u-boot/u-boot/0001-config-Always-use-GNU-ld.patch
+++ b/recipes-bsp/u-boot/u-boot/0001-config-Always-use-GNU-ld.patch
@@ -1,4 +1,4 @@
1From dff01fc9346e6f4e3386536df309d2e78f03f3ee Mon Sep 17 00:00:00 2001 1From a8dc33253472328f2af04973575f26e9106db1c3 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 21 Dec 2011 08:53:02 -0800 3Date: Wed, 21 Dec 2011 08:53:02 -0800
4Subject: [PATCH] config: Always use GNU ld 4Subject: [PATCH] config: Always use GNU ld
@@ -20,14 +20,14 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
20 1 files changed, 3 insertions(+), 1 deletions(-) 20 1 files changed, 3 insertions(+), 1 deletions(-)
21 21
22diff --git a/config.mk b/config.mk 22diff --git a/config.mk b/config.mk
23index ddaa477..59b3e71 100644 23index ddaa477..139dfa0 100644
24--- a/config.mk 24--- a/config.mk
25+++ b/config.mk 25+++ b/config.mk
26@@ -126,11 +126,13 @@ cc-option = $(strip $(if $(findstring $1,$(CC_OPTIONS)),$1,\ 26@@ -126,11 +126,13 @@ cc-option = $(strip $(if $(findstring $1,$(CC_OPTIONS)),$1,\
27 $(if $(call cc-option-sys,$1),$1,$2))) 27 $(if $(call cc-option-sys,$1),$1,$2)))
28 endif 28 endif
29 29
30+exists_bfd_ld = $(shell if $(CROSS_COMPILE)ld.bfd -v >& /dev/null; \ 30+exists_bfd_ld = $(shell if $(CROSS_COMPILE)ld.bfd -v > /dev/null 2>&1; \
31+ then echo "$(1)"; else echo "$(2)"; fi; ) 31+ then echo "$(1)"; else echo "$(2)"; fi; )
32 # 32 #
33 # Include the make variables (CC, etc...) 33 # Include the make variables (CC, etc...)
@@ -39,5 +39,5 @@ index ddaa477..59b3e71 100644
39 CPP = $(CC) -E 39 CPP = $(CC) -E
40 AR = $(CROSS_COMPILE)ar 40 AR = $(CROSS_COMPILE)ar
41-- 41--
421.7.5.4 421.7.9.1
43 43
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch b/recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch
index 15f22b34..64685e39 100644
--- a/recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0007-config-Always-use-GNU-ld.patch
@@ -1,7 +1,7 @@
1From 06fe8be6b5c70853c0e3fac93d7bba9cb3d0292f Mon Sep 17 00:00:00 2001 1From a8dc33253472328f2af04973575f26e9106db1c3 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 21 Dec 2011 08:53:02 -0800 3Date: Wed, 21 Dec 2011 08:53:02 -0800
4Subject: [PATCH 07/10] config: Always use GNU ld 4Subject: [PATCH] config: Always use GNU ld
5 5
6This patch makes sure that we always use the GNU ld. u-boot uses certain 6This patch makes sure that we always use the GNU ld. u-boot uses certain
7construct e.g. OVERLAY which are not implemented in gold therefore it 7construct e.g. OVERLAY which are not implemented in gold therefore it
@@ -20,14 +20,14 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
20 1 files changed, 3 insertions(+), 1 deletions(-) 20 1 files changed, 3 insertions(+), 1 deletions(-)
21 21
22diff --git a/config.mk b/config.mk 22diff --git a/config.mk b/config.mk
23index ddaa477..59b3e71 100644 23index ddaa477..139dfa0 100644
24--- a/config.mk 24--- a/config.mk
25+++ b/config.mk 25+++ b/config.mk
26@@ -126,11 +126,13 @@ cc-option = $(strip $(if $(findstring $1,$(CC_OPTIONS)),$1,\ 26@@ -126,11 +126,13 @@ cc-option = $(strip $(if $(findstring $1,$(CC_OPTIONS)),$1,\
27 $(if $(call cc-option-sys,$1),$1,$2))) 27 $(if $(call cc-option-sys,$1),$1,$2)))
28 endif 28 endif
29 29
30+exists_bfd_ld = $(shell if $(CROSS_COMPILE)ld.bfd -v >& /dev/null; \ 30+exists_bfd_ld = $(shell if $(CROSS_COMPILE)ld.bfd -v > /dev/null 2>&1; \
31+ then echo "$(1)"; else echo "$(2)"; fi; ) 31+ then echo "$(1)"; else echo "$(2)"; fi; )
32 # 32 #
33 # Include the make variables (CC, etc...) 33 # Include the make variables (CC, etc...)
@@ -39,5 +39,5 @@ index ddaa477..59b3e71 100644
39 CPP = $(CC) -E 39 CPP = $(CC) -E
40 AR = $(CROSS_COMPILE)ar 40 AR = $(CROSS_COMPILE)ar
41-- 41--
421.7.2.5 421.7.9.1
43 43
diff --git a/recipes-bsp/u-boot/u-boot_2011.09.bb b/recipes-bsp/u-boot/u-boot_2011.09.bb
index 4a9d3cb1..b164c777 100644
--- a/recipes-bsp/u-boot/u-boot_2011.09.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.09.bb
@@ -1,6 +1,6 @@
1require u-boot.inc 1require u-boot.inc
2 2
3PR = "r6" 3PR = "r7"
4 4
5# SPL build 5# SPL build
6UBOOT_BINARY = "u-boot.img" 6UBOOT_BINARY = "u-boot.img"
diff --git a/recipes-bsp/u-boot/u-boot_2011.12.bb b/recipes-bsp/u-boot/u-boot_2011.12.bb
index 35ffd4b7..9bbd31e2 100644
--- a/recipes-bsp/u-boot/u-boot_2011.12.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.12.bb
@@ -6,7 +6,7 @@ UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img"
6UBOOT_SYMLINK = "u-boot-${MACHINE}.img" 6UBOOT_SYMLINK = "u-boot-${MACHINE}.img"
7 7
8PV = "2011.12" 8PV = "2011.12"
9PR = "r5" 9PR = "r6"
10 10
11# No patches for other machines yet 11# No patches for other machines yet
12COMPATIBLE_MACHINE = "(beagleboard|pandaboard|hawkboard|am3517-evm|am37x-evm|omap3evm)" 12COMPATIBLE_MACHINE = "(beagleboard|pandaboard|hawkboard|am3517-evm|am37x-evm|omap3evm)"