diff options
-rw-r--r-- | meta-ti-bsp/conf/machine/am62axx-evm-k3r5.conf | 11 | ||||
-rw-r--r-- | meta-ti-bsp/conf/machine/am62axx-evm.conf | 11 | ||||
-rw-r--r-- | meta-ti-bsp/conf/machine/include/am62axx.inc | 15 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb | 2 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | 1 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb | 2 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc | 1 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc | 2 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb | 65 |
9 files changed, 87 insertions, 23 deletions
diff --git a/meta-ti-bsp/conf/machine/am62axx-evm-k3r5.conf b/meta-ti-bsp/conf/machine/am62axx-evm-k3r5.conf new file mode 100644 index 00000000..ca30537f --- /dev/null +++ b/meta-ti-bsp/conf/machine/am62axx-evm-k3r5.conf | |||
@@ -0,0 +1,11 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: AM62AXX EVM (R5F) | ||
3 | #@DESCRIPTION: Machine configuration for the TI AM62Axx EVM (R5F core) | ||
4 | |||
5 | require conf/machine/include/k3r5.inc | ||
6 | |||
7 | SYSFW_SOC = "am62ax" | ||
8 | SYSFW_CONFIG = "evm" | ||
9 | SYSFW_SUFFIX = "gp" | ||
10 | |||
11 | UBOOT_MACHINE = "am62ax_evm_r5_defconfig" | ||
diff --git a/meta-ti-bsp/conf/machine/am62axx-evm.conf b/meta-ti-bsp/conf/machine/am62axx-evm.conf new file mode 100644 index 00000000..4eb179f3 --- /dev/null +++ b/meta-ti-bsp/conf/machine/am62axx-evm.conf | |||
@@ -0,0 +1,11 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: AM62AXX EVM | ||
3 | #@DESCRIPTION: Machine configuration for the TI AM62AXX EVM | ||
4 | |||
5 | require conf/machine/include/am62axx.inc | ||
6 | |||
7 | KERNEL_DEVICETREE = " \ | ||
8 | ti/k3-am62a7-sk.dtb \ | ||
9 | " | ||
10 | |||
11 | UBOOT_MACHINE = "am62ax_evm_a53_defconfig" | ||
diff --git a/meta-ti-bsp/conf/machine/include/am62axx.inc b/meta-ti-bsp/conf/machine/include/am62axx.inc new file mode 100644 index 00000000..cc477366 --- /dev/null +++ b/meta-ti-bsp/conf/machine/include/am62axx.inc | |||
@@ -0,0 +1,15 @@ | |||
1 | require conf/machine/include/k3.inc | ||
2 | SOC_FAMILY:append = ":am62axx" | ||
3 | |||
4 | MACHINE_FEATURES += "screen touchscreen" | ||
5 | |||
6 | SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS2" | ||
7 | SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" | ||
8 | |||
9 | TFA_K3_SYSTEM_SUSPEND = "1" | ||
10 | |||
11 | do_image_wic[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy" | ||
12 | do_image_tar[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy" | ||
13 | |||
14 | TFA_BOARD = "lite" | ||
15 | OPTEEMACHINE = "k3-am62x" | ||
diff --git a/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb b/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb index e7aa9ef4..2f75f4e3 100644 --- a/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb +++ b/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb | |||
@@ -13,7 +13,7 @@ PR = "${INC_PR}.1" | |||
13 | 13 | ||
14 | CLEANBROKEN = "1" | 14 | CLEANBROKEN = "1" |
15 | 15 | ||
16 | COMPATIBLE_MACHINE = "j721s2|j784s4" | 16 | COMPATIBLE_MACHINE = "j721s2|j784s4|am62axx" |
17 | 17 | ||
18 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 18 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
19 | 19 | ||
diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb index eb641270..37d022e9 100644 --- a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb +++ b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | |||
@@ -39,6 +39,7 @@ SYSFW_PREFIX:j784s4-evm-k3r5 = "fs" | |||
39 | SYSFW_PREFIX:j784s4-hs-evm-k3r5 = "fs" | 39 | SYSFW_PREFIX:j784s4-hs-evm-k3r5 = "fs" |
40 | SYSFW_PREFIX:am62xx-evm-k3r5 = "fs" | 40 | SYSFW_PREFIX:am62xx-evm-k3r5 = "fs" |
41 | SYSFW_PREFIX:am62xx-lp-evm-k3r5 = "fs" | 41 | SYSFW_PREFIX:am62xx-lp-evm-k3r5 = "fs" |
42 | SYSFW_PREFIX:am62axx-evm-k3r5 = "fs" | ||
42 | 43 | ||
43 | SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin" | 44 | SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin" |
44 | 45 | ||
diff --git a/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb b/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb index ce5f4e1f..2db761ba 100644 --- a/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb +++ b/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb | |||
@@ -7,7 +7,7 @@ PR = "${INC_PR}.0" | |||
7 | 7 | ||
8 | CLEANBROKEN = "1" | 8 | CLEANBROKEN = "1" |
9 | 9 | ||
10 | COMPATIBLE_MACHINE = "am62xx" | 10 | COMPATIBLE_MACHINE = "am62xx|am62axx" |
11 | 11 | ||
12 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 12 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
13 | 13 | ||
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc index 8c7bf9dd..1eca5c00 100644 --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc | |||
@@ -37,6 +37,7 @@ PACKAGECONFIG:append:j7200 = " dm" | |||
37 | PACKAGECONFIG:append:j721s2 = " dm" | 37 | PACKAGECONFIG:append:j721s2 = " dm" |
38 | PACKAGECONFIG:append:j784s4 = " dm" | 38 | PACKAGECONFIG:append:j784s4 = " dm" |
39 | PACKAGECONFIG:append:am62xx = " dm" | 39 | PACKAGECONFIG:append:am62xx = " dm" |
40 | PACKAGECONFIG:append:am62axx = " dm" | ||
40 | 41 | ||
41 | COMPATIBLE_MACHINE = "(ti-soc)" | 42 | COMPATIBLE_MACHINE = "(ti-soc)" |
42 | 43 | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc index 808a4766..69796915 100644 --- a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc +++ b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc | |||
@@ -30,6 +30,8 @@ RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721e = " vxd-dec-fw" | |||
30 | # Add run-time dependency for Chips&Media Wave521 firmware to the rootfs | 30 | # Add run-time dependency for Chips&Media Wave521 firmware to the rootfs |
31 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cnm-wave-fw" | 31 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cnm-wave-fw" |
32 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j784s4 = " cnm-wave-fw" | 32 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j784s4 = " cnm-wave-fw" |
33 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am62axx = " cnm-wave-fw" | ||
33 | 34 | ||
34 | # Add run-time dependency for TIFS Low Power Module stub | 35 | # Add run-time dependency for TIFS Low Power Module stub |
35 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am62xx = " tifs-lpm-stub" | 36 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am62xx = " tifs-lpm-stub" |
37 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am62axx = " tifs-lpm-stub" | ||
diff --git a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb index ddfa07be..9b94a61e 100644 --- a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb +++ b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb | |||
@@ -20,6 +20,7 @@ PLAT_SFX:j784s4 = "j784s4" | |||
20 | PLAT_SFX:am65xx = "am65xx" | 20 | PLAT_SFX:am65xx = "am65xx" |
21 | PLAT_SFX:am64xx = "am64xx" | 21 | PLAT_SFX:am64xx = "am64xx" |
22 | PLAT_SFX:am62xx = "am62xx" | 22 | PLAT_SFX:am62xx = "am62xx" |
23 | PLAT_SFX:am62axx = "am62axx" | ||
23 | 24 | ||
24 | FILESEXTRAPATHS:prepend := "${METATIBASE}/recipes-bsp/ti-sci-fw/files/:" | 25 | FILESEXTRAPATHS:prepend := "${METATIBASE}/recipes-bsp/ti-sci-fw/files/:" |
25 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc | 26 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc |
@@ -63,31 +64,34 @@ C7X_4_FW = "ipc_echo_test_c7x_4_release_strip.xe71" | |||
63 | ETH_FW = "app_remoteswitchcfg_server_strip.xer5f" | 64 | ETH_FW = "app_remoteswitchcfg_server_strip.xer5f" |
64 | 65 | ||
65 | DM_FW_LIST = "" | 66 | DM_FW_LIST = "" |
66 | DM_FW_LIST:am65xx = "" | 67 | DM_FW_LIST:am65xx = "" |
67 | DM_FW_LIST:j721e = "${DM_FIRMWARE}" | 68 | DM_FW_LIST:j721e = "${DM_FIRMWARE}" |
68 | DM_FW_LIST:j7200 = "${DM_FIRMWARE}" | 69 | DM_FW_LIST:j7200 = "${DM_FIRMWARE}" |
69 | DM_FW_LIST:j721s2 = "${DM_FIRMWARE}" | 70 | DM_FW_LIST:j721s2 = "${DM_FIRMWARE}" |
70 | DM_FW_LIST:am64xx = "" | 71 | DM_FW_LIST:am64xx = "" |
71 | DM_FW_LIST:am62xx = "${DM_FIRMWARE}" | 72 | DM_FW_LIST:am62xx = "${DM_FIRMWARE}" |
72 | DM_FW_LIST:j784s4 = "${DM_FIRMWARE}" | 73 | DM_FW_LIST:am62axx = "${DM_FIRMWARE}" |
74 | DM_FW_LIST:j784s4 = "${DM_FIRMWARE}" | ||
73 | 75 | ||
74 | IPC_FW_LIST = "" | 76 | IPC_FW_LIST = "" |
75 | IPC_FW_LIST:am65xx = "${MCU_1_0_FW} ${MCU_1_1_FW}" | 77 | IPC_FW_LIST:am65xx = "${MCU_1_0_FW} ${MCU_1_1_FW}" |
76 | IPC_FW_LIST:j721e = " ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_3_0_FW} ${MCU_3_1_FW} ${C66_1_FW} ${C66_2_FW} ${C7X_1_FW}" | 78 | IPC_FW_LIST:j721e = " ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_3_0_FW} ${MCU_3_1_FW} ${C66_1_FW} ${C66_2_FW} ${C7X_1_FW}" |
77 | IPC_FW_LIST:j7200 = " ${MCU_1_1_FW} ${MCU_2_0_FW} ${MCU_2_1_FW}" | 79 | IPC_FW_LIST:j7200 = " ${MCU_1_1_FW} ${MCU_2_0_FW} ${MCU_2_1_FW}" |
78 | IPC_FW_LIST:j721s2 = " ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_2_0_FW} ${MCU_3_1_FW} ${C7X_1_FW} ${C7X_2_FW}" | 80 | IPC_FW_LIST:j721s2 = " ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_2_0_FW} ${MCU_3_1_FW} ${C7X_1_FW} ${C7X_2_FW}" |
79 | IPC_FW_LIST:am64xx = "${MCU_1_0_FW} ${MCU_1_1_FW} ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_3_0_FW}" | 81 | IPC_FW_LIST:am64xx = "${MCU_1_0_FW} ${MCU_1_1_FW} ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_3_0_FW}" |
80 | IPC_FW_LIST:am62xx = " ${MCU_2_0_FW}" | 82 | IPC_FW_LIST:am62xx = " ${MCU_2_0_FW}" |
81 | IPC_FW_LIST:j784s4 = " ${MCU_1_1_FW} ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_3_0_FW} ${MCU_3_1_FW} ${C7X_1_FW} ${C7X_2_FW} ${C7X_3_FW} ${C7X_4_FW}" | 83 | IPC_FW_LIST:am62axx = " ${MCU_2_0_FW} ${C7X_1_FW}" |
84 | IPC_FW_LIST:j784s4 = " ${MCU_1_1_FW} ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_3_0_FW} ${MCU_3_1_FW} ${C7X_1_FW} ${C7X_2_FW} ${C7X_3_FW} ${C7X_4_FW}" | ||
82 | 85 | ||
83 | ETH_FW_LIST = "" | 86 | ETH_FW_LIST = "" |
84 | ETH_FW_LIST:am65xx = "" | 87 | ETH_FW_LIST:am65xx = "" |
85 | ETH_FW_LIST:j721e = "${ETH_FW}" | 88 | ETH_FW_LIST:j721e = "${ETH_FW}" |
86 | ETH_FW_LIST:j7200 = "${ETH_FW}" | 89 | ETH_FW_LIST:j7200 = "${ETH_FW}" |
87 | ETH_FW_LIST:j721s2 = "" | 90 | ETH_FW_LIST:j721s2 = "" |
88 | ETH_FW_LIST:am64xx = "" | 91 | ETH_FW_LIST:am64xx = "" |
89 | ETH_FW_LIST:am62xx = "" | 92 | ETH_FW_LIST:am62xx = "" |
90 | ETH_FW_LIST:j784s4 = "${ETH_FW}" | 93 | ETH_FW_LIST:am62axx = "" |
94 | ETH_FW_LIST:j784s4 = "${ETH_FW}" | ||
91 | 95 | ||
92 | # Update the am64xx ipc binaries to be consistent with other platforms | 96 | # Update the am64xx ipc binaries to be consistent with other platforms |
93 | do_install:prepend:am64xx() { | 97 | do_install:prepend:am64xx() { |
@@ -107,6 +111,13 @@ do_install:prepend:am62xx() { | |||
107 | ) | 111 | ) |
108 | } | 112 | } |
109 | 113 | ||
114 | # Update the am62axx ipc binaries to be consistent with other platforms | ||
115 | do_install:prepend:am62axx() { | ||
116 | ( cd ${RTOS_IPC_FW_DIR}; \ | ||
117 | ln -s am62a-mcu-r5f0_0-fw ${MCU_1_0_FW}; \ | ||
118 | ) | ||
119 | } | ||
120 | |||
110 | # Sign the firmware | 121 | # Sign the firmware |
111 | do_install:prepend() { | 122 | do_install:prepend() { |
112 | # DM Firmware | 123 | # DM Firmware |
@@ -183,6 +194,11 @@ ALTERNATIVE:${PN}:am62xx = "\ | |||
183 | am62-main-r5f0_0-fw \ | 194 | am62-main-r5f0_0-fw \ |
184 | " | 195 | " |
185 | 196 | ||
197 | ALTERNATIVE:${PN}:am62axx = "\ | ||
198 | am62a-mcu-r5f0_0-fw \ | ||
199 | am62a-c71_0-fw \ | ||
200 | " | ||
201 | |||
186 | ALTERNATIVE:${PN}:j721e = "\ | 202 | ALTERNATIVE:${PN}:j721e = "\ |
187 | j7-mcu-r5f0_0-fw \ | 203 | j7-mcu-r5f0_0-fw \ |
188 | j7-mcu-r5f0_1-fw \ | 204 | j7-mcu-r5f0_1-fw \ |
@@ -257,6 +273,9 @@ ALTERNATIVE_LINK_NAME[am64-mcu-m4f0_0-fw] = "${nonarch_base_libdir}/firmware/am6 | |||
257 | ALTERNATIVE_LINK_NAME[am62-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/am62-main-r5f0_0-fw" | 273 | ALTERNATIVE_LINK_NAME[am62-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/am62-main-r5f0_0-fw" |
258 | ALTERNATIVE_LINK_NAME[am62-mcu-m4f0_0-fw] = "${nonarch_base_libdir}/firmware/am62-mcu-m4f0_0-fw" | 274 | ALTERNATIVE_LINK_NAME[am62-mcu-m4f0_0-fw] = "${nonarch_base_libdir}/firmware/am62-mcu-m4f0_0-fw" |
259 | 275 | ||
276 | ALTERNATIVE_LINK_NAME[am62a-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/am62a-mcu-r5f0_0-fw" | ||
277 | ALTERNATIVE_LINK_NAME[am62a-c71_0-fw] = "${nonarch_base_libdir}/firmware/am62a-c71_0-fw" | ||
278 | |||
260 | ALTERNATIVE_LINK_NAME[j7-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/j7-mcu-r5f0_0-fw" | 279 | ALTERNATIVE_LINK_NAME[j7-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/j7-mcu-r5f0_0-fw" |
261 | ALTERNATIVE_LINK_NAME[j7-mcu-r5f0_1-fw] = "${nonarch_base_libdir}/firmware/j7-mcu-r5f0_1-fw" | 280 | ALTERNATIVE_LINK_NAME[j7-mcu-r5f0_1-fw] = "${nonarch_base_libdir}/firmware/j7-mcu-r5f0_1-fw" |
262 | ALTERNATIVE_LINK_NAME[j7-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/j7-main-r5f0_0-fw" | 281 | ALTERNATIVE_LINK_NAME[j7-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/j7-main-r5f0_0-fw" |
@@ -326,6 +345,10 @@ ALTERNATIVE_TARGET[am64-mcu-m4f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ip | |||
326 | ALTERNATIVE_TARGET[am62-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${DM_FIRMWARE}" | 345 | ALTERNATIVE_TARGET[am62-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${DM_FIRMWARE}" |
327 | ALTERNATIVE_TARGET[am62-mcu-m4f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${MCU_2_0_FW}" | 346 | ALTERNATIVE_TARGET[am62-mcu-m4f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${MCU_2_0_FW}" |
328 | 347 | ||
348 | ALTERNATIVE_TARGET[am62a-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${DM_FIRMWARE}" | ||
349 | ALTERNATIVE_TARGET[am62a-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${MCU_2_0_FW}" | ||
350 | ALTERNATIVE_TARGET[am62a-c71_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${C7X_1_FW}" | ||
351 | |||
329 | ALTERNATIVE_TARGET[j7-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${DM_FIRMWARE}" | 352 | ALTERNATIVE_TARGET[j7-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${DM_FIRMWARE}" |
330 | ALTERNATIVE_TARGET[j7-mcu-r5f0_1-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${MCU_1_1_FW}" | 353 | ALTERNATIVE_TARGET[j7-mcu-r5f0_1-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${MCU_1_1_FW}" |
331 | ALTERNATIVE_TARGET[j7-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/ethfw/${ETH_FW}" | 354 | ALTERNATIVE_TARGET[j7-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/ethfw/${ETH_FW}" |