diff options
-rw-r--r-- | recipes-ti/devtools/gcc-linaro-baremetal-aarch64-native.bb | 23 | ||||
-rw-r--r-- | recipes-ti/devtools/gcc-linaro-baremetal-native.bb | 23 | ||||
-rw-r--r-- | recipes-ti/devtools/gcc-linaro.inc | 10 | ||||
-rw-r--r-- | recipes-ti/includes/ti-paths.inc | 5 |
4 files changed, 61 insertions, 0 deletions
diff --git a/recipes-ti/devtools/gcc-linaro-baremetal-aarch64-native.bb b/recipes-ti/devtools/gcc-linaro-baremetal-aarch64-native.bb new file mode 100644 index 00000000..97344f90 --- /dev/null +++ b/recipes-ti/devtools/gcc-linaro-baremetal-aarch64-native.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | include recipes-ti/devtools/gcc-linaro.inc | ||
2 | |||
3 | PACKAGE_DIR = "gcc-linaro-${PV}-${GCC_ARM_YEAR}-x86_64_aarch64-elf" | ||
4 | S = "${WORKDIR}/${PACKAGE_DIR}" | ||
5 | |||
6 | LIC_CHKSUM = "bc7fad4bba98e7a4cd5ab3042506493c" | ||
7 | |||
8 | inherit native | ||
9 | require recipes-ti/includes/ti-paths.inc | ||
10 | |||
11 | SRC_URI = "https://releases.linaro.org/components/toolchain/binaries/7.2-${GCC_ARM_YEAR}/aarch64-elf/gcc-linaro-${PV}-${GCC_ARM_YEAR}-x86_64_aarch64-elf.tar.xz;name=gcc-linaro-aarch64" | ||
12 | |||
13 | SRC_URI[gcc-linaro-aarch64.md5sum] = "4972f8943820bdd2f577f498de78964b" | ||
14 | SRC_URI[gcc-linaro-aarch64.sha256sum] = "30fb7d876bcb982c502057c593d9c1f11b35d5158a26d986718e2b998388c4c8" | ||
15 | |||
16 | do_install() { | ||
17 | install -d ${D}${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE} | ||
18 | cp -r ${S}/. ${D}${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE} | ||
19 | } | ||
20 | |||
21 | FILES_${PN} = "${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE}/*" | ||
22 | |||
23 | INSANE_SKIP_${PN} = "already-stripped" | ||
diff --git a/recipes-ti/devtools/gcc-linaro-baremetal-native.bb b/recipes-ti/devtools/gcc-linaro-baremetal-native.bb new file mode 100644 index 00000000..0268ae3d --- /dev/null +++ b/recipes-ti/devtools/gcc-linaro-baremetal-native.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | include recipes-ti/devtools/gcc-linaro.inc | ||
2 | |||
3 | PACKAGE_DIR = "gcc-linaro-${PV}-${GCC_ARM_YEAR}-x86_64_arm-eabi" | ||
4 | S = "${WORKDIR}/${PACKAGE_DIR}" | ||
5 | |||
6 | LIC_CHKSUM = "bc7fad4bba98e7a4cd5ab3042506493c" | ||
7 | |||
8 | inherit native | ||
9 | require recipes-ti/includes/ti-paths.inc | ||
10 | |||
11 | SRC_URI = "https://releases.linaro.org/components/toolchain/binaries/7.2-${GCC_ARM_YEAR}/arm-eabi/gcc-linaro-${PV}-${GCC_ARM_YEAR}-x86_64_arm-eabi.tar.xz;name=gcc-linaro" | ||
12 | |||
13 | SRC_URI[gcc-linaro.md5sum] = "9a4a39cfc78c84375b1160aa93587aed" | ||
14 | SRC_URI[gcc-linaro.sha256sum] = "45fc4f90af2e2e9c3197a275f6005ef5639f7a1889fa3eb24c3125ccd70fcd3d" | ||
15 | |||
16 | do_install() { | ||
17 | install -d ${D}${GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE} | ||
18 | cp -r ${S}/. ${D}${GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE} | ||
19 | } | ||
20 | |||
21 | FILES_${PN} = "${GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE}/*" | ||
22 | |||
23 | INSANE_SKIP_${PN} = "already-stripped" | ||
diff --git a/recipes-ti/devtools/gcc-linaro.inc b/recipes-ti/devtools/gcc-linaro.inc new file mode 100644 index 00000000..19f5a2cf --- /dev/null +++ b/recipes-ti/devtools/gcc-linaro.inc | |||
@@ -0,0 +1,10 @@ | |||
1 | DESCRIPTION = "Linaro GCC for ARM" | ||
2 | HOMEPAGE = "https://launchpad.net/gcc-arm-embedded" | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "GPL-3.0-with-GCC-exception & GPLv3" | ||
5 | LIC_FILES_CHKSUM = "file://share/doc/gcc/GNU-Free-Documentation-License.html;md5=${LIC_CHKSUM}" | ||
6 | |||
7 | PV = "7.2.1" | ||
8 | PR = "r0" | ||
9 | |||
10 | GCC_ARM_YEAR = "2017.11" | ||
diff --git a/recipes-ti/includes/ti-paths.inc b/recipes-ti/includes/ti-paths.inc index 4f99d5ef..a401264a 100644 --- a/recipes-ti/includes/ti-paths.inc +++ b/recipes-ti/includes/ti-paths.inc | |||
@@ -56,6 +56,8 @@ export CG_XML_INSTALL_DIR_RECIPE = "${installdir}/ti-cg-xml-tree" | |||
56 | export OMP_INSTALL_DIR_RECIPE = "${installdir}/ti-omp-tree" | 56 | export OMP_INSTALL_DIR_RECIPE = "${installdir}/ti-omp-tree" |
57 | export MPM_INSTALL_DIR_RECIPE = "${installdir}/ti-mpm-tree" | 57 | export MPM_INSTALL_DIR_RECIPE = "${installdir}/ti-mpm-tree" |
58 | export TI_CGT6X_7_INSTALL_DIR_RECIPE = "${installdir}/cgt6x-7" | 58 | export TI_CGT6X_7_INSTALL_DIR_RECIPE = "${installdir}/cgt6x-7" |
59 | export GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE = "${installdir}/gcc-linaro-baremetal" | ||
60 | export GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE = "${installdir}/gcc-linaro-baremetal-aarch64" | ||
59 | 61 | ||
60 | # This is where the tools will end up in sysroot | 62 | # This is where the tools will end up in sysroot |
61 | export BIOS_INSTALL_DIR = "${STAGING_DIR_TARGET}${BIOS_INSTALL_DIR_RECIPE}" | 63 | export BIOS_INSTALL_DIR = "${STAGING_DIR_TARGET}${BIOS_INSTALL_DIR_RECIPE}" |
@@ -103,6 +105,9 @@ export CG_XML_INSTALL_DIR = "${STAGING_DIR_NATIVE}${CG_XML_INSTALL_DIR_RECIP | |||
103 | export OMP_INSTALL_DIR = "${STAGING_DIR_TARGET}${OMP_INSTALL_DIR_RECIPE}" | 105 | export OMP_INSTALL_DIR = "${STAGING_DIR_TARGET}${OMP_INSTALL_DIR_RECIPE}" |
104 | export MPM_INSTALL_DIR = "${STAGING_DIR_TARGET}${MPM_INSTALL_DIR_RECIPE}" | 106 | export MPM_INSTALL_DIR = "${STAGING_DIR_TARGET}${MPM_INSTALL_DIR_RECIPE}" |
105 | export TI_CGT6X_7_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT6X_7_INSTALL_DIR_RECIPE}" | 107 | export TI_CGT6X_7_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT6X_7_INSTALL_DIR_RECIPE}" |
108 | export GCC_LINARO_BAREMETAL_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE}" | ||
109 | export GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE}" | ||
110 | |||
106 | 111 | ||
107 | DSPSUFFIX_omapl137 = "x674" | 112 | DSPSUFFIX_omapl137 = "x674" |
108 | DSPSUFFIX_omapl138 = "x674" | 113 | DSPSUFFIX_omapl138 = "x674" |